# Infinite plugin restart

**URL:** <https://discuss.elastic.co/t/infinite-plugin-restart/117474>\
**Category:** Logstash\
**Created:** [January 29, 2018, 2:17pm UTC](https://discuss.elastic.co/t/infinite-plugin-restart/117474 "2018-01-29T14:17:02Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![puneetbaijal](https://avatars.discourse-cdn.com/v4/letter/p/aca169/32.png) [@puneetbaijal](https://discuss.elastic.co/u/puneetbaijal)\
**Post date:** [January 29, 2018, 2:17pm UTC](https://discuss.elastic.co/t/infinite-plugin-restart/117474/1 "2018-01-29T14:17:02Z")

</div>

Hi,  
I'm using Logstash 6.1 with the JDBC input plugin after upgrading from 5.2, and noticed a new behavior that was not there earlier.

Earlier when Logstash was not able to connect to the database or ran into an SQL error, it would terminate - which was fine for my use case, but with version 6.1 after the error it just attempts to restart the plugin with the errors:

```
Unable to connect to database. Tried 1 times {:error_message=>"Java::JavaSql::SQLRecoverableException: ORA-01033: ORACLE initialization or shutdown in progress\n"}
[ERROR][logstash.pipeline] A plugin had an unrecoverable error. Will restart this plugin.

```

I tried searching for options but can't figure out if there is a way to limit the number of retries so that logstash terminates in case of such errors.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 26, 2018, 2:17pm UTC](https://discuss.elastic.co/t/infinite-plugin-restart/117474/2 "2018-02-26T14:17:04Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
