# INFO Error publishing events

**URL:** <https://discuss.elastic.co/t/info-error-publishing-events/88521>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [June 7, 2017, 7:26am UTC](https://discuss.elastic.co/t/info-error-publishing-events/88521 "2017-06-07T07:26:26Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![AadarshKumayan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/aadarshkumayan/32/18790_2.png) [@AadarshKumayan](https://discuss.elastic.co/u/AadarshKumayan)\
**Post date:** [June 7, 2017, 7:26am UTC](https://discuss.elastic.co/t/info-error-publishing-events/88521/1 "2017-06-07T07:26:26Z")

</div>

Hi i have set up elk on centos machine  
my client is a ubuntu machine  
all the service are running but when i try to send logs to my elk server filebeat log reports error

```
INFO Error publishing events (retrying): read tcp clientip->hostip read: connection reset by peer

```

version -  
elastic search-5.4  
logstash-5.4  
kibana -5.4  
filebeat - 5.4

---

<div class="post-metadata">

**Author:** ![exekias](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/exekias/32/28718_2.png) [@exekias](https://discuss.elastic.co/u/exekias)\
**Post date:** [June 12, 2017, 8:54am UTC](https://discuss.elastic.co/t/info-error-publishing-events/88521/2 "2017-06-12T08:54:54Z")

</div>

Can you dump your conf files here? at least for filebeat.

The error explains that it couldn't connect to elasticsearch, it should be running in [http://localhost:9200](http://localhost:9200) by default, can you check it's working first?

---

<div class="post-metadata">

**Author:** ![AadarshKumayan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/aadarshkumayan/32/18790_2.png) [@AadarshKumayan](https://discuss.elastic.co/u/AadarshKumayan)\
**Post date:** [June 15, 2017, 5:33am UTC](https://discuss.elastic.co/t/info-error-publishing-events/88521/3 "2017-06-15T05:33:53Z")

</div>

the problem was resolved actually the new version of elk and filebeat don't support tls ,instead tls certificates are now defined in ssl certificate section  
thank for the help elk team

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 13, 2017, 5:33am UTC](https://discuss.elastic.co/t/info-error-publishing-events/88521/4 "2017-07-13T05:33:55Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
