# Initial Configuration

**URL:** <https://discuss.elastic.co/t/initial-configuration/93653>\
**Category:** Beats\
**Tags:** winlogbeat\
**Created:** [July 18, 2017, 6:40pm UTC](https://discuss.elastic.co/t/initial-configuration/93653 "2017-07-18T18:40:32Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![viralblack](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/viralblack/32/20193_2.png) [@viralblack](https://discuss.elastic.co/u/viralblack)\
**Post date:** [July 18, 2017, 6:40pm UTC](https://discuss.elastic.co/t/initial-configuration/93653/1 "2017-07-18T18:40:32Z")

</div>

Well, everything else seems to be configured correctly from what I can tell. Now this is repeating in the winlogbeat log

2017-07-18T14:38:21-04:00 ERR Failed to publish events caused by: EOF  
2017-07-18T14:38:21-04:00 INFO Error publishing events (retrying): EOF  
2017-07-18T14:38:41-04:00 INFO Non-zero metrics in the last 30s: libbeat.logstash.call\_count.PublishEvents=1 libbeat.logstash.publish.read\_errors=1 libbeat.logstash.publish.write\_bytes=677 libbeat.logstash.published\_but\_not\_acked\_events=100 uptime={"server\_time":"2017-07-18T18:38:41.7852489Z","start\_time":"2017-07-18T18:28:41.7216539Z","uptime":"10m0.063595s","uptime\_ms":"600063595"}  
2017-07-18T14:39:11-04:00 INFO Non-zero metrics in the last 30s: uptime={"server\_time":"2017-07-18T18:39:11.7846738Z","start\_time":"2017-07-18T18:28:41.7216539Z","uptime":"10m30.0630199s","uptime\_ms":"630063019"}

Ideas? Theres nothing else filtering traffic between the winlogbeat location and the CentOS 7 installation of ELK

---

<div class="post-metadata">

**Author:** ![viralblack](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/viralblack/32/20193_2.png) [@viralblack](https://discuss.elastic.co/u/viralblack)\
**Post date:** [July 18, 2017, 7:00pm UTC](https://discuss.elastic.co/t/initial-configuration/93653/2 "2017-07-18T19:00:41Z")

</div>

Well, progress made, discovered the stack is misconfigured internally, just trying to find the right configuration file now. when I tail logstash.log I get the following.

{:timestamp=\>"2017-07-18T11:58:15.016000-0700", :message=\>"Attempted to send a bulk request to Elasticsearch configured at '["[http://localhost:9200/](http://localhost:9200/)"]', but Elasticsearch appears to be unreachable or down!", :error\_message=\>"Connection refused (Connection refused)", :class=\>"Manticore::SocketException", :client\_config=\>{:hosts=\>["[http://localhost:9200/](http://localhost:9200/)"], :ssl=\>nil, :transport\_options=\>{:socket\_timeout=\>0, :request\_timeout=\>0, :proxy=\>nil, :ssl=\>{}}, :transport\_class=\>Elasticsearch::Transport::Transport::HTTP::Manticore, :logger=\>nil, :tracer=\>nil, :reload\_connections=\>false, :retry\_on\_failure=\>false, :reload\_on\_failure=\>false, :randomize\_hosts=\>false}, :level=\>:error}  
{:timestamp=\>"2017-07-18T11:58:15.035000-0700", :message=\>"Attempted to send a bulk request to Elasticsearch configured at '["[http://localhost:9200/](http://localhost:9200/)"]', but Elasticsearch appears to be unreachable or down!", :error\_message=\>"Connection refused (Connection refused)", :class=\>"Manticore::SocketException", :client\_config=\>{:hosts=\>["[http://localhost:9200/](http://localhost:9200/)"], :ssl=\>nil, :transport\_options=\>{:socket\_timeout=\>0, :request\_timeout=\>0, :proxy=\>nil, :ssl=\>{}}, :transport\_class=\>Elasticsearch::Transport::Transport::HTTP::Manticore, :logger=\>nil, :tracer=\>nil, :reload\_connections=\>false, :retry\_on\_failure=\>false, :reload\_on\_failure=\>false, :randomize\_hosts=\>false}, :level=\>:error}  
{:timestamp=\>"2017-07-18T11:58:15.036000-0700", :message=\>"Attempted to send a bulk request to Elasticsearch configured at '["[http://localhost:9200/](http://localhost:9200/)"]', but Elasticsearch appears to be unreachable or down!", :error\_message=\>"Connection refused (Connection refused)", :class=\>"Manticore::SocketException", :client\_config=\>{:hosts=\>["[http://localhost:9200/](http://localhost:9200/)"], :ssl=\>nil, :transport\_options=\>{:socket\_timeout=\>0, :request\_timeout=\>0, :proxy=\>nil, :ssl=\>{}}, :transport\_class=\>Elasticsearch::Transport::Transport::HTTP::Manticore, :logger=\>nil, :tracer=\>nil, :reload\_connections=\>false, :retry\_on\_failure=\>false, :reload\_on\_failure=\>false, :randomize\_hosts=\>false}, :level=\>:error}

localhost needs to be swapped to an IP address, changed the .conf for input and outut in /etc/logstash/conf.d, still looking for where else it might be wrong

---

<div class="post-metadata">

**Author:** ![steffens](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/steffens/32/79630_2.png) [@steffens](https://discuss.elastic.co/u/steffens)\
**Post date:** [July 18, 2017, 11:21pm UTC](https://discuss.elastic.co/t/initial-configuration/93653/3 "2017-07-18T23:21:55Z")

</div>

Is Elasticsearch running on same host as logstash? If not, check your Elasticsearch configuration for not binding to localhost only.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 15, 2017, 11:22pm UTC](https://discuss.elastic.co/t/initial-configuration/93653/4 "2017-08-15T23:22:10Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
