# Initial recovery failing "Unknown alias name was passed to alias Filter"

**URL:** <https://discuss.elastic.co/t/initial-recovery-failing-unknown-alias-name-was-passed-to-alias-filter/5041>\
**Category:** Elasticsearch\
**Created:** [August 3, 2011, 7:58am UTC](https://discuss.elastic.co/t/initial-recovery-failing-unknown-alias-name-was-passed-to-alias-filter/5041 "2011-08-03T07:58:44Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![Pierre\_Baillet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/pierre_baillet/32/3154_2.png) [@Pierre\_Baillet](https://discuss.elastic.co/u/Pierre_Baillet)\
**Post date:** [August 3, 2011, 7:58am UTC](https://discuss.elastic.co/t/initial-recovery-failing-unknown-alias-name-was-passed-to-alias-filter/5041/1 "2011-08-03T07:58:44Z")

</div>

Hello,

I'm playing with all ES clustering feature right now as we intend to deploy the search engine sometimes soon. I'm using unicast discovery to configure my cluster nodes with some Chef help (currently I have 2 nodes). In the gateway settings, I'm also setting that gateway.expected\_nodes = 2. That's pretty much the only configuration I'm doing. I'm also boostrap.mlockall'ing the memory.

I've managed to start the whole cluster from an empty database and reindex my date inside correctly without any issue. Works as advertised. I then tried to shut down one of the node, delete its data and start it again.

After some time, it fails starting with a never-ending error[1]. I've not yet setup a shared gateway as I thought this was only there to speed up the recovery (and ensure indices are stored safely in S3 for example) but I wonder it the issue I see here is related ?

## Any hint ? Cheers,

Pierre Baillet  
Server Shepherd @ [http://www.fotopedia.com](http://www.fotopedia.com)

1: 2011-08-03\_07:37:45.37053 [2011-08-03 07:37:45,368][WARN][indices.cluster] [Sluggo] [picor][0] failed to start shard  
2011-08-03\_07:37:45.37057 org.elasticsearch.index.shard.recovery.RecoveryFailedException: Index Shard [picor][0]: Recovery failed from [Reilly, Ben][1OvwxQYOSiCherwlLvReOQ][inet[/------:9300]] into [Sluggo][NrNDzEgkQQaB1HKvMqa16g][inet[/------:9300]]  
2011-08-03\_07:37:45.37058 at org.elasticsearch.index.shard.recovery.RecoveryTarget.doRecovery(RecoveryTarget.java:243)  
2011-08-03\_07:37:45.37061 at org.elasticsearch.index.shard.recovery.RecoveryTarget.access$100(RecoveryTarget.java:61)  
2011-08-03\_07:37:45.37064 at org.elasticsearch.index.shard.recovery.RecoveryTarget$2.run(RecoveryTarget.java:146)  
2011-08-03\_07:37:45.37065 at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)  
2011-08-03\_07:37:45.37065 at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)  
2011-08-03\_07:37:45.37066 at java.lang.Thread.run(Thread.java:636)  
2011-08-03\_07:37:45.37066 Caused by: org.elasticsearch.transport.RemoteTransportException: [Reilly, Ben][inet[/10.203.38.176:9300]][index/shard/recovery/startRecovery]  
2011-08-03\_07:37:45.37067 Caused by: org.elasticsearch.index.engine.RecoveryEngineException: [picor][0] Phase[2] Execution failed  
2011-08-03\_07:37:45.37069 at org.elasticsearch.index.engine.robin.RobinEngine.recover(RobinEngine.java:1030)  
2011-08-03\_07:37:45.37070 at org.elasticsearch.index.shard.service.InternalIndexShard.recover(InternalIndexShard.java:420)  
2011-08-03\_07:37:45.37070 at org.elasticsearch.index.shard.recovery.RecoverySource.recover(RecoverySource.java:110)  
2011-08-03\_07:37:45.37071 at org.elasticsearch.index.shard.recovery.RecoverySource.access$1600(RecoverySource.java:60)  
2011-08-03\_07:37:45.37071 at org.elasticsearch.index.shard.recovery.RecoverySource$StartRecoveryTransportRequestHandler.messageReceived(RecoverySource.java:296)  
2011-08-03\_07:37:45.37074 at org.elasticsearch.index.shard.recovery.RecoverySource$StartRecoveryTransportRequestHandler.messageReceived(RecoverySource.java:285)  
2011-08-03\_07:37:45.37075 at org.elasticsearch.transport.netty.MessageChannelHandler$RequestHandler.run(MessageChannelHandler.java:238)  
2011-08-03\_07:37:45.37075 at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)  
2011-08-03\_07:37:45.37076 at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)  
2011-08-03\_07:37:45.37077 at java.lang.Thread.run(Thread.java:636)  
2011-08-03\_07:37:45.37077 Caused by: org.elasticsearch.transport.RemoteTransportException: [Sluggo][inet[/10.83.58.138:9300]][index/shard/recovery/translogOps]  
2011-08-03\_07:37:45.37079 Caused by: org.elasticsearch.indices.InvalidAliasNameException: [picor] Invalid alias name [users], Unknown alias name was passed to alias Filter  
2011-08-03\_07:37:45.37080 at org.elasticsearch.index.aliases.IndexAliasesService.aliasFilter(IndexAliasesService.java:87)  
2011-08-03\_07:37:45.37080 at org.elasticsearch.index.shard.service.InternalIndexShard.innerDeleteByQuery(InternalIndexShard.java:337)  
2011-08-03\_07:37:45.37081 at org.elasticsearch.index.shard.service.InternalIndexShard.performRecoveryOperation(InternalIndexShard.java:516)  
2011-08-03\_07:37:45.37082 at org.elasticsearch.index.shard.recovery.RecoveryTarget$TranslogOperationsRequestHandler.messageReceived(RecoveryTarget.java:340)  
2011-08-03\_07:37:45.37082 at org.elasticsearch.index.shard.recovery.RecoveryTarget$TranslogOperationsRequestHandler.messageReceived(RecoveryTarget.java:326)  
2011-08-03\_07:37:45.37083 at org.elasticsearch.transport.netty.MessageChannelHandler$RequestHandler.run(MessageChannelHandler.java:238)  
2011-08-03\_07:37:45.37084 at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)  
2011-08-03\_07:37:45.37085 at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)  
2011-08-03\_07:37:45.37086 at java.lang.Thread.run(Thread.java:636)

---

<div class="post-metadata">

**Author:** ![kimchy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kimchy/32/44952_2.png) [@kimchy](https://discuss.elastic.co/u/kimchy)\
**Post date:** [August 3, 2011, 8:32am UTC](https://discuss.elastic.co/t/initial-recovery-failing-unknown-alias-name-was-passed-to-alias-filter/5041/2 "2011-08-03T08:32:05Z")

</div>

I can see where the problem is coming from, opened a bug:  
[Delete By Query wrongly persisted to translog · Issue #1198 · elastic/elasticsearch · GitHub](https://github.com/elasticsearch/elasticsearch/issues/1198).

On Wed, Aug 3, 2011 at 10:58 AM, Pierre Baillet [oct@fotopedia.com](mailto:oct@fotopedia.com) wrote:

> Hello,
> 
> I'm playing with all ES clustering feature right now as we intend to deploy  
> the search engine sometimes soon. I'm using unicast discovery to configure  
> my cluster nodes with some Chef help (currently I have 2 nodes). In the  
> gateway settings, I'm also setting that gateway.expected\_nodes = 2. That's  
> pretty much the only configuration I'm doing. I'm also boostrap.mlockall'ing  
> the memory.
> 
> I've managed to start the whole cluster from an empty database and reindex  
> my date inside correctly without any issue. Works as advertised. I then  
> tried to shut down one of the node, delete its data and start it again.
> 
> After some time, it fails starting with a never-ending error[1]. I've not  
> yet setup a shared gateway as I thought this was only there to speed up the  
> recovery (and ensure indices are stored safely in S3 for example) but I  
> wonder it the issue I see here is related ?
> 
> ## Any hint ? Cheers,
> 
> Pierre Baillet  
> Server Shepherd @ [http://www.fotopedia.com](http://www.fotopedia.com)
> 
> 1: 2011-08-03\_07:37:45.37053 [2011-08-03 07:37:45,368][WARN  
> ][indices.cluster] [Sluggo] [picor][0] failed to start shard  
> 2011-08-03\_07:37:45.37057  
> org.elasticsearch.index.shard.recovery.RecoveryFailedException: Index Shard  
> [picor][0]: Recovery failed from [Reilly,  
> Ben][1OvwxQYOSiCherwlLvReOQ][inet[/------:9300]] into  
> [Sluggo][NrNDzEgkQQaB1HKvMqa16g][inet[/------:9300]]  
> 2011-08-03\_07:37:45.37058 at  
> org.elasticsearch.index.shard.recovery.RecoveryTarget.doRecovery(RecoveryTarget.java:243)  
> 2011-08-03\_07:37:45.37061 at  
> org.elasticsearch.index.shard.recovery.RecoveryTarget.access$100(RecoveryTarget.java:61)  
> 2011-08-03\_07:37:45.37064 at  
> org.elasticsearch.index.shard.recovery.RecoveryTarget$2.run(RecoveryTarget.java:146)  
> 2011-08-03\_07:37:45.37065 at  
> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)  
> 2011-08-03\_07:37:45.37065 at  
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)  
> 2011-08-03\_07:37:45.37066 at java.lang.Thread.run(Thread.java:636)  
> 2011-08-03\_07:37:45.37066 Caused by:  
> org.elasticsearch.transport.RemoteTransportException: [Reilly,  
> Ben][inet[/10.203.38.176:9300]][index/shard/recovery/startRecovery]  
> 2011-08-03\_07:37:45.37067 Caused by:  
> org.elasticsearch.index.engine.RecoveryEngineException: [picor][0] Phase[2]  
> Execution failed  
> 2011-08-03\_07:37:45.37069 at  
> org.elasticsearch.index.engine.robin.RobinEngine.recover(RobinEngine.java:1030)  
> 2011-08-03\_07:37:45.37070 at  
> org.elasticsearch.index.shard.service.InternalIndexShard.recover(InternalIndexShard.java:420)  
> 2011-08-03\_07:37:45.37070 at  
> org.elasticsearch.index.shard.recovery.RecoverySource.recover(RecoverySource.java:110)  
> 2011-08-03\_07:37:45.37071 at  
> org.elasticsearch.index.shard.recovery.RecoverySource.access$1600(RecoverySource.java:60)  
> 2011-08-03\_07:37:45.37071 at  
> org.elasticsearch.index.shard.recovery.RecoverySource$StartRecoveryTransportRequestHandler.messageReceived(RecoverySource.java:296)  
> 2011-08-03\_07:37:45.37074 at  
> org.elasticsearch.index.shard.recovery.RecoverySource$StartRecoveryTransportRequestHandler.messageReceived(RecoverySource.java:285)  
> 2011-08-03\_07:37:45.37075 at  
> org.elasticsearch.transport.netty.MessageChannelHandler$RequestHandler.run(MessageChannelHandler.java:238)  
> 2011-08-03\_07:37:45.37075 at  
> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)  
> 2011-08-03\_07:37:45.37076 at  
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)  
> 2011-08-03\_07:37:45.37077 at java.lang.Thread.run(Thread.java:636)  
> 2011-08-03\_07:37:45.37077 Caused by:  
> org.elasticsearch.transport.RemoteTransportException:  
> [Sluggo][inet[/10.83.58.138:9300]][index/shard/recovery/translogOps]  
> 2011-08-03\_07:37:45.37079 Caused by:  
> org.elasticsearch.indices.InvalidAliasNameException: [picor] Invalid alias  
> name [users], Unknown alias name was passed to alias Filter  
> 2011-08-03\_07:37:45.37080 at  
> org.elasticsearch.index.aliases.IndexAliasesService.aliasFilter(IndexAliasesService.java:87)  
> 2011-08-03\_07:37:45.37080 at  
> org.elasticsearch.index.shard.service.InternalIndexShard.innerDeleteByQuery(InternalIndexShard.java:337)  
> 2011-08-03\_07:37:45.37081 at  
> org.elasticsearch.index.shard.service.InternalIndexShard.performRecoveryOperation(InternalIndexShard.java:516)  
> 2011-08-03\_07:37:45.37082 at  
> org.elasticsearch.index.shard.recovery.RecoveryTarget$TranslogOperationsRequestHandler.messageReceived(RecoveryTarget.java:340)  
> 2011-08-03\_07:37:45.37082 at  
> org.elasticsearch.index.shard.recovery.RecoveryTarget$TranslogOperationsRequestHandler.messageReceived(RecoveryTarget.java:326)  
> 2011-08-03\_07:37:45.37083 at  
> org.elasticsearch.transport.netty.MessageChannelHandler$RequestHandler.run(MessageChannelHandler.java:238)  
> 2011-08-03\_07:37:45.37084 at  
> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)  
> 2011-08-03\_07:37:45.37085 at  
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)  
> 2011-08-03\_07:37:45.37086 at java.lang.Thread.run(Thread.java:636)

---

<div class="post-metadata">

**Author:** ![Pierre\_Baillet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/pierre_baillet/32/3154_2.png) [@Pierre\_Baillet](https://discuss.elastic.co/u/Pierre_Baillet)\
**Post date:** [August 3, 2011, 8:35am UTC](https://discuss.elastic.co/t/initial-recovery-failing-unknown-alias-name-was-passed-to-alias-filter/5041/3 "2011-08-03T08:35:37Z")

</div>

Great, thanks for the faster-than-anything fix 🙂

--  
Pierre Baillet  
Server Shepherd @ [http://www.fotopedia.com](http://www.fotopedia.com)

Le mercredi 3 août 2011 à 10:32, Shay Banon a écrit :

> I can see where the problem is coming from, opened a bug: [Delete By Query wrongly persisted to translog · Issue #1198 · elastic/elasticsearch · GitHub](https://github.com/elasticsearch/elasticsearch/issues/1198).
> 
> On Wed, Aug 3, 2011 at 10:58 AM, Pierre Baillet \<[oct@fotopedia.com](mailto:oct@fotopedia.com) ([mailto:oct@fotopedia.com](mailto:oct@fotopedia.com))\> wrote:
> 
> > Hello,
> > 
> > I'm playing with all ES clustering feature right now as we intend to deploy the search engine sometimes soon. I'm using unicast discovery to configure my cluster nodes with some Chef help (currently I have 2 nodes). In the gateway settings, I'm also setting that gateway.expected\_nodes = 2. That's pretty much the only configuration I'm doing. I'm also boostrap.mlockall'ing the memory.
> > 
> > I've managed to start the whole cluster from an empty database and reindex my date inside correctly without any issue. Works as advertised. I then tried to shut down one of the node, delete its data and start it again.
> > 
> > After some time, it fails starting with a never-ending error[1]. I've not yet setup a shared gateway as I thought this was only there to speed up the recovery (and ensure indices are stored safely in S3 for example) but I wonder it the issue I see here is related ?
> > 
> > ## Any hint ? Cheers,
> > 
> > Pierre Baillet  
> > Server Shepherd @ [http://www.fotopedia.com](http://www.fotopedia.com)
> > 
> > 1: 2011-08-03\_07:37:45.37053 [2011-08-03 07:37:45,368][WARN][indices.cluster] [Sluggo] [picor][0] failed to start shard  
> > 2011-08-03\_07:37:45.37057 org.elasticsearch.index.shard.recovery.RecoveryFailedException: Index Shard [picor][0]: Recovery failed from [Reilly, Ben][1OvwxQYOSiCherwlLvReOQ][inet[/------:9300]] into [Sluggo][NrNDzEgkQQaB1HKvMqa16g][inet[/------:9300]]  
> > 2011-08-03\_07:37:45.37058 at org.elasticsearch.index.shard.recovery.RecoveryTarget.doRecovery(RecoveryTarget.java:243)  
> > 2011-08-03\_07:37:45.37061 at org.elasticsearch.index.shard.recovery.RecoveryTarget.access$100(RecoveryTarget.java:61)  
> > 2011-08-03\_07:37:45.37064 at org.elasticsearch.index.shard.recovery.RecoveryTarget$2.run(RecoveryTarget.java:146)  
> > 2011-08-03\_07:37:45.37065 at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)  
> > 2011-08-03\_07:37:45.37065 at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)  
> > 2011-08-03\_07:37:45.37066 at java.lang.Thread.run(Thread.java:636)  
> > 2011-08-03\_07:37:45.37066 Caused by: org.elasticsearch.transport.RemoteTransportException: [Reilly, Ben][inet[/10.203.38.176:9300]][index/shard/recovery/startRecovery]  
> > 2011-08-03\_07:37:45.37067 Caused by: org.elasticsearch.index.engine.RecoveryEngineException: [picor][0] Phase[2] Execution failed  
> > 2011-08-03\_07:37:45.37069 at org.elasticsearch.index.engine.robin.RobinEngine.recover(RobinEngine.java:1030)  
> > 2011-08-03\_07:37:45.37070 at org.elasticsearch.index.shard.service.InternalIndexShard.recover(InternalIndexShard.java:420)  
> > 2011-08-03\_07:37:45.37070 at org.elasticsearch.index.shard.recovery.RecoverySource.recover(RecoverySource.java:110)  
> > 2011-08-03\_07:37:45.37071 at org.elasticsearch.index.shard.recovery.RecoverySource.access$1600(RecoverySource.java:60)  
> > 2011-08-03\_07:37:45.37071 at org.elasticsearch.index.shard.recovery.RecoverySource$StartRecoveryTransportRequestHandler.messageReceived(RecoverySource.java:296)  
> > 2011-08-03\_07:37:45.37074 at org.elasticsearch.index.shard.recovery.RecoverySource$StartRecoveryTransportRequestHandler.messageReceived(RecoverySource.java:285)  
> > 2011-08-03\_07:37:45.37075 at org.elasticsearch.transport.netty.MessageChannelHandler$RequestHandler.run(MessageChannelHandler.java:238)  
> > 2011-08-03\_07:37:45.37075 at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)  
> > 2011-08-03\_07:37:45.37076 at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)  
> > 2011-08-03\_07:37:45.37077 at java.lang.Thread.run(Thread.java:636)  
> > 2011-08-03\_07:37:45.37077 Caused by: org.elasticsearch.transport.RemoteTransportException: [Sluggo][inet[/10.83.58.138:9300]][index/shard/recovery/translogOps]  
> > 2011-08-03\_07:37:45.37079 Caused by: org.elasticsearch.indices.InvalidAliasNameException: [picor] Invalid alias name [users], Unknown alias name was passed to alias Filter  
> > 2011-08-03\_07:37:45.37080 at org.elasticsearch.index.aliases.IndexAliasesService.aliasFilter(IndexAliasesService.java:87)  
> > 2011-08-03\_07:37:45.37080 at org.elasticsearch.index.shard.service.InternalIndexShard.innerDeleteByQuery(InternalIndexShard.java:337)  
> > 2011-08-03\_07:37:45.37081 at org.elasticsearch.index.shard.service.InternalIndexShard.performRecoveryOperation(InternalIndexShard.java:516)  
> > 2011-08-03\_07:37:45.37082 at org.elasticsearch.index.shard.recovery.RecoveryTarget$TranslogOperationsRequestHandler.messageReceived(RecoveryTarget.java:340)  
> > 2011-08-03\_07:37:45.37082 at org.elasticsearch.index.shard.recovery.RecoveryTarget$TranslogOperationsRequestHandler.messageReceived(RecoveryTarget.java:326)  
> > 2011-08-03\_07:37:45.37083 at org.elasticsearch.transport.netty.MessageChannelHandler$RequestHandler.run(MessageChannelHandler.java:238)  
> > 2011-08-03\_07:37:45.37084 at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)  
> > 2011-08-03\_07:37:45.37085 at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)  
> > 2011-08-03\_07:37:45.37086 at java.lang.Thread.run(Thread.java:636)

---

<div class="post-metadata">

**Author:** ![Dan\_Pilone](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dan_pilone/32/3261_2.png) [@Dan\_Pilone](https://discuss.elastic.co/u/Dan_Pilone)\
**Post date:** [August 3, 2011, 3:40pm UTC](https://discuss.elastic.co/t/initial-recovery-failing-unknown-alias-name-was-passed-to-alias-filter/5041/4 "2011-08-03T15:40:04Z")

</div>

AH! That's exactly what we've been seeing but haven't been able to track  
down. Thanks for the fix. Now do you have any idea how we can get from a  
running 0.17.2-SNAPSHOT instance to I guess a 0.17.3-SNAPSHOT instance  
without losing the index? We definitely have done lots of Delete By Queries  
on the currently running 0.17.2-SNAPSHOT cluster. -- Dan

---

<div class="post-metadata">

**Author:** ![kimchy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kimchy/32/44952_2.png) [@kimchy](https://discuss.elastic.co/u/kimchy)\
**Post date:** [August 3, 2011, 4:45pm UTC](https://discuss.elastic.co/t/initial-recovery-failing-unknown-alias-name-was-passed-to-alias-filter/5041/5 "2011-08-03T16:45:52Z")

</div>

you will need to delete the transaction logs for each shard, which means you  
will loose that relevant data. I will release 0.17.3 either today or  
tomorrow to address this and other bugs that have been fixed, and make a  
note that you should flush before upgrading to it so one won't hit it.

On Wed, Aug 3, 2011 at 6:40 PM, Dan Pilone [dan@element84.com](mailto:dan@element84.com) wrote:

> AH! That's exactly what we've been seeing but haven't been able to track  
> down. Thanks for the fix. Now do you have any idea how we can get from a  
> running 0.17.2-SNAPSHOT instance to I guess a 0.17.3-SNAPSHOT instance  
> without losing the index? We definitely have done lots of Delete By Queries  
> on the currently running 0.17.2-SNAPSHOT cluster. -- Dan

---

<div class="post-metadata">

**Author:** ![Dan\_Pilone](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dan_pilone/32/3261_2.png) [@Dan\_Pilone](https://discuss.elastic.co/u/Dan_Pilone)\
**Post date:** [August 3, 2011, 5:54pm UTC](https://discuss.elastic.co/t/initial-recovery-failing-unknown-alias-name-was-passed-to-alias-filter/5041/6 "2011-08-03T17:54:38Z")

</div>

Beautiful!! It worked great and we're running on a 0.17.3-SNAPSHOT build  
without issue. Thanks a ton. And if you're ever in Washington, DC I owe  
you a couple drinks. -- Dan

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 3:58am UTC](https://discuss.elastic.co/t/initial-recovery-failing-unknown-alias-name-was-passed-to-alias-filter/5041/7 "2017-07-06T03:58:21Z")

</div>


