# Input Output Error when creating snapshot

**URL:** <https://discuss.elastic.co/t/input-output-error-when-creating-snapshot/160231>\
**Category:** Elasticsearch\
**Created:** [December 10, 2018, 5:54pm UTC](https://discuss.elastic.co/t/input-output-error-when-creating-snapshot/160231 "2018-12-10T17:54:32Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Andres\_Gonzalez](https://avatars.discourse-cdn.com/v4/letter/a/96bed5/32.png) [@Andres\_Gonzalez](https://discuss.elastic.co/u/Andres_Gonzalez)\
**Post date:** [December 10, 2018, 5:54pm UTC](https://discuss.elastic.co/t/input-output-error-when-creating-snapshot/160231/1 "2018-12-10T17:54:32Z")

</div>

We are trying to add a Windows Shared Folder as the repository location for a Single Node Elasticsearch Instance that is running on SUSE SLES.

However once we try to create a new snapshot we get the following error:

> [2018-12-10T11:00:36,436][WARN][r.suppressed] path: /\_snapshot/auto\_repo\_nov\_2018/test, params: {repository=auto\_repo\_nov\_2018, snapshot=test}  
> org.elasticsearch.snapshots.SnapshotCreationException: [auto\_repo\_nov\_2018:test/-XukaQxVSfeiK7zWKnfkDA] failed to create snapshot  
> at org.elasticsearch.repositories.blobstore.BlobStoreRepository.initializeSnapshot(BlobStoreRepository.java:336) ~[elasticsearch-6.3.2.jar:6.3.2]  
> at org.elasticsearch.snapshots.SnapshotsService.beginSnapshot(SnapshotsService.java:363) ~[elasticsearch-6.3.2.jar:6.3.2]  
> at org.elasticsearch.snapshots.SnapshotsService.access$700(SnapshotsService.java:104) ~[elasticsearch-6.3.2.jar:6.3.2]  
> at org.elasticsearch.snapshots.SnapshotsService$1.lambda$clusterStateProcessed$1(SnapshotsService.java:281) ~[elasticsearch-6.3.2.jar:6.3.2]  
> at org.elasticsearch.common.util.concurrent.ThreadContext$ContextPreservingRunnable.run(ThreadContext.java:626) ~[elasticsearch-6.3.2.jar:6.3.2]  
> at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) [?:1.8.0\_161]  
> at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) [?:1.8.0\_161]  
> at java.lang.Thread.run(Unknown Source) [?:1.8.0\_161]  
> **Caused by: java.io.IOException: Input/output error**  
> at sun.nio.ch.FileDispatcherImpl.close0(Native Method) ~[?:?]  
> at sun.nio.ch.FileDispatcherImpl.close(Unknown Source) ~[?:?]  
> at sun.nio.ch.FileChannelImpl.implCloseChannel(Unknown Source) ~[?:?]  
> at java.nio.channels.spi.AbstractInterruptibleChannel.close(Unknown Source) ~[?:1.8.0\_161]  
> at java.nio.channels.Channels$1.close(Unknown Source) ~[?:1.8.0\_161]  
> at org.elasticsearch.core.internal.io.IOUtils.close(IOUtils.java:94) ~[elasticsearch-core-6.3.2.jar:6.3.2]  
> at org.elasticsearch.core.internal.io.IOUtils.close(IOUtils.java:64) ~[elasticsearch-core-6.3.2.jar:6.3.2]  
> at org.elasticsearch.core.internal.io.Streams.copy(Streams.java:64) ~[elasticsearch-core-6.3.2.jar:6.3.2]  
> at org.elasticsearch.common.blobstore.fs.FsBlobContainer.writeBlob(FsBlobContainer.java:131) ~[elasticsearch-6.3.2.jar:6.3.2]  
> at org.elasticsearch.repositories.blobstore.ChecksumBlobStoreFormat.writeBlob(ChecksumBlobStoreFormat.java:191) ~[elasticsearch-6.3.2.jar:6.3.2]  
> at org.elasticsearch.repositories.blobstore.ChecksumBlobStoreFormat.write(ChecksumBlobStoreFormat.java:161) ~[elasticsearch-6.3.2.jar:6.3.2]  
> at org.elasticsearch.repositories.blobstore.BlobStoreRepository.initializeSnapshot(BlobStoreRepository.java:326) ~[elasticsearch-6.3.2.jar:6.3.2]  
> ... 7 more

I think we might have made a mistake adding the windows Shared Folder in our linux server. What we did was the following steps:

1. Mount the Windows Shared Folder on linux with a command like the following in /etc/fstab by using command:

> \<windows server shared folder\> \<linux mount point\> cifs defaults,gid=,file\_mode=0777,dir\_mode=0777,noauto,nofail,credentials=\<credentials file\>,x-systemd.automount,x-systemd.requires=network-online.target 0 0

1. Add the mount point at **path.repo** inside our elasticsearch.yml.

2. Finally we just register the repository in Elasticsearch.

Do you have any idea what our problem is?.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 7, 2019, 5:54pm UTC](https://discuss.elastic.co/t/input-output-error-when-creating-snapshot/160231/2 "2019-01-07T17:54:34Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
