# Install Elasticsearch on Debian Jessie failed

**URL:** <https://discuss.elastic.co/t/install-elasticsearch-on-debian-jessie-failed/105013>\
**Category:** Elasticsearch\
**Created:** [October 24, 2017, 8:43am UTC](https://discuss.elastic.co/t/install-elasticsearch-on-debian-jessie-failed/105013 "2017-10-24T08:43:17Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![Nos2016](https://avatars.discourse-cdn.com/v4/letter/n/85f322/32.png) [@Nos2016](https://discuss.elastic.co/u/Nos2016)\
**Post date:** [October 24, 2017, 8:43am UTC](https://discuss.elastic.co/t/install-elasticsearch-on-debian-jessie-failed/105013/1 "2017-10-24T08:43:18Z")

</div>

Hi,

As my elasticsearch stop frequently, I decide to reinstall it on my debian jessie.  
I did the following commands :  
sudo apt-get --purge autoremove elasticsearch  
sudo rm -rf /var/lib/elasticsearch/  
sudo rm -rf /etc/elasticsearch  
wget -qO - [https://artifacts.elastic.co/GPG-KEY-elasticsearch](https://artifacts.elastic.co/GPG-KEY-elasticsearch) | sudo apt-key add -  
sudo apt update && sudo apt install elasticsearch  
sudo update-rc.d elasticsearch defaults 95 10  
I tried also sudo -i service elasticsearch start

However at the end of installation, my elasticsearch service won't start and I don't know why :  
The following is the status log of my Elasticsearch :  
systemctl status elasticsearch  
● elasticsearch.service - Elasticsearch  
Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; disabled)  
Active: failed (Result: signal) since mar. 2017-10-24 10:33:41 CEST; 2min 38s ago  
Docs: [http://www.elastic.co](http://www.elastic.co)  
Process: 24344 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID\_DIR}/elasticsearch.pid --quiet -Edefault.path.logs=${LOG\_DIR} -Edefault.path.data=${DATA\_DIR} -Edefault.path.conf=${CONF\_DIR} (code=killed, signal=KILL)  
Process: 24341 ExecStartPre=/usr/share/elasticsearch/bin/elasticsearch-systemd-pre-exec (code=exited, status=0/SUCCESS)  
Main PID: 24344 (code=killed, signal=KILL)

oct. 24 10:33:37 [vps75137.ovh.net](http://vps75137.ovh.net) systemd[1]: Started Elasticsearch.  
oct. 24 10:33:41 [vps75137.ovh.net](http://vps75137.ovh.net) systemd[1]: elasticsearch.service: main process exited, code=killed, status=9/KILL  
oct. 24 10:33:41 [vps75137.ovh.net](http://vps75137.ovh.net) systemd[1]: Unit elasticsearch.service entered failed state.

I don't know why ?  
There is nothing in my /var/log/elasticsearch/

If someone can help me.

Best regards,

JC

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [October 24, 2017, 8:52am UTC](https://discuss.elastic.co/t/install-elasticsearch-on-debian-jessie-failed/105013/2 "2017-10-24T08:52:13Z")

</div>

Is there anything in the main OS sysslog?

---

<div class="post-metadata">

**Author:** ![Nos2016](https://avatars.discourse-cdn.com/v4/letter/n/85f322/32.png) [@Nos2016](https://discuss.elastic.co/u/Nos2016)\
**Post date:** [October 24, 2017, 8:55am UTC](https://discuss.elastic.co/t/install-elasticsearch-on-debian-jessie-failed/105013/3 "2017-10-24T08:55:59Z")

</div>

Oct 24 10:33:37 vps75137 systemd[1]: Failed to reset devices.list on /system.slice/nfs-common.service: No such file or directory  
Oct 24 10:33:37 vps75137 systemd[1]: Failed to reset devices.list on /system.slice/rpcbind.service: No such file or directory  
Oct 24 10:33:37 vps75137 systemd[1]: Failed to reset devices.list on /system.slice/systemd-random-seed.service: No such file or directory  
Oct 24 10:33:37 vps75137 systemd[1]: Failed to reset devices.list on /system.slice/networking.service: No such file or directory  
Oct 24 10:33:37 vps75137 systemd[1]: Failed to reset devices.list on /system.slice/systemd-journald.service: No such file or directory  
Oct 24 10:33:37 vps75137 systemd[1]: Failed to reset devices.list on /system.slice/systemd-remount-fs.service: No such file or directory  
Oct 24 10:33:37 vps75137 systemd[1]: Started Elasticsearch.  
Oct 24 10:33:41 vps75137 systemd[1]: elasticsearch.service: main process exited, code=killed, status=9/KILL  
Oct 24 10:33:41 vps75137 systemd[1]: Unit elasticsearch.service entered failed state.  
Oct 24 10:39:01 vps75137 CRON[24384]: (root) CMD ( [-x /usr/lib/php5/sessionclean] && /usr/lib/php5/sessionclean)

---

<div class="post-metadata">

**Author:** ![Nos2016](https://avatars.discourse-cdn.com/v4/letter/n/85f322/32.png) [@Nos2016](https://discuss.elastic.co/u/Nos2016)\
**Post date:** [October 24, 2017, 1:00pm UTC](https://discuss.elastic.co/t/install-elasticsearch-on-debian-jessie-failed/105013/4 "2017-10-24T13:00:11Z")

</div>

Any advice ?

---

<div class="post-metadata">

**Author:** ![Nos2016](https://avatars.discourse-cdn.com/v4/letter/n/85f322/32.png) [@Nos2016](https://discuss.elastic.co/u/Nos2016)\
**Post date:** [October 25, 2017, 12:32pm UTC](https://discuss.elastic.co/t/install-elasticsearch-on-debian-jessie-failed/105013/5 "2017-10-25T12:32:39Z")

</div>

> [@Nos2016](#):
>
> Failed to reset devices.list on /system.slice/nfs-common.service: No such file or directory

First of all, I discovered in /etc/sysctl.d/99-sysctl.conf that there was a mistake on the following lines:

#kernel.printk = 3 4 1 3

##############################################################3

You can see a "3" at the end of comment's line. You need to remove it. After that, I reinstall Elasticsearch.

However, same result for Elasticsearch 😢. My new syslog :  
Oct 25 14:24:08 vps75137 systemd[1]: Failed to reset devices.list on /system.slice/systemd-tmpfiles-setup.service: No such file or directory  
Oct 25 14:24:08 vps75137 systemd[1]: Failed to reset devices.list on /system.slice/nfs-common.service: No such file or directory  
Oct 25 14:24:08 vps75137 systemd[1]: Failed to reset devices.list on /system.slice/rpcbind.service: No such file or directory  
Oct 25 14:24:08 vps75137 systemd[1]: Failed to reset devices.list on /system.slice/systemd-random-seed.service: No such file or directory  
Oct 25 14:24:08 vps75137 systemd[1]: Failed to reset devices.list on /system.slice/networking.service: No such file or directory  
Oct 25 14:24:08 vps75137 systemd[1]: Failed to reset devices.list on /system.slice/systemd-journald.service: No such file or directory  
Oct 25 14:24:08 vps75137 systemd[1]: Failed to reset devices.list on /system.slice/systemd-remount-fs.service: No such file or directory  
Oct 25 14:24:08 vps75137 systemd[1]: Started Elasticsearch.  
Oct 25 14:24:12 vps75137 systemd[1]: elasticsearch.service: main process exited, code=killed, status=9/KILL  
Oct 25 14:24:12 vps75137 systemd[1]: Unit elasticsearch.service entered failed state.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 22, 2017, 12:33pm UTC](https://discuss.elastic.co/t/install-elasticsearch-on-debian-jessie-failed/105013/6 "2017-11-22T12:33:07Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
