# Install Fleet server 8.2.2 fails: Error - could not start the HTTP server for the API: failed to listen on the named pipe

**URL:** <https://discuss.elastic.co/t/install-fleet-server-8-2-2-fails-error-could-not-start-the-http-server-for-the-api-failed-to-listen-on-the-named-pipe/307964>\
**Category:** Elasticsearch\
**Tags:** docker, fleet, elastic-agent\
**Created:** [June 23, 2022, 8:29am UTC](https://discuss.elastic.co/t/install-fleet-server-8-2-2-fails-error-could-not-start-the-http-server-for-the-api-failed-to-listen-on-the-named-pipe/307964 "2022-06-23T08:29:33Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![tidenhub](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tidenhub/32/107473_2.png) [@tidenhub](https://discuss.elastic.co/u/tidenhub)\
**Post date:** [June 23, 2022, 8:29am UTC](https://discuss.elastic.co/t/install-fleet-server-8-2-2-fails-error-could-not-start-the-http-server-for-the-api-failed-to-listen-on-the-named-pipe/307964/1 "2022-06-23T08:29:33Z")

</div>

Hi, I set up Elasticsearch and Kibana via Docker Compose using [elasticsearch/docker-compose.yml at 8.2 · elastic/elasticsearch (github.com)](https://github.com/elastic/elasticsearch/blob/8.2/docs/reference/setup/install/docker/docker-compose.yml).

I created the agent policy to host Fleet Server.  
I choose "Quick start" as deployment mode for security,  
and added "[https://localhost:8220](https://localhost:8220)" as Fleet Server host.  
Finally, I tried to install the fleet server on the Windows 10 host. But I'm getting the following error, and the troubleshooting guide hasn't helped me.

```auto
PS C:\Users\tiede\elastic-agent-8.2.2-windows-x86_64> .\elastic-agent.exe enroll `
>> --fleet-server-es=https://localhost:9200 `
>> --fleet-server-service-token=XXXXX`
>> --fleet-server-policy=fleet-server-policy `
>> --fleet-server-insecure-http

```

With the command above, I'm getting this:

```auto
{"log.level":"error","@timestamp":"2022-06-23T11:01:09.340+0200","log.origin":{"file.name":"status/reporter.go","file.line":236},"message":"Elastic Agent status changed to: 'error'","ecs.version":"1.6.0"}
{"log.level":"error","@timestamp":"2022-06-23T11:01:09.340+0200","log.origin":{"file.name":"log/reporter.go","file.line":36},"message":"2022-06-23T11:01:09+02:00 - message: Application: fleet-server--8.2.2[]: State changed to FAILED: Error - could not start the HTTP server for the API: failed to listen on the named pipe \\\\.\\pipe\\default-fleet-server: open \\\\.\\pipe\\default-fleet-server: Access is denied. - type: 'ERROR' - sub_type: 'FAILED'","ecs.version":"1.6.0"}
Error: fleet-server failed: context canceled

```

What I'm I missing, to get the Fleet server up and running?

---

<div class="post-metadata">

**Author:** ![MarianaD](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/marianad/32/42687_2.png) [@MarianaD](https://discuss.elastic.co/u/MarianaD)\
**Post date:** [July 13, 2022, 9:34am UTC](https://discuss.elastic.co/t/install-fleet-server-8-2-2-fails-error-could-not-start-the-http-server-for-the-api-failed-to-listen-on-the-named-pipe/307964/2 "2022-07-13T09:34:01Z")

</div>

hi @tidenhub , I see in the errors `Access is denied` , are you running the enroll cmd as adminstrator?

---

<div class="post-metadata">

**Author:** ![tidenhub](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tidenhub/32/107473_2.png) [@tidenhub](https://discuss.elastic.co/u/tidenhub)\
**Post date:** [July 13, 2022, 12:02pm UTC](https://discuss.elastic.co/t/install-fleet-server-8-2-2-fails-error-could-not-start-the-http-server-for-the-api-failed-to-listen-on-the-named-pipe/307964/3 "2022-07-13T12:02:19Z")

</div>

Yes, the enroll and run was executed as administrator.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 10, 2022, 12:03pm UTC](https://discuss.elastic.co/t/install-fleet-server-8-2-2-fails-error-could-not-start-the-http-server-for-the-api-failed-to-listen-on-the-named-pipe/307964/4 "2022-08-10T12:03:01Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
