# Install reporting failed

**URL:** <https://discuss.elastic.co/t/install-reporting-failed/61238>\
**Category:** Kibana\
**Tags:** elastic-stack-reporting\
**Created:** [September 22, 2016, 11:00am UTC](https://discuss.elastic.co/t/install-reporting-failed/61238 "2016-09-22T11:00:53Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![ugiwgh](https://avatars.discourse-cdn.com/v4/letter/u/ecc23a/32.png) [@ugiwgh](https://discuss.elastic.co/u/ugiwgh)\
**Post date:** [September 22, 2016, 11:00am UTC](https://discuss.elastic.co/t/install-reporting-failed/61238/1 "2016-09-22T11:00:53Z")

</div>

[root@centos7 kibana-4.6.1-linux-x86\_64]# bin/kibana plugin --remove reporting  
Removing reporting...  
[root@centos7 kibana-4.6.1-linux-x86\_64]# bin/kibana plugin --install reporting --url file:///root/es/reporting-latest.tar.gz  
Installing reporting  
Attempting to transfer from file:///root/es/reporting-latest.tar.gz  
Transferring 50539752 bytes....................  
Transfer complete  
Extracting plugin archive  
Extraction complete  
Optimizing and caching browser bundles...  
Killed

---

<div class="post-metadata">

**Author:** ![LeeDr](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leedr/32/9289_2.png) [@LeeDr](https://discuss.elastic.co/u/LeeDr)\
**Post date:** [October 10, 2016, 6:31pm UTC](https://discuss.elastic.co/t/install-reporting-failed/61238/2 "2016-10-10T18:31:12Z")

</div>

Did you get this problem solved? Did you kill it after it appeared hung? It can take several minutes for that last step `Optimizing and caching browser bundles...`

---

<div class="post-metadata">

**Author:** ![Joe\_Fleming](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/joe_fleming/32/3561_2.png) [@Joe\_Fleming](https://discuss.elastic.co/u/Joe_Fleming)\
**Post date:** [October 10, 2016, 11:11pm UTC](https://discuss.elastic.co/t/install-reporting-failed/61238/3 "2016-10-10T23:11:23Z")

</div>

I'm assuming the `Killed` in the output came from the process. How much memory does your server have, and are you using swap?

The Kibana "optimize" step will take at least 2gb of ram, otherwise it'll just crash like this. You can probably get away with 1gb if you also have 1gb or more of swap, at the cost of the process taking a long time to run.

As a workaround, if you the both doesn't or can't have that much memory, you can run it on a box that does and then copy the whole Kibana package back to your server.

---

<div class="post-metadata">

**Author:** ![ugiwgh](https://avatars.discourse-cdn.com/v4/letter/u/ecc23a/32.png) [@ugiwgh](https://discuss.elastic.co/u/ugiwgh)\
**Post date:** [October 12, 2016, 6:12am UTC](https://discuss.elastic.co/t/install-reporting-failed/61238/4 "2016-10-12T06:12:55Z")

</div>

Yes, it seems that memory is not enough. I move them to the server where is much more memory.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 1:43pm UTC](https://discuss.elastic.co/t/install-reporting-failed/61238/5 "2017-07-06T13:43:04Z")

</div>


