# Installation in error \[Solved\]

**URL:** <https://discuss.elastic.co/t/installation-in-error-solved/81977>\
**Category:** Elasticsearch\
**Created:** [April 11, 2017, 11:50am UTC](https://discuss.elastic.co/t/installation-in-error-solved/81977 "2017-04-11T11:50:24Z")\
**Posts on this page:** 11\
**Page:** 1

<div class="post-metadata">

**Author:** ![rlatrasse45](https://avatars.discourse-cdn.com/v4/letter/r/f07891/32.png) [@rlatrasse45](https://discuss.elastic.co/u/rlatrasse45)\
**Post date:** [April 11, 2017, 11:50am UTC](https://discuss.elastic.co/t/installation-in-error-solved/81977/1 "2017-04-11T11:50:24Z")

</div>

Hey,  
I want install elasticsearch on my server (Linux RHEL-6Server-6.6.0.2.el6.x86\_64) with jdk1.8.0\_112 but I always the same error.  
I try with the latest version of jdk (1.8.0.121) but the result is the same.

> [elasticsearch@pcyy4aix ~]$ cd /logiciels/elasticsearch-5.3.0/bin  
> [elasticsearch@pcyy4aix bin]$ ./elasticsearch  
> Error occurred during initialization of VM  
> java.lang.OutOfMemoryError: unable to create new native thread  
> Elasticsearch requires at least Java 8 but your Java version from /usr/bin/java does not meet this requirement

> [elasticsearch@pcyy4aix bin]$ java -version  
> java version "1.8.0\_121"  
> Java(TM) SE Runtime Environment (build 1.8.0\_121-b13)  
> Java HotSpot(TM) 64-Bit Server VM (build 25.121-b13, mixed mode)

In the script, I find

> "$JAVA" -cp "$ES\_CLASSPATH" org.elasticsearch.tools.JavaVersionChecker  
> if [$? -ne 0]; then  
> echo "Elasticsearch requires at least Java 8 but your Java version from $JAVA does not meet this requirement"  
> exit 1  
> fi

And I try with the same variables and command line, no mistake

> [elasticsearch@pcyy4aixbin]$ JAVA=/usr/bin/java  
> [elasticsearch@pcyy4aix bin]$ES\_CLASSPATH=/logiciels/elasticsearch-5.3.0/lib/elasticsearch-5.3.0.jar:/logiciels/elasticsearch-5.3.0/lib/\*  
> [elasticsearch@pcyy4aix bin]$ "$JAVA" -cp "$ES\_CLASSPATH" org.elasticsearch.tools.JavaVersionChecker  
> [elasticsearch@pcyy4aixbin]$ echo $?  
> 0

Thank you for your help.

---

<div class="post-metadata">

**Author:** ![Prashant\_Agrawal](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/prashant_agrawal/32/74982_2.png) [@Prashant\_Agrawal](https://discuss.elastic.co/u/Prashant_Agrawal)\
**Post date:** [April 11, 2017, 11:53am UTC](https://discuss.elastic.co/t/installation-in-error-solved/81977/2 "2017-04-11T11:53:46Z")

</div>

> [@rlatrasse45](#):
>
> java.lang.OutOfMemoryError:

Comes when you dont have sufficient memory , can you tell how much memory you have in system , you can check it via

> free -m

If you have less than 4 GB then try changing the heap size in jvm.options from 2G (default) and make it 1G or 512M

---

<div class="post-metadata">

**Author:** ![rlatrasse45](https://avatars.discourse-cdn.com/v4/letter/r/f07891/32.png) [@rlatrasse45](https://discuss.elastic.co/u/rlatrasse45)\
**Post date:** [April 11, 2017, 11:58am UTC](https://discuss.elastic.co/t/installation-in-error-solved/81977/3 "2017-04-11T11:58:11Z")

</div>

Here is what I have:

> [elasticsearch@pcyy4aix ~]$ free -m  
> total used free shared buffers cached  
> Mem: 15822 2400 13422 12 277 1342  
> -/+ buffers/cache: 780 15041  
> Swap: 1055 0 1055

I think I have enough memory

---

<div class="post-metadata">

**Author:** ![rlatrasse45](https://avatars.discourse-cdn.com/v4/letter/r/f07891/32.png) [@rlatrasse45](https://discuss.elastic.co/u/rlatrasse45)\
**Post date:** [April 11, 2017, 1:03pm UTC](https://discuss.elastic.co/t/installation-in-error-solved/81977/4 "2017-04-11T13:03:08Z")

</div>

And how to make the change ?

---

<div class="post-metadata">

**Author:** ![rlatrasse45](https://avatars.discourse-cdn.com/v4/letter/r/f07891/32.png) [@rlatrasse45](https://discuss.elastic.co/u/rlatrasse45)\
**Post date:** [April 11, 2017, 3:18pm UTC](https://discuss.elastic.co/t/installation-in-error-solved/81977/5 "2017-04-11T15:18:50Z")

</div>

I added

> ES\_JAVA\_OPTS="-Xms8g -Xmx8g" ./bin/elasticsearch

In the script "elasticsearch" but I always have an error:

> [elasticsearch@pcyy4aix bin]$ ./elasticsearch  
> ./elasticsearch: fork: retry: Resource temporarily unavailable  
> ./elasticsearch: fork: retry: Resource temporarily unavailable  
> ./elasticsearch: fork: retry: Resource temporarily unavailable  
> ./elasticsearch: fork: retry: Resource temporarily unavailable

---

<div class="post-metadata">

**Author:** ![rlatrasse45](https://avatars.discourse-cdn.com/v4/letter/r/f07891/32.png) [@rlatrasse45](https://discuss.elastic.co/u/rlatrasse45)\
**Post date:** [April 11, 2017, 3:31pm UTC](https://discuss.elastic.co/t/installation-in-error-solved/81977/6 "2017-04-11T15:31:03Z")

</div>

I fund the file "jvm.options" in the folder "config".  
I have change the parameters "Xms" and "Xmx" with "1g" or "8 g" and nothing.  
Always the same error.

---

<div class="post-metadata">

**Author:** ![rlatrasse45](https://avatars.discourse-cdn.com/v4/letter/r/f07891/32.png) [@rlatrasse45](https://discuss.elastic.co/u/rlatrasse45)\
**Post date:** [April 11, 2017, 3:49pm UTC](https://discuss.elastic.co/t/installation-in-error-solved/81977/7 "2017-04-11T15:49:57Z")

</div>

I found the problem.  
I increase the number of processus of user "elasticsearch" of 2 to 200 to modify the file "/etc/security/limits.conf" and added the line

> elasticsearch hard nproc 200

Now, I have a another problem:

> [elasticsearch@pcyy4aix bin]$ ./elasticsearch  
> Exception in thread "main" SettingsException[Failed to load settings from /logiciels/elasticsearch-5.3.0/config/elasticsearch.yml]; nested: AccessDeniedException[/logiciels/elasticsearch-5.3.0/config/elasticsearch.yml];  
> at org.elasticsearch.node.InternalSettingsPreparer.prepareEnvironment(InternalSettingsPreparer.java:107)  
> at org.elasticsearch.cli.EnvironmentAwareCommand.createEnv(EnvironmentAwareCommand.java:63)  
> at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:58)  
> at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:122)  
> at org.elasticsearch.cli.Command.main(Command.java:88)  
> at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:91)  
> at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:84)  
> Caused by: java.nio.file.AccessDeniedException: /logiciels/elasticsearch-5.3.0/config/elasticsearch.yml  
> at sun.nio.fs.UnixException.translateToIOException(UnixException.java:84)  
> at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:102)  
> at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:107)  
> at sun.nio.fs.UnixFileSystemProvider.newByteChannel(UnixFileSystemProvider.java:214)  
> at java.nio.file.Files.newByteChannel(Files.java:361)  
> at java.nio.file.Files.newByteChannel(Files.java:407)  
> at java.nio.file.spi.FileSystemProvider.newInputStream(FileSystemProvider.java:384)  
> at java.nio.file.Files.newInputStream(Files.java:152)  
> at org.elasticsearch.common.settings.Settings$Builder.loadFromPath(Settings.java:1011)  
> at org.elasticsearch.node.InternalSettingsPreparer.prepareEnvironment(InternalSettingsPreparer.java:105)  
> ... 6 more

---

<div class="post-metadata">

**Author:** ![rlatrasse45](https://avatars.discourse-cdn.com/v4/letter/r/f07891/32.png) [@rlatrasse45](https://discuss.elastic.co/u/rlatrasse45)\
**Post date:** [April 11, 2017, 4:07pm UTC](https://discuss.elastic.co/t/installation-in-error-solved/81977/8 "2017-04-11T16:07:46Z")

</div>

I fund this error's origin.  
The folder of "elasticsearch" had the owner "root" instead of "elasticsearch".

Now, the process run:

> 496 7182 1 13 18:03 ? 00:00:19 /usr/bin/java -Xms1g -Xmx1g -XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingOccupancyOnly -XX:+DisableExplicitGC -XX:+AlwaysPreTouch -server -Xss1m -Djava.awt.headless=true -Dfile.encoding=UTF-8 -Djna.nosys=true -Djdk.io.permissionsUseCanonicalPath=true -Dio.netty.noUnsafe=true -Dio.netty.noKeySetOptimization=true -Dio.netty.recycler.maxCapacityPerThread=0 -Dlog4j.shutdownHookEnabled=false -Dlog4j2.disable.jmx=true -Dlog4j.skipJansi=true -XX:+HeapDumpOnOutOfMemoryError -Des.path.home=/logiciels/elasticsearch-5.3.0 -cp /logiciels/elasticsearch-5.3.0/lib/elasticsearch-5.3.0.jar:/logiciels/elasticsearch-5.3.0/lib/\* org.elasticsearch.bootstrap.Elasticsearch -p /var/run/elasticsearch/elasticsearch.pid -d -Edefault.path.logs=/var/log/elasticsearch -Edefault.path.data=/var/lib/elasticsearch -Edefault.path.conf=/etc/elasticsearch

But the connection at the URL "http://@IP:9200" don't answer.

Is it normal ?

---

<div class="post-metadata">

**Author:** ![rlatrasse45](https://avatars.discourse-cdn.com/v4/letter/r/f07891/32.png) [@rlatrasse45](https://discuss.elastic.co/u/rlatrasse45)\
**Post date:** [April 11, 2017, 4:14pm UTC](https://discuss.elastic.co/t/installation-in-error-solved/81977/9 "2017-04-11T16:14:37Z")

</div>

The test with curl works 😄

> [root@pcyy4aix logiciels]# curl [http://localhost:9200/](http://localhost:9200/)  
> {  
> "name" : "t9LuWpF",  
> "cluster\_name" : "elasticsearch",  
> "cluster\_uuid" : "ILYG0mQRTlqDa7mP5x2DuA",  
> "version" : {  
> "number" : "5.3.0",  
> "build\_hash" : "3adb13b",  
> "build\_date" : "2017-03-23T03:31:50.652Z",  
> "build\_snapshot" : false,  
> "lucene\_version" : "6.4.1"  
> },  
> "tagline" : "You Know, for Search"  
> }

---

<div class="post-metadata">

**Author:** ![Prashant\_Agrawal](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/prashant_agrawal/32/74982_2.png) [@Prashant\_Agrawal](https://discuss.elastic.co/u/Prashant_Agrawal)\
**Post date:** [April 12, 2017, 12:18pm UTC](https://discuss.elastic.co/t/installation-in-error-solved/81977/10 "2017-04-12T12:18:06Z")

</div>

Great to hear it works.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 10, 2017, 12:18pm UTC](https://discuss.elastic.co/t/installation-in-error-solved/81977/11 "2017-05-10T12:18:39Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
