# Installed logstash rpm, service keeps stopping with no clear reason

**URL:** <https://discuss.elastic.co/t/installed-logstash-rpm-service-keeps-stopping-with-no-clear-reason/299446>\
**Category:** Logstash\
**Created:** [March 11, 2022, 12:03pm UTC](https://discuss.elastic.co/t/installed-logstash-rpm-service-keeps-stopping-with-no-clear-reason/299446 "2022-03-11T12:03:00Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![jelmew](https://avatars.discourse-cdn.com/v4/letter/j/898d66/32.png) [@jelmew](https://discuss.elastic.co/u/jelmew)\
**Post date:** [March 11, 2022, 12:03pm UTC](https://discuss.elastic.co/t/installed-logstash-rpm-service-keeps-stopping-with-no-clear-reason/299446/1 "2022-03-11T12:03:00Z")

</div>

Hi all,

We are trying to setup logstash to connect to elastic cloud. We downloaded the rpm and installed it. But even without any configuration pointing to our elastic cloud instance, the service just stops with the message:

```auto
[2022-03-11T12:55:06,877][FATAL][org.logstash.Logstash] Logstash stopped processing because of an error: (SystemExit) exit
org.jruby.exceptions.SystemExit: (SystemExit) exit
	at org.jruby.RubyKernel.exit(org/jruby/RubyKernel.java:747) ~[jruby.jar:?]
	at org.jruby.RubyKernel.exit(org/jruby/RubyKernel.java:710) ~[jruby.jar:?]
	at usr.share.logstash.lib.bootstrap.environment.<main>(/usr/share/logstash/lib/bootstrap/environment.rb:94) ~[?:?]

```

The only other error line is

```auto
[2022-03-11T12:55:06,777][ERROR][logstash.config.sourceloader] No configuration found in the configured sources.

```

What might cause this behaviour? We fee hesitant to modify the config any further while it is not even running.

Kind regards,  
Jelmer van Amen

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [March 11, 2022, 4:48pm UTC](https://discuss.elastic.co/t/installed-logstash-rpm-service-keeps-stopping-with-no-clear-reason/299446/2 "2022-03-11T16:48:49Z")

</div>

> [@jelmew](#):
>
> What might cause this behaviour?

You need to provided additional information. See [this](https://discuss.elastic.co/t/fatal-470-logstash-stopped-processing-because-of-an-error-systemexit-exit/273091/2) thread.

---

<div class="post-metadata">

**Author:** ![leandrojmp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leandrojmp/32/107231_2.png) [@leandrojmp](https://discuss.elastic.co/u/leandrojmp)\
**Post date:** [March 11, 2022, 4:56pm UTC](https://discuss.elastic.co/t/installed-logstash-rpm-service-keeps-stopping-with-no-clear-reason/299446/3 "2022-03-11T16:56:28Z")

</div>

Logstash won't run without any configuration, you need a configuration file with `input` and `output`, without it Logstash has nothing to do and will not start.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 8, 2022, 4:56pm UTC](https://discuss.elastic.co/t/installed-logstash-rpm-service-keeps-stopping-with-no-clear-reason/299446/4 "2022-04-08T16:56:38Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
