# Installing 8.4.x on docker and having issues

**URL:** <https://discuss.elastic.co/t/installing-8-4-x-on-docker-and-having-issues/316530>\
**Category:** Logstash\
**Tags:** docker\
**Created:** [October 13, 2022, 11:34am UTC](https://discuss.elastic.co/t/installing-8-4-x-on-docker-and-having-issues/316530 "2022-10-13T11:34:16Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![neilwcdl](https://avatars.discourse-cdn.com/v4/letter/n/a9a28c/32.png) [@neilwcdl](https://discuss.elastic.co/u/neilwcdl)\
**Post date:** [October 13, 2022, 11:34am UTC](https://discuss.elastic.co/t/installing-8-4-x-on-docker-and-having-issues/316530/1 "2022-10-13T11:34:16Z")

</div>

Hi,

Sorry I'm very new to logstash and docker and currently looking at installing 8.4.3, as we are currently on 8.3.2.

Installing 8.3.3 - no issues  
Installing 8.4.0 - the issues start

**---\> Running in 54f67362af15**  
**Using bundled JDK: /usr/share/logstash/jdk**  
**Unrecognized VM option 'UseConcMarkSweepGC'**  
**Error: Could not create the Java Virtual Machine.**  
**Error: A fatal exception has occurred. Program will exit.**

The dockerfile, where I specify the install of the plugins

RUN rm -f /usr/share/logstash/pipeline/logstash.conf /usr/share/logstash/config/logstash-sample.conf &&   
/usr/share/logstash/bin/logstash-plugin install logstash-input-beats &&   
/usr/share/logstash/bin/logstash-plugin install logstash-filter-prune &&   
/usr/share/logstash/bin/logstash-plugin install logstash-output-opensearch &&   
mkdir -p /usr/share/logstash/queue &&   
chown -R logstash:root /usr/share/logstash/queue

Is anyone able to tell me what I'm missing, as I've commented out the RUN section and this builds fine. Just seems to be an issue with installing the different plugins.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 13, 2022, 11:34am UTC](https://discuss.elastic.co/t/installing-8-4-x-on-docker-and-having-issues/316530/2 "2022-10-13T11:34:17Z")

</div>

OpenSearch/OpenDistro are AWS run products and differ from the original Elasticsearch and Kibana products that Elastic builds and maintains. You may need to contact them directly for further assistance.

(This is an automated response from your friendly Elastic bot. Please report this post if you have any suggestions or concerns :elasticheart: )

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 10, 2022, 11:34am UTC](https://discuss.elastic.co/t/installing-8-4-x-on-docker-and-having-issues/316530/3 "2022-11-10T11:34:19Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
