# Installing Elastic Agent on Kubernetes doesn't come up as healthy - managed by Elastic Fleet

**URL:** <https://discuss.elastic.co/t/installing-elastic-agent-on-kubernetes-doesnt-come-up-as-healthy-managed-by-elastic-fleet/328729>\
**Category:** Elastic Agent\
**Created:** [March 28, 2023, 3:38pm UTC](https://discuss.elastic.co/t/installing-elastic-agent-on-kubernetes-doesnt-come-up-as-healthy-managed-by-elastic-fleet/328729 "2023-03-28T15:38:58Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Alexios\_Polyzos](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alexios_polyzos/32/119065_2.png) [@Alexios\_Polyzos](https://discuss.elastic.co/u/Alexios_Polyzos)\
**Post date:** [March 28, 2023, 3:38pm UTC](https://discuss.elastic.co/t/installing-elastic-agent-on-kubernetes-doesnt-come-up-as-healthy-managed-by-elastic-fleet/328729/1 "2023-03-28T15:38:58Z")

</div>

So, I'm trying to install the elastic agent on Kubernetes via the daemonset manifest files found [here](https://www.elastic.co/guide/en/fleet/7.17/running-on-kubernetes-managed-by-fleet.html).

I'm providing the `FLEET_URL` and `FLEET_ENROLLMENT_TOKEN`, and after the first seconds the agents show up as healthy on the Fleet UI of Kibana. But, after a couple of minutes they go to `Unhealthy` and eventually `offline`. The errors I'm seeing are:

```auto
18:33:15.472
elastic_agent
[elastic_agent][warn] Component state changed endpoint-default (STARTING->DEGRADED): Degraded: endpoint service missed 1 check-in
18:34:15.478
elastic_agent
[elastic_agent][error] Component state changed endpoint-default (DEGRADED->FAILED): Failed: endpoint service missed 3 check-ins
18:34:15.478
elastic_agent
[elastic_agent][error] Unit state changed endpoint-default-00d9d3db-473f-4911-ae11-86bd3c022631 (STARTING->FAILED): Failed: endpoint service missed 3 check-ins
18:34:15.478
elastic_agent
[elastic_agent][error] Unit state changed endpoint-default (STARTING->FAILED): Failed: endpoint service missed 3 check-ins

```

Any idea?

---

<div class="post-metadata">

**Author:** ![Alexios\_Polyzos](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alexios_polyzos/32/119065_2.png) [@Alexios\_Polyzos](https://discuss.elastic.co/u/Alexios_Polyzos)\
**Post date:** [March 29, 2023, 6:10pm UTC](https://discuss.elastic.co/t/installing-elastic-agent-on-kubernetes-doesnt-come-up-as-healthy-managed-by-elastic-fleet/328729/2 "2023-03-29T18:10:00Z")

</div>

Apparently, elastic-agent can run on Kubernetes but the [endpoint security cannot](https://discuss.elastic.co/t/issue-enrolling-elastic-agent-in-docker/325511/2).

To me it seems that consecutively, the whole elastic-agent cannot run in Kubernetes as there's no option (?) to disable the endpoint security.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 26, 2023, 6:10pm UTC](https://discuss.elastic.co/t/installing-elastic-agent-on-kubernetes-doesnt-come-up-as-healthy-managed-by-elastic-fleet/328729/3 "2023-04-26T18:10:42Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
