# Installing Opendistro ES on Amazon Linux - ES running but empty reply form server

**URL:** https://discuss.elastic.co/t/installing-opendistro-es-on-amazon-linux-es-running-but-empty-reply-form-server/220318
**Category:** Elasticsearch
**Created:** [February 21, 2020, 9:20am UTC](https://discuss.elastic.co/t/installing-opendistro-es-on-amazon-linux-es-running-but-empty-reply-form-server/220318 "2020-02-21T09:20:59Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![reshma\_ramakrishnan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/reshma_ramakrishnan/32/63095_2.png) [@reshma\_ramakrishnan](https://discuss.elastic.co/u/reshma_ramakrishnan)
#### Post date: [February 21, 2020, 9:20am UTC](https://discuss.elastic.co/t/installing-opendistro-es-on-amazon-linux-es-running-but-empty-reply-form-server/220318/1 "2020-02-21T09:20:59Z")

</div>

I am installing Opendistro Elasticsearch using RPM into Amazon Linux based EC2 instance.  
I see my ES is running but when I do `curl ` `http://localhost:9200/` it returns the below error:  
`curl: (52) Empty reply from server` .

I tried the below ways of updating the `network_host` :network.host: ["_eth0_", "127.0.0.1"]  
network.host: 127.0.0.1  
network.host: ["_eth0_", "127.0.0.1" ::[1] ]  
network.host: 127.0.0.1:9200

I can see that the service is running on port 9200. Heap memory and limit.conf settings are all increased. All values appears to be correct but still unable to figure out why this fails.

---

<div class="post-metadata">

### Author: ![reshma\_ramakrishnan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/reshma_ramakrishnan/32/63095_2.png) [@reshma\_ramakrishnan](https://discuss.elastic.co/u/reshma_ramakrishnan)
#### Post date: [February 21, 2020, 3:14pm UTC](https://discuss.elastic.co/t/installing-opendistro-es-on-amazon-linux-es-running-but-empty-reply-form-server/220318/2 "2020-02-21T15:14:27Z")

</div>

I figured out the solution: I added `discovery.type: single-node` to my elasticsear h.yml since I want to run single node and it worked.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [March 20, 2020, 3:14pm UTC](https://discuss.elastic.co/t/installing-opendistro-es-on-amazon-linux-es-running-but-empty-reply-form-server/220318/3 "2020-03-20T15:14:36Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
