# IntakeV2ReportingEventHandler - Failed to handle event of type METRICS with this error: access denied

**URL:** <https://discuss.elastic.co/t/intakev2reportingeventhandler-failed-to-handle-event-of-type-metrics-with-this-error-access-denied/241762>\
**Category:** APM\
**Tags:** java\
**Created:** [July 18, 2020, 8:37pm UTC](https://discuss.elastic.co/t/intakev2reportingeventhandler-failed-to-handle-event-of-type-metrics-with-this-error-access-denied/241762 "2020-07-18T20:37:55Z")\
**Posts on this page:** 1\
**Showing post:** 2

<div class="post-metadata">

**Author:** ![miker256](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/miker256/32/60563_2.png) [@miker256](https://discuss.elastic.co/u/miker256)\
**Post date:** [July 20, 2020, 12:24am UTC](https://discuss.elastic.co/t/intakev2reportingeventhandler-failed-to-handle-event-of-type-metrics-with-this-error-access-denied/241762/2 "2020-07-20T00:24:47Z")

</div>

This thread may help you out.

> [@\[apm-reporter\] ERROR co.elastic.apm.agent.report.IntakeV2ReportingEventHandler - Error sending data to APM server: cannot retry due to server authentication, in streaming mode, response code is 401](https://discuss.elastic.co/t/apm-reporter-error-co-elastic-apm-agent-report-intakev2reportingeventhandler-error-sending-data-to-apm-server-cannot-retry-due-to-server-authentication-in-streaming-mode-response-code-is-401/217564):
>
> Kibana version : 7.5.2 Elasticsearch version : 7.5.2 APM Server version : 7.5.2 \*\*APM Agent language \*\*: java Original install method : ECK operator 1.0.0 GA I have updated apm-server-quickstart-apm-token secret-token to a known value, but the apm agent is unable to connect to apm server, throwing authentication error. Please let me know which secret should i update for apm server to accept secret-token i have set

---

_[View the full topic](https://discuss.elastic.co/t/intakev2reportingeventhandler-failed-to-handle-event-of-type-metrics-with-this-error-access-denied/241762)._
