# Integrations doesn't get populated for agent policy under fleet server

**URL:** <https://discuss.elastic.co/t/integrations-doesnt-get-populated-for-agent-policy-under-fleet-server/365788>\
**Category:** Kibana\
**Tags:** fleet\
**Created:** [August 29, 2024, 5:48pm UTC](https://discuss.elastic.co/t/integrations-doesnt-get-populated-for-agent-policy-under-fleet-server/365788 "2024-08-29T17:48:02Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![AnyThink\_A](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/anythink_a/32/122141_2.png) [@AnyThink\_A](https://discuss.elastic.co/u/AnyThink_A)\
**Post date:** [August 29, 2024, 5:48pm UTC](https://discuss.elastic.co/t/integrations-doesnt-get-populated-for-agent-policy-under-fleet-server/365788/1 "2024-08-29T17:48:02Z")

</div>

Hello All,

I am trying create a fleet policy with integration, however, when click on integration it keeps loading and throws an error at the end.

I check kibana logs and it shows below error  
{"service":{"node":{"roles":["background\_tasks","ui"]}},"ecs":{"version":"8.11.0"},"@timestamp":"2024-08-29T17:44:14.575+00:00","message":"Error connecting to package registry: request to [https://epr.elastic.co/search?kibana.version=8.15.0](https://epr.elastic.co/search?kibana.version=8.15.0) failed, reason: unable to verify the first certificate","log":{"level":"ERROR","logger":"plugins.fleet"},"process":{"pid":903,"uptime":3856.396779622},"trace":{"id":"727cd961f93c9a9336e323e261659fd6"},"transaction":{"id":"7fb85f031d6bc3da"}}

The issue is related to certificate and I am not sure, how can I resolve it, since I am using it for personal LAB, I don't have third party certificate.

Kindly help me in this.

Regards,  
Ameer Mane

---

<div class="post-metadata">

**Author:** ![Julia\_Bardi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/julia_bardi/32/79463_2.png) [@Julia\_Bardi](https://discuss.elastic.co/u/Julia_Bardi)\
**Post date:** [October 14, 2024, 7:46am UTC](https://discuss.elastic.co/t/integrations-doesnt-get-populated-for-agent-policy-under-fleet-server/365788/2 "2024-10-14T07:46:38Z")

</div>

Hi,

Is this still happening? Are you using a firewall or proxy? The epr link is accessible.
