# Intermittent metric registration error: worker\_millis\_per\_event

**URL:** <https://discuss.elastic.co/t/intermittent-metric-registration-error-worker-millis-per-event/383836>\
**Category:** Logstash\
**Tags:** docker\
**Created:** [December 3, 2025, 9:36am UTC](https://discuss.elastic.co/t/intermittent-metric-registration-error-worker-millis-per-event/383836 "2025-12-03T09:36:48Z")\
**Posts on this page:** 1\
**Showing post:** 5

<div class="post-metadata">

**Author:** ![Rios](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rios/32/95745_2.png) [@Rios](https://discuss.elastic.co/u/Rios)\
**Post date:** [December 11, 2025, 10:23am UTC](https://discuss.elastic.co/t/intermittent-metric-registration-error-worker-millis-per-event/383836/5 "2025-12-11T10:23:19Z")

</div>

I don't know has been this solved, a few more tips:

- Set `LS_JAVA_PATH`. Check [this topic](https://discuss.elastic.co/t/logstash-setting-ls-java-home/307538) about Java path issues.
- Review `jvm.options`, `log4j2.properties` and JVM settings. Do you have upgraded LS version? Like from older 7.x or something? Check [this](https://www.elastic.co/guide/en/logstash/8.19/getting-started-with-logstash.html#jdk-upgrade) for any case.
- Maybe to try ​TAR.GZ version without docker, if is possible, at least temporarily.

---

_[View the full topic](https://discuss.elastic.co/t/intermittent-metric-registration-error-worker-millis-per-event/383836)._
