# Internal server 500 error - \[illegal\_argument\_exception\] application privileges must refer to at least one resource"}

**URL:** <https://discuss.elastic.co/t/internal-server-500-error-illegal-argument-exception-application-privileges-must-refer-to-at-least-one-resource/282564>\
**Category:** Kibana\
**Tags:** elastic-stack-security\
**Created:** [August 26, 2021, 10:56am UTC](https://discuss.elastic.co/t/internal-server-500-error-illegal-argument-exception-application-privileges-must-refer-to-at-least-one-resource/282564 "2021-08-26T10:56:46Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![rishabhcldcvr](https://avatars.discourse-cdn.com/v4/letter/r/c0e974/32.png) [@rishabhcldcvr](https://discuss.elastic.co/u/rishabhcldcvr)\
**Post date:** [August 26, 2021, 10:56am UTC](https://discuss.elastic.co/t/internal-server-500-error-illegal-argument-exception-application-privileges-must-refer-to-at-least-one-resource/282564/1 "2021-08-26T10:56:46Z")

</div>

ES master:

> # curl localhost:9200/
> 
> {  
> "name" : "AZPRDBRK007",  
> "cluster\_name" : "monitoring-cluster",  
> "cluster\_uuid" : "7n4PuY7FQgWSIS0-2LxCRg",  
> "version" : {  
> "number" : "7.9.0",  
> "build\_flavor" : "default",  
> "build\_type" : "deb",  
> "build\_hash" : "a479a2a7fce0389512d6a9361301708b92dff667",  
> "build\_date" : "2020-08-11T21:36:48.204330Z",  
> "build\_snapshot" : false,  
> "lucene\_version" : "8.6.0",  
> "minimum\_wire\_compatibility\_version" : "6.8.0",  
> "minimum\_index\_compatibility\_version" : "6.0.0-beta1"  
> },  
> "tagline" : "You Know, for Search"  
> }

Kibana verion: 7.9.3

I am getting **Internal server 500 error - [illegal\_argument\_exception] application privileges must refer to at least one resource"}** on accessing Kibana after I enter the elastic user name and password. Same goes for every user.

I have verified that the .kibana index is getting created when I delete it manually and restart the Kibana

Adding some stack trace from Kibana's logs

```auto
Aug 26 05:17:42 AZPRDBRK008 systemd[1]: Started Kibana.

Aug 26 05:17:50 AZPRDBRK008 kibana[25404]: {"type":"log","@timestamp":"2021-08-26T05:17:50Z","tags":["warning","plugins-discovery"],"pid":25404,"message":"Expect plugin \"id\" in camelCase, but found: beats_management"}

Aug 26 05:17:50 AZPRDBRK008 kibana[25404]: {"type":"log","@timestamp":"2021-08-26T05:17:50Z","tags":["warning","plugins-discovery"],"pid":25404,"message":"Expect plugin \"id\" in camelCase, but found: triggers_actions_ui"}
Aug 26 05:18:02 AZPRDBRK008 kibana[25404]: {"type":"log","@timestamp":"2021-08-26T05:18:02Z","tags":["info","plugins-service"],"pid":25404,"message":"Plugin \"visTypeXy\" is disabled."}
Aug 26 05:18:02 AZPRDBRK008 kibana[25404]: {"type":"log","@timestamp":"2021-08-26T05:18:02Z","tags":["info","plugins-service"],"pid":25404,"message":"Plugin \"auditTrail\" is disabled."}
Aug 26 05:18:02 AZPRDBRK008 kibana[25404]: {"type":"log","@timestamp":"2021-08-26T05:18:02Z","tags":["warning","config","deprecation"],"pid":25404,"message":"Config key [monitoring.cluster_alerts.email_notifications.email_address] will be required for email notifications to work in 8.0.\""}
Aug 26 05:18:03 AZPRDBRK008 kibana[25404]: {"type":"log","@timestamp":"2021-08-26T05:18:03Z","tags":["warning","plugins","security","config"],"pid":25404,"message":"Generating a random key for xpack.security.encryptionKey. To prevent sessions from being invalidated on restart, please set xpack.security.encryptionKey in kibana.yml"}

Aug 26 05:18:03 AZPRDBRK008 kibana[25404]: {"type":"log","@timestamp":"2021-08-26T05:18:03Z","tags":["warning","plugins","reporting","config"],"pid":25404,"message":"Generating a random key for xpack.reporting.encryptionKey. To prevent sessions from being invalidated on restart, please set xpack.reporting.encryptionKey in kibana.yml"}

Aug 26 05:18:03 AZPRDBRK008 kibana[25404]: {"type":"log","@timestamp":"2021-08-26T05:18:03Z","tags":["warning","plugins","encryptedSavedObjects","config"],"pid":25404,"message":"Generating a random key for xpack.encryptedSavedObjects.encryptionKey. To be able to decrypt encrypted saved objects attributes after restart, please set xpack.encryptedSavedObjects.encryptionKey in kibana.yml"}

Aug 26 05:18:03 AZPRDBRK008 kibana[25404]: {"type":"log","@timestamp":"2021-08-26T05:18:03Z","tags":["warning","plugins","ingestManager"],"pid":25404,"message":"Fleet APIs are disabled due to the Encrypted Saved Objects plugin using an ephemeral encryption key. Please set xpack.encryptedSavedObjects.encryptionKey in kibana.yml."}

Aug 26 05:18:03 AZPRDBRK008 kibana[25404]: {"type":"log","@timestamp":"2021-08-26T05:18:03Z","tags":["warning","plugins","actions","actions"],"pid":25404,"message":"APIs are disabled due to the Encrypted Saved Objects plugin using an ephemeral encryption key. Please set xpack.encryptedSavedObjects.encryptionKey in kibana.yml."}

Aug 26 05:18:03 AZPRDBRK008 kibana[25404]: {"type":"log","@timestamp":"2021-08-26T05:18:03Z","tags":["warning","plugins","alerts","plugins","alerting"],"pid":25404,"message":"APIs are disabled due to the Encrypted Saved Objects plugin using an ephemeral encryption key. Please set xpack.encryptedSavedObjects.encryptionKey in kibana.yml."}

Aug 26 05:18:03 AZPRDBRK008 kibana[25404]: {"type":"log","@timestamp":"2021-08-26T05:18:03Z","tags":["warning","plugins","monitoring","monitoring"],"pid":25404,"message":"X-Pack Monitoring Cluster Alerts will not be available: undefined"}

Aug 26 05:18:03 AZPRDBRK008 kibana[25404]: {"type":"log","@timestamp":"2021-08-26T05:18:03Z","tags":["info","plugins","reporting","config"],"pid":25404,"message":"Chromium sandbox provides an additional layer of protection, and is supported for Linux Ubuntu Linux 18.04 OS. Automatically enabling Chromium sandbox."}

Aug 26 05:18:03 AZPRDBRK008 kibana[25404]: {"type":"log","@timestamp":"2021-08-26T05:18:03Z","tags":["info","savedobjects-service"],"pid":25404,"message":"Waiting until all Elasticsearch nodes are compatible with Kibana before starting saved objects migrations..."}

Aug 26 05:18:03 AZPRDBRK008 kibana[25404]: {"type":"log","@timestamp":"2021-08-26T05:18:03Z","tags":["info","savedobjects-service"],"pid":25404,"message":"Starting saved objects migrations"}

Aug 26 05:18:04 AZPRDBRK008 kibana[25404]: {"type":"log","@timestamp":"2021-08-26T05:18:04Z","tags":["info","plugins-system"],"pid":25404,"message":"Starting [92] plugins: [taskManager,licensing,observability,globalSearch,globalSearchProviders,code,usageCollection,ossTelemetry,telemetryCollectionManager,telemetry,telemetryCollectionXpack,kibanaUsageCollection,newsfeed,mapsLegacy,kibanaLegacy,translations,timelion,share,legacyExport,esUiShared,bfetch,expressions,data,home,cloud,console,consoleExtensions,apmOss,searchprofiler,painlessLab,grokdebugger,management,upgradeAssistant,licenseManagement,indexPatternManagement,advancedSettings,fileUpload,dataEnhanced,savedObjects,visualizations,visTypeVega,visualize,visTypeTimelion,features,security,snapshotRestore,reporting,enterpriseSearch,encryptedSavedObjects,ingestManager,indexManagement,remoteClusters,crossClusterReplication,indexLifecycleManagement,beats_management,transform,ingestPipelines,maps,graph,canvas,visTypeTable,visTypeMarkdown,tileMap,regionMap,inputControlVis,dashboard,dashboardMode,charts,lens,visTypeVislib,visTypeTimeseries,rollup,visTypeTagcloud,visTypeMetric,watcher,discover,discoverEnhanced,savedObjectsManagement,spaces,lists,eventLog,actions,case,alerts,alertingBuiltins,ml,securitySolution,infra,monitoring,logstash,apm,uptime]"}

Aug 26 05:18:04 AZPRDBRK008 kibana[25404]: {"type":"log","@timestamp":"2021-08-26T05:18:04Z","tags":["info","plugins","taskManager","taskManager"],"pid":25404,"message":"TaskManager is identified by the Kibana UUID: 6175f21d-d4d8-44da-b8ff-8c0bf72675f1"}

Aug 26 05:18:04 AZPRDBRK008 kibana[25404]: {"type":"log","@timestamp":"2021-08-26T05:18:04Z","tags":["info","plugins","crossClusterReplication"],"pid":25404,"message":"Your basic license does not support crossClusterReplication. Please upgrade your license."}

Aug 26 05:18:04 AZPRDBRK008 kibana[25404]: {"type":"log","@timestamp":"2021-08-26T05:18:04Z","tags":["info","plugins","watcher"],"pid":25404,"message":"Your basic license does not support watcher. Please upgrade your license."}

Aug 26 05:18:04 AZPRDBRK008 kibana[25404]: {"type":"log","@timestamp":"2021-08-26T05:18:04Z","tags":["info","plugins","monitoring","monitoring","kibana-monitoring"],"pid":25404,"message":"Starting monitoring stats collection"}

Aug 26 05:18:05 AZPRDBRK008 kibana[25404]: {"type":"log","@timestamp":"2021-08-26T05:18:05Z","tags":["status","plugin:kibana@7.9.0","info"],"pid":25404,"state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"}

Aug 26 05:18:05 AZPRDBRK008 kibana[25404]: {"type":"log","@timestamp":"2021-08-26T05:18:05Z","tags":["status","plugin:elasticsearch@7.9.0","info"],"pid":25404,"state":"yellow","message":"Status changed from uninitialized to yellow - Waiting for Elasticsearch","prevState":"uninitialized","prevMsg":"uninitialized"}

Aug 26 05:18:05 AZPRDBRK008 kibana[25404]: {"type":"log","@timestamp":"2021-08-26T05:18:05Z","tags":["warning"],"pid":25404,"kibanaVersion":"7.9.0","nodes":[{"ip":"10.129.23.13","version":"7.9.3","http":{"publish_address":"10.129.23.13:9200"},"name":"v7.9.3 @ 10.129.23.13:9200 (10.129.23.13)"},{"ip":"10.129.23.12","version":"7.9.3","http":{"publish_address":"10.129.23.12:9200"},"name":"v7.9.3 @ 10.129.23.12:9200 (10.129.23.12)"},{"ip":"10.129.23.6","version":"7.9.3","http":{"publish_address":"10.129.23.6:9200"},"name":"v7.9.3 @ 10.129.23.6:9200 (10.129.23.6)"},{"ip":"10.129.23.14","version":"7.9.3","http":{"publish_address":"10.129.23.14:9200"},"name":"v7.9.3 @ 10.129.23.14:9200 (10.129.23.14)"}],"message":"You're running Kibana 7.9.0 with some different versions of Elasticsearch. Update Kibana or Elasticsearch to the same version to prevent compatibility issues: v7.9.3 @ 10.129.23.13:9200 (10.129.23.13), v7.9.3 @ 10.129.23.12:9200 (10.129.23.12), v7.9.3 @ 10.129.23.6:9200 (10.129.23.6), v7.9.3 @ 10.129.23.14:9200 (10.129.23.14)"}

Aug 26 05:18:05 AZPRDBRK008 kibana[25404]: {"type":"log","@timestamp":"2021-08-26T05:18:05Z","tags":["status","plugin:elasticsearch@7.9.0","info"],"pid":25404,"state":"green","message":"Status changed from yellow to green - Ready","prevState":"yellow","prevMsg":"Waiting for Elasticsearch"}

Aug 26 05:18:05 AZPRDBRK008 kibana[25404]: {"type":"log","@timestamp":"2021-08-26T05:18:05Z","tags":["status","plugin:xpack_main@7.9.0","info"],"pid":25404,"state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"}

Aug 26 05:18:05 AZPRDBRK008 kibana[25404]: {"type":"log","@timestamp":"2021-08-26T05:18:05Z","tags":["status","plugin:monitoring@7.9.0","info"],"pid":25404,"state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"}

Aug 26 05:18:05 AZPRDBRK008 kibana[25404]: {"type":"log","@timestamp":"2021-08-26T05:18:05Z","tags":["status","plugin:spaces@7.9.0","info"],"pid":25404,"state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"}

Aug 26 05:18:05 AZPRDBRK008 kibana[25404]: {"type":"log","@timestamp":"2021-08-26T05:18:05Z","tags":["status","plugin:security@7.9.0","info"],"pid":25404,"state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"}

Aug 26 05:18:05 AZPRDBRK008 kibana[25404]: {"type":"log","@timestamp":"2021-08-26T05:18:05Z","tags":["status","plugin:beats_management@7.9.0","info"],"pid":25404,"state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"}

Aug 26 05:18:06 AZPRDBRK008 kibana[25404]: {"type":"log","@timestamp":"2021-08-26T05:18:06Z","tags":["status","plugin:apm_oss@7.9.0","info"],"pid":25404,"state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"}

Aug 26 05:18:06 AZPRDBRK008 kibana[25404]: {"type":"log","@timestamp":"2021-08-26T05:18:06Z","tags":["status","plugin:console_legacy@7.9.0","info"],"pid":25404,"state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"}

Aug 26 05:18:06 AZPRDBRK008 kibana[25404]: {"type":"log","@timestamp":"2021-08-26T05:18:06Z","tags":["listening","info"],"pid":25404,"message":"Server running at https://0.0.0.0:5601"}

Aug 26 05:18:07 AZPRDBRK008 kibana[25404]: {"type":"log","@timestamp":"2021-08-26T05:18:07Z","tags":["info","http","server","Kibana"],"pid":25404,"message":"http server running at https://0.0.0.0:5601"}

Aug 26 05:18:25 AZPRDBRK008 kibana[25404]: {"type":"error","@timestamp":"2021-08-26T05:18:25Z","tags":["connection","client","error"],"pid":25404,"level":"error","error":{"message":"47621343212288:error:1408F09C:SSL routines:ssl3_get_record:http request:../deps/openssl/openssl/ssl/record/ssl3_record.c:322:\n","name":"Error","stack":"Error: 47621343212288:error:1408F09C:SSL routines:ssl3_get_record:http request:../deps/openssl/openssl/ssl/record/ssl3_record.c:322:\n"},"message":"47621343212288:error:1408F09C:SSL routines:ssl3_get_record:http request:../deps/openssl/openssl/ssl/record/ssl3_record.c:322:\n"}
Aug 26 05:19:37 AZPRDBRK008 kibana[25404]: {"type":"error","@timestamp":"2021-08-26T05:19:37Z","tags":["connection","client","error"],"pid":25404,"level":"error","error":{"message":"47621343212288:error:14094416:SSL routines:ssl3_read_bytes:sslv3 alert certificate unknown:../deps/openssl/openssl/ssl/record/rec_layer_s3.c:1550:SSL alert number 46\n","name":"Error","stack":"Error: 47621343212288:error:14094416:SSL routines:ssl3_read_bytes:sslv3 alert certificate unknown:../deps/openssl/openssl/ssl/record/rec_layer_s3.c:1550:SSL alert number 46\n"},"message":"47621343212288:error:14094416:SSL routines:ssl3_read_bytes:sslv3 alert certificate unknown:../deps/openssl/openssl/ssl/record/rec_layer_s3.c:1550:SSL alert number 46\n"}

```

---

<div class="post-metadata">

**Author:** ![alisongoryachev](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alisongoryachev/32/111352_2.png) [@alisongoryachev](https://discuss.elastic.co/u/alisongoryachev)\
**Post date:** [August 26, 2021, 2:00pm UTC](https://discuss.elastic.co/t/internal-server-500-error-illegal-argument-exception-application-privileges-must-refer-to-at-least-one-resource/282564/2 "2021-08-26T14:00:18Z")

</div>

Welcome, @rishabhcldcvr!

I noticed it looks like you are running ES v7.9.0 and Kibana v7.9.3, is that intentional? Are you attempting to upgrade to 7.9.3?

---

<div class="post-metadata">

**Author:** ![rishabhcldcvr](https://avatars.discourse-cdn.com/v4/letter/r/c0e974/32.png) [@rishabhcldcvr](https://discuss.elastic.co/u/rishabhcldcvr)\
**Post date:** [August 26, 2021, 3:22pm UTC](https://discuss.elastic.co/t/internal-server-500-error-illegal-argument-exception-application-privileges-must-refer-to-at-least-one-resource/282564/3 "2021-08-26T15:22:05Z")

</div>

Hey @alisongoryachev  
Thanks for the reply.

I have re-installed Kibana when this issue occured and after that it has been showing this kibana version mismatch. I have installed it using apt and there I specified the version for kibana=7.9.0. Event the apt list return kibana 7.9.0.

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/0/c/0cab9e279eb5f08b8fed5258445a861dc9c42f62.png)

This is the main error I am getting on opening Kibana console from browser.

```auto
Aug 26 11:48:35 AZPRDBRK008 kibana[13963]: {"type":"error","@timestamp":"2021-08-26T11:48:35Z","tags":[],"pid":13963,"level":"error","error":{"message":"Internal Server Error","name":"Error","stack":"Error: Internal Server Error\n at HapiResponseAdapter.toError (/usr/share/kibana/src/core/server/http/router/response_adapter.js:132:19)\n at HapiResponseAdapter.toHapiResponse (/usr/share/kibana/src/core/server/http/router/response_adapter.js:86:19)\n at HapiResponseAdapter.handle (/usr/share/kibana/src/core/server/http/router/response_adapter.js:81:17)\n at interceptRequest (/usr/share/kibana/src/core/server/http/lifecycle/on_post_auth.js:69:36)\n at process._tickCallback internal/process/next_tick.js:68:7)"},"url":{"protocol":null,"slashes":null,"auth":null,"host":null,"port":null,"hostname":null,"hash":null,"search":null,"query":{},"pathname":"/","path":"/","href":"/"},"message":"Internal Server Error"}

```

---

<div class="post-metadata">

**Author:** ![rishabhcldcvr](https://avatars.discourse-cdn.com/v4/letter/r/c0e974/32.png) [@rishabhcldcvr](https://discuss.elastic.co/u/rishabhcldcvr)\
**Post date:** [August 27, 2021, 9:00am UTC](https://discuss.elastic.co/t/internal-server-500-error-illegal-argument-exception-application-privileges-must-refer-to-at-least-one-resource/282564/5 "2021-08-27T09:00:16Z")

</div>

Today I re-installed the whole ES Cluster but still getting the same error

```auto
Aug 27 08:39:03 AZPRDBRK008 kibana[5718]: {"type":"error","@timestamp":"2021-08-27T08:39:03Z","tags":[],"pid":5718,"level":"error","error":{"message":"Internal Server Error","name":"Error","stack":"Error: Internal Server Error\n at HapiResponseAdapter.toError (/usr/share/kibana/src/core/server/http/router/response_adapter.js:132:19)\n at HapiResponseAdapter.toHapiResponse (/usr/share/kibana/src/core/server/http/router/response_adapter.js:86:19)\n at HapiResponseAdapter.handle (/usr/share/kibana/src/core/server/http/router/response_adapter.js:81:17)\n at interceptRequest (/usr/share/kibana/src/core/server/http/lifecycle/on_post_auth.js:69:36)\n at process._tickCallback (internal/process/next_tick.js:68:7)"},"url":{"protocol":null,"slashes":null,"auth":null,"host":null,"port":null,"hostname":null,"hash":null,"search":null,"query":{},"pathname":"/","path":"/","href":"/"},"message":"Internal Server Error"}
Aug 27 08:39:03 AZPRDBRK008 kibana[5718]: {"type":"response","@timestamp":"2021-08-27T08:39:03Z","tags":[],"pid":5718,"method":"get","statusCode":500,"req":{"url":"/","method":"get","headers":{"host":"<URL>:5601","connection":"keep-alive","sec-ch-ua":"\"Chromium\";v=\"92\", \" Not A;Brand\";v=\"99\", \"Google Chrome\";v=\"92\"","sec-ch-ua-mobile":"?0","upgrade-insecure-requests":"1","user-agent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/92.0.4515.159 Safari/537.36","accept":"text/html,application/xhtml+xml,application/xml;q=0.9,image/avif,image/webp,image/apng,*/*;q=0.8,application/signed-exchange;v=b3;q=0.9","purpose":"prefetch","sec-fetch-site":"none","sec-fetch-mode":"navigate","sec-fetch-user":"?1","sec-fetch-dest":"document","accept-encoding":"gzip, deflate, br","accept-language":"en-US,en;q=0.9"},"remoteAddress":"172.24.41.13","userAgent":"172.24.41.13"},"res":{"statusCode":500,"responseTime":307,"contentLength":9},"message":"GET / 500 307ms - 9.0B"}
Aug 27 08:39:04 AZPRDBRK008 kibana[5718]: {"type":"error","@timestamp":"2021-08-27T08:39:04Z","tags":[],"pid":5718,"level":"error","error":{"message":"Internal Server Error","name":"Error","stack":"Error: Internal Server Error\n at HapiResponseAdapter.toError (/usr/share/kibana/src/core/server/http/router/response_adapter.js:132:19)\n at HapiResponseAdapter.toHapiResponse (/usr/share/kibana/src/core/server/http/router/response_adapter.js:86:19)\n at HapiResponseAdapter.handle (/usr/share/kibana/src/core/server/http/router/response_adapter.js:81:17)\n at interceptRequest (/usr/share/kibana/src/core/server/http/lifecycle/on_post_auth.js:69:36)\n at process._tickCallback (internal/process/next_tick.js:68:7)"},"url":{"protocol":null,"slashes":null,"auth":null,"host":null,"port":null,"hostname":null,"hash":null,"search":null,"query":{},"pathname":"/","path":"/","href":"/"},"message":"Internal Server Error"}
Aug 27 08:39:04 AZPRDBRK008 kibana[5718]: {"type":"response","@timestamp":"2021-08-27T08:39:04Z","tags":[],"pid":5718,"method":"get","statusCode":500,"req":{"url":"/","method":"get","headers":{"host":"<URL>:5601","connection":"keep-alive","sec-ch-ua":"\"Chromium\";v=\"92\", \" Not A;Brand\";v=\"99\", \"Google Chrome\";v=\"92\"","sec-ch-ua-mobile":"?0","upgrade-insecure-requests":"1","user-agent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/92.0.4515.159 Safari/537.36","accept":"text/html,application/xhtml+xml,application/xml;q=0.9,image/avif,image/webp,image/apng,*/*;q=0.8,application/signed-exchange;v=b3;q=0.9","sec-fetch-site":"none","sec-fetch-mode":"navigate","sec-fetch-user":"?1","sec-fetch-dest":"document","accept-encoding":"gzip, deflate, br","accept-language":"en-US,en;q=0.9"},"remoteAddress":"172.24.41.13","userAgent":"172.24.41.13"},"res":{"statusCode":500,"responseTime":217,"contentLength":9},"message":"GET / 500 217ms - 9.0B"}
Aug 27 08:39:12 AZPRDBRK008 kibana[5718]: {"type":"response","@timestamp":"2021-08-27T08:39:12Z","tags":[],"pid":5718,"method":"get","statusCode":404,"req":{"url":"/app/kibana","method":"get","headers":{"host":"<URL>:5601","connection":"keep-alive","sec-ch-ua":"\"Chromium\";v=\"92\", \" Not A;Brand\";v=\"99\", \"Google Chrome\";v=\"92\"","sec-ch-ua-mobile":"?0","upgrade-insecure-requests":"1","user-agent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/92.0.4515.159 Safari/537.36","accept":"text/html,application/xhtml+xml,application/xml;q=0.9,image/avif,image/webp,image/apng,*/*;q=0.8,application/signed-exchange;v=b3;q=0.9","sec-fetch-site":"none","sec-fetch-mode":"navigate","sec-fetch-user":"?1","sec-fetch-dest":"document","accept-encoding":"gzip, deflate, br","accept-language":"en-US,en;q=0.9"},"remoteAddress":"172.24.41.13","userAgent":"172.24.41.13"},"res":{"statusCode":404,"responseTime":195,"contentLength":9},"message":"GET /app/kibana 404 195ms - 9.0B"}
Aug 27 08:39:38 AZPRDBRK008 kibana[5718]: {"type":"error","@timestamp":"2021-08-27T08:39:38Z","tags":["connection","client","error"],"pid":5718,"level":"error","error":{"message":"47450253857536:error:14094416:SSL routines:ssl3_read_bytes:sslv3 alert certificate unknown:../deps/openssl/openssl/ssl/record/rec_layer_s3.c:1550:SSL alert number 46\n","name":"Error","stack":"Error: 47450253857536:error:14094416:SSL routines:ssl3_read_bytes:sslv3 alert certificate unknown:../deps/openssl/openssl/ssl/record/rec_layer_s3.c:1550:SSL alert number 46\n"},"message":"47450253857536:error:14094416:SSL routines:ssl3_read_bytes:sslv3 alert certificate unknown:../deps/openssl/openssl/ssl/record/rec_layer_s3.c:1550:SSL alert number 46\n"}
Aug 27 08:39:58 AZPRDBRK008 kibana[5718]: {"type":"response","@timestamp":"2021-08-27T08:39:58Z","tags":[],"pid":5718,"method":"get","statusCode":404,"req":{"url":"/app/kibana","method":"get","headers":{"host":"<URL>:5601","connection":"keep-alive","cache-control":"max-age=0","sec-ch-ua":"\"Chromium\";v=\"92\", \" Not A;Brand\";v=\"99\", \"Google Chrome\";v=\"92\"","sec-ch-ua-mobile":"?0","upgrade-insecure-requests":"1","user-agent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/92.0.4515.159 Safari/537.36","accept":"text/html,application/xhtml+xml,application/xml;q=0.9,image/avif,image/webp,image/apng,*/*;q=0.8,application/signed-exchange;v=b3;q=0.9","sec-fetch-site":"none","sec-fetch-mode":"navigate","sec-fetch-user":"?1","sec-fetch-dest":"document","accept-encoding":"gzip, deflate, br","accept-language":"en-US,en;q=0.9"},"remoteAddress":"172.24.41.13","userAgent":"172.24.41.13"},"res":{"statusCode":404,"responseTime":125,"contentLength":9},"message":"GET /app/kibana 404 125ms - 9.0B"}
Aug 27 08:40:38 AZPRDBRK008 kibana[5718]: {"type":"error","@timestamp":"2021-08-27T08:40:38Z","tags":["connection","client","error"],"pid":5718,"level":"error","error":{"message":"47450253857536:error:14094416:SSL routines:ssl3_read_bytes:sslv3 alert certificate unknown:../deps/openssl/openssl/ssl/record/rec_layer_s3.c:1550:SSL alert number 46\n","name":"Error","stack":"Error: 47450253857536:error:14094416:SSL routines:ssl3_read_bytes:sslv3 alert certificate unknown:../deps/openssl/openssl/ssl/record/rec_layer_s3.c:1550:SSL alert number 46\n"},"message":"47450253857536:error:14094416:SSL routines:ssl3_read_bytes:sslv3 alert certificate unknown:../deps/openssl/openssl/ssl/record/rec_layer_s3.c:1550:SSL alert number 46\n"}

```

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [August 30, 2021, 12:23am UTC](https://discuss.elastic.co/t/internal-server-500-error-illegal-argument-exception-application-privileges-must-refer-to-at-least-one-resource/282564/6 "2021-08-30T00:23:51Z")

</div>

It looks like there is a problem with your TLS.  
What documentation did you follow to setup Security?  
Can you show your Elasticsearch and Kibana config?

---

<div class="post-metadata">

**Author:** ![rishabhcldcvr](https://avatars.discourse-cdn.com/v4/letter/r/c0e974/32.png) [@rishabhcldcvr](https://discuss.elastic.co/u/rishabhcldcvr)\
**Post date:** [August 30, 2021, 11:33am UTC](https://discuss.elastic.co/t/internal-server-500-error-illegal-argument-exception-application-privileges-must-refer-to-at-least-one-resource/282564/7 "2021-08-30T11:33:27Z")

</div>

Hi @warkolm  
This was setup one year back and it was running but someone has made changes which no one was aware of what changes were done.  
I have installed 7.14.0 version of ES and Kibana after facing issue for such long and it is working now using the same configuration files.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 27, 2021, 11:34am UTC](https://discuss.elastic.co/t/internal-server-500-error-illegal-argument-exception-application-privileges-must-refer-to-at-least-one-resource/282564/8 "2021-09-27T11:34:22Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
