# Internal server error when defining index pattern in kibana

**URL:** <https://discuss.elastic.co/t/internal-server-error-when-defining-index-pattern-in-kibana/240252>\
**Category:** Kibana\
**Created:** [July 8, 2020, 2:58am UTC](https://discuss.elastic.co/t/internal-server-error-when-defining-index-pattern-in-kibana/240252 "2020-07-08T02:58:26Z")\
**Posts on this page:** 11\
**Page:** 1

<div class="post-metadata">

**Author:** ![Evelyn233](https://avatars.discourse-cdn.com/v4/letter/e/85e7bf/32.png) [@Evelyn233](https://discuss.elastic.co/u/Evelyn233)\
**Post date:** [July 8, 2020, 2:58am UTC](https://discuss.elastic.co/t/internal-server-error-when-defining-index-pattern-in-kibana/240252/1 "2020-07-08T02:58:26Z")

</div>

when i trying to define a new index pattern in kibana, it doesn't word due to the internal server error. i don't know how to fix it.

 ![internal server error](https://us1.discourse-cdn.com/elastic/original/3X/0/6/0677605bde2c128d8c5c80248c4b0281a184f1fa.png)  
this is the display of kibana

and this is the status of my index

 ![index](https://us1.discourse-cdn.com/elastic/original/3X/f/8/f8cc87b0db5e525b9b21865e9e3a2cf2c9a4b1de.png)

the system i use is centos7

---

<div class="post-metadata">

**Author:** ![Evelyn233](https://avatars.discourse-cdn.com/v4/letter/e/85e7bf/32.png) [@Evelyn233](https://discuss.elastic.co/u/Evelyn233)\
**Post date:** [July 8, 2020, 2:59am UTC](https://discuss.elastic.co/t/internal-server-error-when-defining-index-pattern-in-kibana/240252/2 "2020-07-08T02:59:03Z")

</div>

please help me, i am very anxious and confused about what is going on in it

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [July 8, 2020, 3:21am UTC](https://discuss.elastic.co/t/internal-server-error-when-defining-index-pattern-in-kibana/240252/3 "2020-07-08T03:21:27Z")

</div>

What do your Kibana logs show?

---

<div class="post-metadata">

**Author:** ![Evelyn233](https://avatars.discourse-cdn.com/v4/letter/e/85e7bf/32.png) [@Evelyn233](https://discuss.elastic.co/u/Evelyn233)\
**Post date:** [July 9, 2020, 7:06am UTC](https://discuss.elastic.co/t/internal-server-error-when-defining-index-pattern-in-kibana/240252/4 "2020-07-09T07:06:43Z")

</div>

> [@warkolm](#):
>
> What do your Kibana logs show?

sorry, i don't know how to check my kibana log

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [July 9, 2020, 7:59am UTC](https://discuss.elastic.co/t/internal-server-error-when-defining-index-pattern-in-kibana/240252/5 "2020-07-09T07:59:18Z")

</div>

How did you install Kibana, RPM? If so then it's in `/var/log/kibana/kibana.log`

---

<div class="post-metadata">

**Author:** ![Evelyn233](https://avatars.discourse-cdn.com/v4/letter/e/85e7bf/32.png) [@Evelyn233](https://discuss.elastic.co/u/Evelyn233)\
**Post date:** [July 9, 2020, 9:43am UTC](https://discuss.elastic.co/t/internal-server-error-when-defining-index-pattern-in-kibana/240252/6 "2020-07-09T09:43:11Z")

</div>

thankyou, now i have solved the problem ,thankyou 😘

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [July 12, 2020, 10:16pm UTC](https://discuss.elastic.co/t/internal-server-error-when-defining-index-pattern-in-kibana/240252/7 "2020-07-12T22:16:33Z")

</div>

Please share the solution in the thread, it might help someone in future 🙂

---

<div class="post-metadata">

**Author:** ![Sai\_Avinash\_Duddupud](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sai_avinash_duddupud/32/48265_2.png) [@Sai\_Avinash\_Duddupud](https://discuss.elastic.co/u/Sai_Avinash_Duddupud)\
**Post date:** [July 13, 2020, 9:11am UTC](https://discuss.elastic.co/t/internal-server-error-when-defining-index-pattern-in-kibana/240252/8 "2020-07-13T09:11:01Z")

</div>

@Evelyn233 I am facing the same issue. Please tell how to fix this

> [@Kibana throws error while creating index pattern](https://discuss.elastic.co/t/kibana-throws-error-while-creating-index-pattern/240932):
>
> I have setup logstash on server1 which is sending data to elastic-search(server2) so that I visualise the same in Kibana but when I am creating index patter it throws Internal Server Error as show in the following image. Please suggest how to fix this? [[enter image description here]](https://i.stack.imgur.com/x2jUw.png)

cc - @warkolm

---

<div class="post-metadata">

**Author:** ![Evelyn233](https://avatars.discourse-cdn.com/v4/letter/e/85e7bf/32.png) [@Evelyn233](https://discuss.elastic.co/u/Evelyn233)\
**Post date:** [July 14, 2020, 2:35am UTC](https://discuss.elastic.co/t/internal-server-error-when-defining-index-pattern-in-kibana/240252/9 "2020-07-14T02:35:33Z")

</div>

this is because my disc is full.

---

<div class="post-metadata">

**Author:** ![Evelyn233](https://avatars.discourse-cdn.com/v4/letter/e/85e7bf/32.png) [@Evelyn233](https://discuss.elastic.co/u/Evelyn233)\
**Post date:** [July 14, 2020, 2:36am UTC](https://discuss.elastic.co/t/internal-server-error-when-defining-index-pattern-in-kibana/240252/10 "2020-07-14T02:36:55Z")

</div>

this problem is due to my full disc, after i expand my disc, i can run kibana. thk

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 11, 2020, 2:36am UTC](https://discuss.elastic.co/t/internal-server-error-when-defining-index-pattern-in-kibana/240252/11 "2020-08-11T02:36:57Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
