# Internal Server Error

**URL:** <https://discuss.elastic.co/t/internal-server-error/283612>\
**Category:** Elasticsearch\
**Tags:** snapshot-and-restore\
**Created:** [September 8, 2021, 5:58am UTC](https://discuss.elastic.co/t/internal-server-error/283612 "2021-09-08T05:58:41Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Busra\_Duygu](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/busra_duygu/32/90462_2.png) [@Busra\_Duygu](https://discuss.elastic.co/u/Busra_Duygu)\
**Post date:** [September 8, 2021, 5:58am UTC](https://discuss.elastic.co/t/internal-server-error/283612/1 "2021-09-08T05:58:41Z")

</div>

Hello dear friends 🙂 I have a problem. First thing I want to do is: I want to backup the indexes I created before, so I created some folders in "C:\ "and added them to my elasticsearch.yml file.Then I restarted elasticsearch from task manager. Then I ran the kibana.bat file. When I make a query in Kibana, I get an error like "doesn't match any of the locations specified by path.repo because this setting is empty".If I want to create a new repository by following the path below on the kibana side, an error appears in the kiabana.bat file.

**my elasticsearch.yml file:**

```auto
# ----------------------------------- Paths ------------------------------------
#
# Path to directory where to store the data (separate multiple locations by comma):
#s
path.data: C:/data
#
# Path to log files:
#
path.logs: C:/logs
path.repo: C:/esbackup
#

```

**The query and error message I'm trying to run on the kibana dev tools side:**

```auto
PUT /_snapshot/esbackup
{
  "type": "fs",
  "settings": {
    "location": "C:/esbackup",
    "compress": true
  }
}
Error message:

"error" : {
    "root_cause" : [
      {
        "type" : "repository_exception",
        "reason" : "[esbackup] location [C:/esbackup] doesn't match any of the locations specified by path.repo because this setting is empty"
      }
    ],
    "type" : "repository_exception",
    "reason" : "[esbackup] failed to create repository",
    "caused_by" : {
      "type" : "repository_exception",
      "reason" : "[esbackup] location [C:/esbackup] doesn't match any of the locations specified by path.repo because this setting is empty"
    }
  },
  "status" : 500
}

```

**When I want to create a new repository by following this path on the kibana side (Dashboard\>Snapshot and Restore\>Repositories\>Register a repository), the error message I get from the kibana.bat file is:**

```auto
 Error: Internal Server Error
    at HapiResponseAdapter.toError (C:\elastic_stack\kibana-7.13.2-windows-x86_64\src\core\server\http\router\response_adapter.js:124:19)
    at HapiResponseAdapter.toHapiResponse (C:\elastic_stack\kibana-7.13.2-windows-x86_64\src\core\server\http\router\response_adapter.js:78:19)
    at HapiResponseAdapter.handle (C:\elastic_stack\kibana-7.13.2-windows-x86_64\src\core\server\http\router\response_adapter.js:73:17)
    at Router.handle (C:\elastic_stack\kibana-7.13.2-windows-x86_64\src\core\server\http\router\router.js:164:34)
    at runMicrotasks (<anonymous>)
    at processTicksAndRejections (internal/process/task_queues.js:93:5)
    at handler (C:\elastic_stack\kibana-7.13.2-windows-x86_64\src\core\server\http\router\router.js:124:50)
    at exports.Manager.execute (C:\elastic_stack\kibana-7.13.2-windows-x86_64\node_modules\@hapi\hapi\lib\toolkit.js:60:28)
    at Object.internals.handler (C:\elastic_stack\kibana-7.13.2-windows-x86_64\node_modules\@hapi\hapi\lib\handler.js:46:20)
    at exports.execute (C:\elastic_stack\kibana-7.13.2-windows-x86_64\node_modules\@hapi\hapi\lib\handler.js:31:20)
    at Request._lifecycle (C:\elastic_stack\kibana-7.13.2-windows-x86_64\node_modules\@hapi\hapi\lib\request.js:370:32)
    at Request._execute (C:\elastic_stack\kibana-7.13.2-windows-x86_64\node_modules\@hapi\hapi\lib\request.js:279:9)

```

I would be very happy if you help me 🤗

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [September 9, 2021, 12:16am UTC](https://discuss.elastic.co/t/internal-server-error/283612/2 "2021-09-09T00:16:51Z")

</div>

Did you get this fixed?  
I am guessing you did based on your other topic - [Error: Invalid snapshot name snapshot with the same name already in-progress](https://discuss.elastic.co/t/error-invalid-snapshot-name-snapshot-with-the-same-name-already-in-progress/283661)

---

<div class="post-metadata">

**Author:** ![Busra\_Duygu](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/busra_duygu/32/90462_2.png) [@Busra\_Duygu](https://discuss.elastic.co/u/Busra_Duygu)\
**Post date:** [October 5, 2021, 8:19am UTC](https://discuss.elastic.co/t/internal-server-error/283612/3 "2021-10-05T08:19:44Z")

</div>

Yes yes the problem is not caused by my incorrect use of / or . I made a mistake while editing the environment variables.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 2, 2021, 8:20am UTC](https://discuss.elastic.co/t/internal-server-error/283612/4 "2021-11-02T08:20:41Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
