# Invalid value "persisted", Options are : \["memory","persisted"\] in 7.9.2 logstash

**URL:** <https://discuss.elastic.co/t/invalid-value-persisted-options-are-memory-persisted-in-7-9-2-logstash/268633>\
**Category:** Logstash\
**Created:** [March 29, 2021, 7:01am UTC](https://discuss.elastic.co/t/invalid-value-persisted-options-are-memory-persisted-in-7-9-2-logstash/268633 "2021-03-29T07:01:52Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Kshema](https://avatars.discourse-cdn.com/v4/letter/k/cc9497/32.png) [@Kshema](https://discuss.elastic.co/u/Kshema)\
**Post date:** [March 29, 2021, 7:01am UTC](https://discuss.elastic.co/t/invalid-value-persisted-options-are-memory-persisted-in-7-9-2-logstash/268633/1 "2021-03-29T07:01:52Z")

</div>

In 7.9.2 version of logstash, when logstash is run using pipelines.yml, an error occurs saying  
`"Invalid value \"persisted#\". Options are : \"persisted\", \"memory\" ".`

The error occurs in `settings.rb` file validate(value) function.

In `logstash.yml`, the configurations are made properly as follows:  
`queue.type: persisted`

Tried different variations for this configuration, still the same error comes up:  
`queue.type: "persisted"`  
`queue.type: "memory"`

Also, commented out this line. The error still persists.

Please provide any suggestions on how this issue can be resolved.

Thanks, in advance.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 26, 2021, 7:02am UTC](https://discuss.elastic.co/t/invalid-value-persisted-options-are-memory-persisted-in-7-9-2-logstash/268633/2 "2021-04-26T07:02:02Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
