# Invalid version of beats protocol

**URL:** https://discuss.elastic.co/t/invalid-version-of-beats-protocol/223769
**Category:** Logstash
**Created:** [March 16, 2020, 1:33pm UTC](https://discuss.elastic.co/t/invalid-version-of-beats-protocol/223769 "2020-03-16T13:33:12Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![sam6](https://avatars.discourse-cdn.com/v4/letter/s/7c8e57/32.png) [@sam6](https://discuss.elastic.co/u/sam6)
#### Post date: [March 16, 2020, 1:33pm UTC](https://discuss.elastic.co/t/invalid-version-of-beats-protocol/223769/1 "2020-03-16T13:33:12Z")

</div>

Hi,

TLS is not enabled on the filebeat or logstash config and im seeing the below error when trying to ingest logs from a fllebeats agent:

[2020-03-16T13:12:20,101][INFO][org.logstash.beats.BeatsHandler][main] [local: 10.142.43.22:5044, remote: 10.142.32.56:55350] Handling exception: org.logstash.beats.InvalidFrameProtocolException: Invalid version of beats protocol: 71  
[2020-03-16T13:12:20,104][WARN][io.netty.channel.DefaultChannelPipeline][main] An exceptionCaught() event was fired, and it reached at the tail of the pipeline. It usually means the last handler in the pipeline did not handle the exception.

Another error follows but with Invalid version of beats protocol: 69

Logstash Version: 7.6.1 Tried AmazonLinux and Ubuntu 18.04  
Filebeats Version 7.6.1 AmazonLinux & Win2019 (also tried 7.4.0 on AmazonLinux)

Filebeat config:

#----------------------------- Logstash output --------------------------------  
#output.logstash:

# The Logstash hosts

hosts: ["[http://10.142.43.22:5044](http://10.142.43.22:5044)"]

# Optional SSL. By default is off.

# List of root certificates for HTTPS server verifications

#ssl.certificate\_authorities: ["/etc/pki/root/ca.pem"]

# Certificate for SSL client authentication

#ssl.certificate: "/etc/pki/client/cert.pem"

# Client Certificate Key

#ssl.key: "/etc/pki/client/cert.key"

Logstash Config:

input {  
beats {  
port =\> 5044  
}  
}

A curl test triggers the same error.

Have also configured TLS, verified certs with openssl and get the same errors with TLS enabled.

Enabled debug logging but it didnt provide any further clues as to the cause of the issue from what i could tell.

Any assistance on this would be greatly appreciated.

Cheers

Sam

---

<div class="post-metadata">

### Author: ![sam6](https://avatars.discourse-cdn.com/v4/letter/s/7c8e57/32.png) [@sam6](https://discuss.elastic.co/u/sam6)
#### Post date: [March 16, 2020, 3:17pm UTC](https://discuss.elastic.co/t/invalid-version-of-beats-protocol/223769/2 "2020-03-16T15:17:52Z")

</div>

I had left the below line in the filebeats.yml file comented so it was trying to communicate using the elasticsearch protocol which is not hashed by default:

output.logstash:

Thankyou Andrew\_Cholakian for this post:

> [@Failed to connect to backoff(elasticsearch(http://10.80.1.220:5044)): read: connection reset by peer](https://discuss.elastic.co/t/failed-to-connect-to-backoff-elasticsearch-http-10-80-1-220-5044-read-connection-reset-by-peer/186342):
>
> Hi, I am getting "Connection reset by peer" error while starting the heartbeat. I have tried almost all the solutions given online but none of them worked. Please find the details below: Elastic Search running on Security Onion 16.04.6.1 - IP: 10.80.1.220 ELK Stack Version: 6.7.2 Host A: 10.80.1.18 Heartbeat version: Tried both 6.7.1 and 7.1 but same result. Heartbeat Log File: 2019-06-18T15:16:21.001-0400 DEBUG [elasticsearch] elasticsearch/client.go:710 ES Ping(url=http://10.80.1.220:5…

I now have new errors to resolve 🙂

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [April 13, 2020, 3:17pm UTC](https://discuss.elastic.co/t/invalid-version-of-beats-protocol/223769/3 "2020-04-13T15:17:53Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
