# Invalid version of beats protocol

**URL:** https://discuss.elastic.co/t/invalid-version-of-beats-protocol/223769
**Category:** Logstash
**Created:** [March 16, 2020, 1:33pm UTC](https://discuss.elastic.co/t/invalid-version-of-beats-protocol/223769 "2020-03-16T13:33:12Z")
**Posts on this page:** 1
**Showing post:** 2

<div class="post-metadata">

### Author: ![sam6](https://avatars.discourse-cdn.com/v4/letter/s/7c8e57/32.png) [@sam6](https://discuss.elastic.co/u/sam6)
#### Post date: [March 16, 2020, 3:17pm UTC](https://discuss.elastic.co/t/invalid-version-of-beats-protocol/223769/2 "2020-03-16T15:17:52Z")

</div>

I had left the below line in the filebeats.yml file comented so it was trying to communicate using the elasticsearch protocol which is not hashed by default:

output.logstash:

Thankyou Andrew\_Cholakian for this post:

> [@Failed to connect to backoff(elasticsearch(http://10.80.1.220:5044)): read: connection reset by peer](https://discuss.elastic.co/t/failed-to-connect-to-backoff-elasticsearch-http-10-80-1-220-5044-read-connection-reset-by-peer/186342):
>
> Hi, I am getting "Connection reset by peer" error while starting the heartbeat. I have tried almost all the solutions given online but none of them worked. Please find the details below: Elastic Search running on Security Onion 16.04.6.1 - IP: 10.80.1.220 ELK Stack Version: 6.7.2 Host A: 10.80.1.18 Heartbeat version: Tried both 6.7.1 and 7.1 but same result. Heartbeat Log File: 2019-06-18T15:16:21.001-0400 DEBUG [elasticsearch] elasticsearch/client.go:710 ES Ping(url=http://10.80.1.220:5…

I now have new errors to resolve 🙂

---

_[View the full topic](https://discuss.elastic.co/t/invalid-version-of-beats-protocol/223769)._
