# Is it necessary to give only elasticsearch master nodes in kibana config

**URL:** https://discuss.elastic.co/t/is-it-necessary-to-give-only-elasticsearch-master-nodes-in-kibana-config/275543
**Category:** Kibana
**Created:** [June 10, 2021, 9:01am UTC](https://discuss.elastic.co/t/is-it-necessary-to-give-only-elasticsearch-master-nodes-in-kibana-config/275543 "2021-06-10T09:01:27Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![elk11](https://avatars.discourse-cdn.com/v4/letter/e/45deac/32.png) [@elk11](https://discuss.elastic.co/u/elk11)
#### Post date: [June 10, 2021, 9:01am UTC](https://discuss.elastic.co/t/is-it-necessary-to-give-only-elasticsearch-master-nodes-in-kibana-config/275543/1 "2021-06-10T09:01:27Z")

</div>

Elasticsearch and Kibana version: 7.3.1

I'm deploying Elasticsearch (3 nodes) and Kibana on docker.

node1: elasticsearch master(data) and kibana  
node2: elasticsearch (data)  
node3: elasticsearch (data)

our kibana config looks like this:

```auto
server.name: kibana
elasticsearch.hosts: ["http://node1:9200"]
elasticsearch.requestTimeout: 60000

```

with above setup Kibana won't start up with following error:

```auto
{"type":"log","@timestamp":"2021-06-10T08:51:41Z","tags":["error","elasticsearch","admin"],"pid":6,"message":"Request error, retrying\nGET http://node1:9200/_nodes?filter_path=nodes.*.version%2Cnodes.*.http.publish_address%2Cnodes.*.ip => connect EHOSTUNREACH xx.xx.xx.xx:9200"}
{"type":"log","@timestamp":"2021-06-10T08:51:42Z","tags":["warning","elasticsearch","admin"],"pid":6,"message":"Unable to revive connection: http://node1:9200/"}
{"type":"log","@timestamp":"2021-06-10T08:51:42Z","tags":["warning","elasticsearch","admin"],"pid":6,"message":"No living connections"}

```

When I do curl request from kibana container to master node, I get `No route to host`. But curl request to other elasticsearch node (on different VM works).

So as a workaround I'm planning to add all three nodes to `elasticsearch.hosts` in `kibana.yaml`. Is that okay? Or it needs to connect to master node specifically?

---

<div class="post-metadata">

### Author: ![Marius\_Dragomir](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/marius_dragomir/32/42087_2.png) [@Marius\_Dragomir](https://discuss.elastic.co/u/Marius_Dragomir)
#### Post date: [June 15, 2021, 1:57pm UTC](https://discuss.elastic.co/t/is-it-necessary-to-give-only-elasticsearch-master-nodes-in-kibana-config/275543/2 "2021-06-15T13:57:55Z")

</div>

That looks like a hostname unreachable issue. I would check the docker compose file. You only need to point to the master node normally in kibana.yml.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 13, 2021, 1:58pm UTC](https://discuss.elastic.co/t/is-it-necessary-to-give-only-elasticsearch-master-nodes-in-kibana-config/275543/3 "2021-07-13T13:58:33Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
