# Is kibana send e-mail bug fixed in 6.1.2?

**URL:** <https://discuss.elastic.co/t/is-kibana-send-e-mail-bug-fixed-in-6-1-2/117285>\
**Category:** Kibana\
**Created:** [January 27, 2018, 6:23am UTC](https://discuss.elastic.co/t/is-kibana-send-e-mail-bug-fixed-in-6-1-2/117285 "2018-01-27T06:23:08Z")\
**Posts on this page:** 11\
**Page:** 1

<div class="post-metadata">

**Author:** ![yuluopiaoyang](https://avatars.discourse-cdn.com/v4/letter/y/bbce88/32.png) [@yuluopiaoyang](https://discuss.elastic.co/u/yuluopiaoyang)\
**Post date:** [January 27, 2018, 6:23am UTC](https://discuss.elastic.co/t/is-kibana-send-e-mail-bug-fixed-in-6-1-2/117285/1 "2018-01-27T06:23:08Z")

</div>

Is kibana alert send e-mail bug fixed in 6.1.2? I still can't send e-mail.Or I have some wrong in config?This is my config.  
xpack.notification.email.account:  
outlook\_account:  
profile: outlook  
email\_defaults:  
from: [cipublic@xxxx.com](mailto:cipublic@xxxx.com)  
smtp:  
auth: true  
starttls.enable: true  
host: [smtpscn.xxxx.com](http://smtpscn.xxxx.com)  
port: 50  
user: pmail\_CIpublic  
password: XXXXX

My mailbox is inside company [mailbox.Is](http://mailbox.Is) the port number must 587 or any other port number?  
Is the profile config outlook or standard?

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [January 27, 2018, 9:25am UTC](https://discuss.elastic.co/t/is-kibana-send-e-mail-bug-fixed-in-6-1-2/117285/2 "2018-01-27T09:25:26Z")

</div>

> [@yuluopiaoyang](#):
>
> Is kibana alert send e-mail bug fixed in 6.1.2? I still can't send e-mail.

How long have you had this issue?  
What do your logs say?

---

<div class="post-metadata">

**Author:** ![yuluopiaoyang](https://avatars.discourse-cdn.com/v4/letter/y/bbce88/32.png) [@yuluopiaoyang](https://discuss.elastic.co/u/yuluopiaoyang)\
**Post date:** [January 27, 2018, 9:46am UTC](https://discuss.elastic.co/t/is-kibana-send-e-mail-bug-fixed-in-6-1-2/117285/3 "2018-01-27T09:46:22Z")

</div>

Thank you for your respond.I just updated the kibana version from 6.1.1 to 6.1.2 yesterday. I used docker image to install kibana, and I don't know where to find the log. Can you tell me the log dir?

---

<div class="post-metadata">

**Author:** ![yuluopiaoyang](https://avatars.discourse-cdn.com/v4/letter/y/bbce88/32.png) [@yuluopiaoyang](https://discuss.elastic.co/u/yuluopiaoyang)\
**Post date:** [January 30, 2018, 2:16am UTC](https://discuss.elastic.co/t/is-kibana-send-e-mail-bug-fixed-in-6-1-2/117285/4 "2018-01-30T02:16:32Z")

</div>

Hi，I have found the kibana log, there is a request timeout wrong in the log, I think maybe I need to see the detail in elastic log. Then I config the elastic path.logs, then reinstall the elastic. The log path was generated but the path is empty, I can't find the log file,can you help me? Thank you!

---

<div class="post-metadata">

**Author:** ![yuluopiaoyang](https://avatars.discourse-cdn.com/v4/letter/y/bbce88/32.png) [@yuluopiaoyang](https://discuss.elastic.co/u/yuluopiaoyang)\
**Post date:** [January 30, 2018, 3:53am UTC](https://discuss.elastic.co/t/is-kibana-send-e-mail-bug-fixed-in-6-1-2/117285/5 "2018-01-30T03:53:17Z")

</div>

I just test fire an e-mail now, I found a error in kibana log

{"type":"error","@timestamp":"2018-01-30T03:48:36Z","tags":[],"pid":1,"level":"error","error":{"message":"Request Timeout after 30000ms","name":"Error","stack":"Error  
: Request Timeout after 30000ms\n at /usr/share/kibana/node\_modules/elasticsearch/src/lib/transport.js:342:15\n at Timeout. (/usr/share/kibana/node\_m  
odules/elasticsearch/src/lib/transport.js:371:7)\n at ontimeout (timers.js:386:11)\n at tryOnTimeout (timers.js:250:5)\n at Timer.listOnTimeout (timers.js:21  
4:5)"},"url":{"protocol":null,"slashes":null,"auth":null,"host":null,"port":null,"hostname":null,"hash":null,"search":"","query":{},"pathname":"/api/watcher/watch/exe  
cute","path":"/api/watcher/watch/execute","href":"/api/watcher/watch/execute"},"message":"Request Timeout after 30000ms"}

How can I solve it? Thank you!

---

<div class="post-metadata">

**Author:** ![yuluopiaoyang](https://avatars.discourse-cdn.com/v4/letter/y/bbce88/32.png) [@yuluopiaoyang](https://discuss.elastic.co/u/yuluopiaoyang)\
**Post date:** [January 30, 2018, 3:58am UTC](https://discuss.elastic.co/t/is-kibana-send-e-mail-bug-fixed-in-6-1-2/117285/6 "2018-01-30T03:58:31Z")

</div>

There is another error.  
{"type":"error","@timestamp":"2018-01-30T03:37:47Z","tags":[],"pid":1,"level":"error","error":{"message":"json argument must contain a watchStatusJson property","name  
":"Error","stack":"Error: json argument must contain a watchStatusJson property\n at Function.fromUpstreamJson (/usr/share/kibana/plugins/x-pack/plugins/watcher/se  
rver/models/watch\_status/watch\_status.js:128:13)\n at new WatchHistoryItem (/usr/share/kibana/plugins/x-pack/plugins/watcher/server/models/watch\_history\_item/watch  
\_history\_item.js:17:36)\n at Function.fromUpstreamJson (/usr/share/kibana/plugins/x-pack/plugins/watcher/server/models/watch\_history\_item/watch\_history\_item.js:43:  
12)\n at executeWatch.then.hit (/usr/share/kibana/plugins/x-pack/plugins/watcher/server/routes/api/watch/register\_execute\_route.js:43:51)\n at tryCatcher (/usr/  
share/kibana/node\_modules/bluebird/js/main/util.js:26:23)\n at Promise.\_settlePromiseFromHandler (/usr/share/kibana/node\_modules/bluebird/js/main/promise.js:503:31  
)\n at Promise.\_settlePromiseAt (/usr/share/kibana/node\_modules/bluebird/js/main/promise.js:577:18)\n at Promise.\_settlePromises (/usr/share/kibana/node\_modules  
/bluebird/js/main/promise.js:693:14)\n at Async.\_drainQueue (/usr/share/kibana/node\_modules/bluebird/js/main/async.js:123:16)\n at Async.\_drainQueues (/usr/shar  
e/kibana/node\_modules/bluebird/js/main/async.js:133:10)\n at Immediate.Async.drainQueues (/usr/share/kibana/node\_modules/bluebird/js/main/async.js:15:14)\n at r  
unCallback (timers.js:672:20)\n at tryOnImmediate (timers.js:645:5)\n at processImmediate [as \_immediateCallback] (timers.js:617:5)"},"url":{"protocol":null,"sl  
ashes":null,"auth":null,"host":null,"port":null,"hostname":null,"hash":null,"search":"","query":{},"pathname":"/api/watcher/watch/execute","path":"/api/watcher/watch/  
execute","href":"/api/watcher/watch/execute"},"message":"json argument must contain a watchStatusJson property"}

Can you help me? I have been blocked several days.

---

<div class="post-metadata">

**Author:** ![yuluopiaoyang](https://avatars.discourse-cdn.com/v4/letter/y/bbce88/32.png) [@yuluopiaoyang](https://discuss.elastic.co/u/yuluopiaoyang)\
**Post date:** [January 30, 2018, 4:19am UTC](https://discuss.elastic.co/t/is-kibana-send-e-mail-bug-fixed-in-6-1-2/117285/7 "2018-01-30T04:19:14Z")

</div>

OK. I have solved this problem.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [January 30, 2018, 4:31am UTC](https://discuss.elastic.co/t/is-kibana-send-e-mail-bug-fixed-in-6-1-2/117285/8 "2018-01-30T04:31:00Z")

</div>

What was the solution?

---

<div class="post-metadata">

**Author:** ![yuluopiaoyang](https://avatars.discourse-cdn.com/v4/letter/y/bbce88/32.png) [@yuluopiaoyang](https://discuss.elastic.co/u/yuluopiaoyang)\
**Post date:** [January 30, 2018, 4:33am UTC](https://discuss.elastic.co/t/is-kibana-send-e-mail-bug-fixed-in-6-1-2/117285/9 "2018-01-30T04:33:40Z")

</div>

Use the default auth,starttls.enable and port config. Then it is work.

---

<div class="post-metadata">

**Author:** ![yuluopiaoyang](https://avatars.discourse-cdn.com/v4/letter/y/bbce88/32.png) [@yuluopiaoyang](https://discuss.elastic.co/u/yuluopiaoyang)\
**Post date:** [January 30, 2018, 4:36am UTC](https://discuss.elastic.co/t/is-kibana-send-e-mail-bug-fixed-in-6-1-2/117285/10 "2018-01-30T04:36:53Z")

</div>

I think the port config value 587 on the official website confused me. I suggest change it.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 27, 2018, 4:40am UTC](https://discuss.elastic.co/t/is-kibana-send-e-mail-bug-fixed-in-6-1-2/117285/11 "2018-02-27T04:40:21Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
