# Is there a way to stop the error that occurs in Kibana (v8.3.2)?

**URL:** <https://discuss.elastic.co/t/is-there-a-way-to-stop-the-error-that-occurs-in-kibana-v8-3-2/310504>\
**Category:** Kibana\
**Created:** [July 25, 2022, 7:02am UTC](https://discuss.elastic.co/t/is-there-a-way-to-stop-the-error-that-occurs-in-kibana-v8-3-2/310504 "2022-07-25T07:02:38Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![ProLite](https://avatars.discourse-cdn.com/v4/letter/p/cc9497/32.png) [@ProLite](https://discuss.elastic.co/u/ProLite)\
**Post date:** [July 25, 2022, 7:02am UTC](https://discuss.elastic.co/t/is-there-a-way-to-stop-the-error-that-occurs-in-kibana-v8-3-2/310504/1 "2022-07-25T07:02:38Z")

</div>

I am building the following environment on a local server.  
・ Kibana: 8.3.2  
・ Elsticsearch: 8.3.2 (Basic license)  
When I started the above two services with systemd, it started without any problem, but when I checked the log, the following error was written in kibana.log.

```auto
{
  "ecs": {
    "version": "8.0.0"
  },
  "@timestamp": "2022-07-25T16:07:58.076+09:00",
  "message": "Task ML:saved-objects-sync \"ML:saved-objects-sync-task\" failed: ResponseError: {\"error\":\"Incorrect HTTP method for uri [/_ml/anomaly_detectors] and method [GET], allowed: [POST]\",\"status\":405}",
  "log": {
    "level": "ERROR",
    "logger": "plugins.taskManager"
  },
  "process": {
    "pid": 2685
  },
  "trace": {
    "id": "0f337104bf927519d50fedbb3a4a5730"
  },
  "transaction": {
    "id": "095d566b7aef7f77"
  }
}

```

The above log is generated every hour because it is due to a task executed on the kibana server side.  
I also think this task is related to machine learning.  
However, elasticsearch.yml on the Elasticsearch server to which kibana is connected has the following settings.

```auto
xpack.ml.enabled: false

```

For this reason, elasticsearch does not accept APIs related to machine learning, so we expect the above logs to occur.

In Kibana of v7.14 that I used before, the above log did not occur.  
Please tell me how to resolve this error.

---

<div class="post-metadata">

**Author:** ![Larry\_Gregory](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/larry_gregory/32/34969_2.png) [@Larry\_Gregory](https://discuss.elastic.co/u/Larry_Gregory)\
**Post date:** [July 25, 2022, 11:25am UTC](https://discuss.elastic.co/t/is-there-a-way-to-stop-the-error-that-occurs-in-kibana-v8-3-2/310504/2 "2022-07-25T11:25:39Z")

</div>

@James_Gowdy, would you be able to help out with this?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 22, 2022, 11:26am UTC](https://discuss.elastic.co/t/is-there-a-way-to-stop-the-error-that-occurs-in-kibana-v8-3-2/310504/3 "2022-08-22T11:26:23Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
