# Is there any limit to the size of single doc being indexed?

**URL:** https://discuss.elastic.co/t/is-there-any-limit-to-the-size-of-single-doc-being-indexed/53247
**Category:** Elasticsearch
**Created:** [June 19, 2016, 9:45pm UTC](https://discuss.elastic.co/t/is-there-any-limit-to-the-size-of-single-doc-being-indexed/53247 "2016-06-19T21:45:20Z")
**Posts on this page:** 1
**Showing post:** 1

<div class="post-metadata">

### Author: ![michele\_crudele](https://avatars.discourse-cdn.com/v4/letter/m/91b2a8/32.png) [@michele\_crudele](https://discuss.elastic.co/u/michele_crudele)
#### Post date: [June 19, 2016, 9:45pm UTC](https://discuss.elastic.co/t/is-there-any-limit-to-the-size-of-single-doc-being-indexed/53247/1 "2016-06-19T21:45:20Z")

</div>

I'm getting several exceptions like the one below in bulk indexing.

```auto
u'error': {u'caused_by': {u'reason': u'Java heap space', u'type': u'out_of_memory_error'}, u'reason': u'failed to parse', u'type': u'mapper_parsing_exception'}

```

I'm indexing documents with an array field with a big number of elements (may be 1000 - 10000 order of magnitude). Each element is a small json object. These documents have a big size: some of them are about 3MB.  
I take care of not exceeding the payload limit of the bulk indexing, so I suspect the typology and size of the documents I'm indexing can be the root cause of the exceptions.  
Is there any limit on the size of a single document that can be ingested? If not, is there any configuration parameter that I can tune to fix the problem?  
I'm running a single node elasticsearch, with default configuration.  
Thanks in advance.

---

_[View the full topic](https://discuss.elastic.co/t/is-there-any-limit-to-the-size-of-single-doc-being-indexed/53247)._
