# Issue after upgrade from metricbeat 7.1.1 to 7.2.0

**URL:** https://discuss.elastic.co/t/issue-after-upgrade-from-metricbeat-7-1-1-to-7-2-0/187878
**Category:** Beats
**Tags:** metricbeat
**Created:** [June 27, 2019, 3:44pm UTC](https://discuss.elastic.co/t/issue-after-upgrade-from-metricbeat-7-1-1-to-7-2-0/187878 "2019-06-27T15:44:52Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![ohardy](https://avatars.discourse-cdn.com/v4/letter/o/f4b2a3/32.png) [@ohardy](https://discuss.elastic.co/u/ohardy)
#### Post date: [June 27, 2019, 3:44pm UTC](https://discuss.elastic.co/t/issue-after-upgrade-from-metricbeat-7-1-1-to-7-2-0/187878/1 "2019-06-27T15:44:52Z")

</div>

Hi,

Before upgrade, I got records of type event.dataset='kubernetes.container' with kubernetes meta data added like labels, pod id, etc.

After the upgrade, I lost kubernetes meta data.

I change nothing, just upgraded the version so I think it's a bug

---

<div class="post-metadata">

### Author: ![sicute](https://avatars.discourse-cdn.com/v4/letter/s/a6a055/32.png) [@sicute](https://discuss.elastic.co/u/sicute)
#### Post date: [July 1, 2019, 9:07am UTC](https://discuss.elastic.co/t/issue-after-upgrade-from-metricbeat-7-1-1-to-7-2-0/187878/2 "2019-07-01T09:07:25Z")

</div>

same with me too.  
After upgrade to 7.2 from 7.1. metricbeat and filebeat was failed to load dashboard , but for packetbeat 7.2 was working fine .

> Blockquote  
> sudo filebeat setup -e  
> 2019-07-01T08:51:32.864Z INFO instance/beat.go:606 Home path: [/usr/share/filebeat] Config path: [/etc/filebeat] Data path: [/var/lib/filebeat] Logs path: [/var/log/filebeat]  
> 2019-07-01T08:51:32.864Z INFO instance/beat.go:614 Beat ID: e6193c32-a7f2-49e9-a78e-bc2b0cd9f2cf

2019-07-01T08:51:33.013Z INFO template/load.go:169 Existing template will be overwritten, as overwrite is enabled.  
2019-07-01T08:51:33.100Z INFO template/load.go:108 Try loading template filebeat-7.2.0 to Elasticsearch  
2019-07-01T08:51:33.415Z INFO template/load.go:100 template with name 'filebeat-7.2.0' loaded.  
2019-07-01T08:51:33.415Z INFO [index-management] idxmgmt/std.go:289 Loaded index template.  
2019-07-01T08:51:33.416Z INFO [index-management] idxmgmt/std.go:300 Write alias successfully generated.  
Index setup finished.  
Loading dashboards (Kibana must be running and reachable)  
2019-07-01T08:51:33.416Z INFO kibana/client.go:118 Kibana url: [http://10.0.xxxxxx:5601](http://10.0.xxxxxx:5601)  
2019-07-01T08:51:33.622Z INFO kibana/client.go:118 Kibana url: [http://10.0.xxxxxx:5601](http://10.0.xxxxxx:5601)  
2019-07-01T08:52:11.498Z ERROR instance/beat.go:877 Exiting: Failed to import dashboard: Failed to load directory /usr/share/filebeat/kibana/7/dashboard:  
error loading /usr/share/filebeat/kibana/7/dashboard/Filebeat-panw-network-overview.json: returned 400 to import file: . Response: {"statusCode":400,"error":"Bad Request","message":"Document "091fe860-756a-11e9-976e-65a8f47cc4c1" has property "visualization" which belongs to a more recent version of Kibana (7.0.1)."}  
error loading /usr/share/filebeat/kibana/7/dashboard/Filebeat-panw-threat-overview.json: returned 400 to import file: . Response: {"statusCode":400,"error":"Bad Request","message":"Document "0bd2a0c0-7574-11e9-976e-65a8f47cc4c1" has property "visualization" which belongs to a more recent version of Kibana (7.0.1)."}  
Exiting: Failed to import dashboard: Failed to load directory /usr/share/filebeat/kibana/7/dashboard:  
error loading /usr/share/filebeat/kibana/7/dashboard/Filebeat-panw-network-overview.json: returned 400 to import file: . Response: {"statusCode":400,"error":"Bad Request","message":"Document "091fe860-756a-11e9-976e-65a8f47cc4c1" has property "visualization" which belongs to a more recent version of Kibana (7.0.1)."}  
error loading /usr/share/filebeat/kibana/7/dashboard/Filebeat-panw-threat-overview.json: returned 400 to import file: . Response: {"statusCode":400,"error":"Bad Request","message":"Document "0bd2a0c0-7574-11e9-976e-65a8f47cc4c1" has property "visualization" which belongs to a more recent version of Kibana (7.0.1)."}

and here status settings :  
{  
".kibana\_1" : {  
"settings" : {  
"index" : {  
"number\_of\_shards" : "1",  
"auto\_expand\_replicas" : "0-1",  
"blocks" : {  
"read\_only\_allow\_delete" : "false"  
},

}

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 29, 2019, 9:19am UTC](https://discuss.elastic.co/t/issue-after-upgrade-from-metricbeat-7-1-1-to-7-2-0/187878/3 "2019-07-29T09:19:00Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
