# Issue in ElasticSearch Cluster

**URL:** <https://discuss.elastic.co/t/issue-in-elasticsearch-cluster/129308>\
**Category:** Elasticsearch\
**Created:** [April 24, 2018, 12:54pm UTC](https://discuss.elastic.co/t/issue-in-elasticsearch-cluster/129308 "2018-04-24T12:54:28Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![Rajashree\_Sekar](https://avatars.discourse-cdn.com/v4/letter/r/c0e974/32.png) [@Rajashree\_Sekar](https://discuss.elastic.co/u/Rajashree_Sekar)\
**Post date:** [April 24, 2018, 12:54pm UTC](https://discuss.elastic.co/t/issue-in-elasticsearch-cluster/129308/1 "2018-04-24T12:54:28Z")

</div>

Could not form a cluster with 1 master node and two data nodes .  
Im creating cluster inside vbox.

Getting Handshake exception. Please help me to solve the issue.

# Master Node yml file:

cluster.name: CRIST  
node.name: es-master-01  
node.master: true  
network.host: 0.0.0.0  
discovery.zen.ping.unicast.hosts: ["192.168.33.13","192.168.33.11","192.168.33.14"]

# data node 1 yml file:

cluster.name: CRIST  
node.name: data-node-01  
node.data: true  
network.host: 0.0.0.0  
discovery.zen.ping.unicast.hosts: ["192.168.33.11", "192.168.33.13","192.168.33.14"]

# data node 2 yml file:

cluster.name: CRIST  
node.name: data-node-02  
node.master: false  
node.data: true  
network.host: 0.0.0.0  
discovery.zen.ping.unicast.hosts: ["192.168.33.11", "192.168.33.13","192.168.33.14"]

Logs for your reference:

[data-node-02] bound or publishing to a non-loopback address, enforcing bootstrap checks  
[2018-04-24T12:27:51,425][WARN][o.e.d.z.ZenDiscovery] [data-node-02] failed to connect to master [{es-master-01}{MqmS11EbSBSjps9cISRDyw}{qI9S3ZeiSDWLbS-74fDBSQ}{10.0$org.elasticsearch.transport.ConnectTransportException: [es-master-01][10.0.2.15:9300] handshake failed. unexpected remote node {data-node-02}{xLTwvjwZTluE0WsFJKQCjw}{WP-e6$ at org.elasticsearch.transport.TransportService.lambda$connectToNode$3(TransportService.java:335) ~[elasticsearch-6.2.4.jar:6.2.4]  
at org.elasticsearch.transport.TcpTransport.connectToNode(TcpTransport.java:514) ~[elasticsearch-6.2.4.jar:6.2.4]  
at org.elasticsearch.transport.TransportService.connectToNode(TransportService.java:331) ~[elasticsearch-6.2.4.jar:6.2.4]  
at org.elasticsearch.transport.TransportService.connectToNode(TransportService.java:318) ~[elasticsearch-6.2.4.jar:6.2.4]  
at org.elasticsearch.discovery.zen.ZenDiscovery.joinElectedMaster(ZenDiscovery.java:515) [elasticsearch-6.2.4.jar:6.2.4]  
at org.elasticsearch.discovery.zen.ZenDiscovery.innerJoinCluster(ZenDiscovery.java:483) [elasticsearch-6.2.4.jar:6.2.4]  
at org.elasticsearch.discovery.zen.ZenDiscovery.access$2500(ZenDiscovery.java:90) [elasticsearch-6.2.4.jar:6.2.4]  
at org.elasticsearch.discovery.zen.ZenDiscovery$JoinThreadControl$1.run(ZenDiscovery.java:1253) [elasticsearch-6.2.4.jar:6.2.4]

Thanks in advance!

---

<div class="post-metadata">

**Author:** ![A\_B](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/a_b/32/17104_2.png) [@A\_B](https://discuss.elastic.co/u/A_B)\
**Post date:** [April 24, 2018, 2:28pm UTC](https://discuss.elastic.co/t/issue-in-elasticsearch-cluster/129308/2 "2018-04-24T14:28:07Z")

</div>

> [data-node-02] failed to connect to master

and

> handshake failed. unexpected remote node {data-node-02}

are key here

> [@Rajashree\_Sekar](#):
>
> discovery.zen.ping.unicast.hosts

I think that should be a list of master-eligible nodes.

I would try to create a cluster first with default settings (all nodes master-eligible). Also, iirc, having the cluster name in all caps can cause issues but that might be my memory playing tricks on me.

---

<div class="post-metadata">

**Author:** ![Rajashree\_Sekar](https://avatars.discourse-cdn.com/v4/letter/r/c0e974/32.png) [@Rajashree\_Sekar](https://discuss.elastic.co/u/Rajashree_Sekar)\
**Post date:** [April 24, 2018, 4:07pm UTC](https://discuss.elastic.co/t/issue-in-elasticsearch-cluster/129308/3 "2018-04-24T16:07:19Z")

</div>

> [@A\_B](#):
>
> I think that should be a list of master-eligible node

ok I'll change the list to have only master-eligible nodes

---

<div class="post-metadata">

**Author:** ![Rajashree\_Sekar](https://avatars.discourse-cdn.com/v4/letter/r/c0e974/32.png) [@Rajashree\_Sekar](https://discuss.elastic.co/u/Rajashree_Sekar)\
**Post date:** [April 24, 2018, 4:59pm UTC](https://discuss.elastic.co/t/issue-in-elasticsearch-cluster/129308/4 "2018-04-24T16:59:27Z")

</div>

I tried the  
a) discovery.zen.ping.unicast.hosts with only master eligible nodes  
b) changed cluster name to small

both gave same exception- Handshake failed

on hitting \_cluster api  
root@data-node-01:/# curl -XGET 'localhost:9200/\_cluster/state?pretty'  
{  
"error" : {  
"root\_cause" : [  
{  
"type" : "master\_not\_discovered\_exception",  
"reason" : null  
}  
],  
"type" : "master\_not\_discovered\_exception",  
"reason" : null  
},  
"status" : 503  
}

---

<div class="post-metadata">

**Author:** ![A\_B](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/a_b/32/17104_2.png) [@A\_B](https://discuss.elastic.co/u/A_B)\
**Post date:** [April 25, 2018, 9:32am UTC](https://discuss.elastic.co/t/issue-in-elasticsearch-cluster/129308/5 "2018-04-25T09:32:47Z")

</div>

The first node you have to get running is _es-master-01_

Once you have ES running there and `curl http://es-master-01:9200` gives you an ok response, then you can try to start the two other ones.

Before starting ES on the other VMs, make sure that `curl http://es-master-01:9200` also works from them.

For `es-master-01` I would use the IP for that VM in the `curl` commands.

---

<div class="post-metadata">

**Author:** ![zqc0512](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/zqc0512/32/32141_2.png) [@zqc0512](https://discuss.elastic.co/u/zqc0512)\
**Post date:** [April 26, 2018, 6:42am UTC](https://discuss.elastic.co/t/issue-in-elasticsearch-cluster/129308/6 "2018-04-26T06:42:09Z")

</div>

> [@Rajashree\_Sekar](#):
>
> [es-master-01][10.0.2.15:9300] handshake failed. unexpected remote node {data-node-02}{xLTwvjwZTluE0WsFJKQCjw}{WP-e6$ at

this ip is **10.0.2.15** is not 192.168.33.11 see you system hosts configure.

---

<div class="post-metadata">

**Author:** ![Rajashree\_Sekar](https://avatars.discourse-cdn.com/v4/letter/r/c0e974/32.png) [@Rajashree\_Sekar](https://discuss.elastic.co/u/Rajashree_Sekar)\
**Post date:** [April 26, 2018, 1:02pm UTC](https://discuss.elastic.co/t/issue-in-elasticsearch-cluster/129308/7 "2018-04-26T13:02:29Z")

</div>

I removed transport.host and set network.host as my VM's ip. And it worked. Thanks for the support.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 24, 2018, 1:02pm UTC](https://discuss.elastic.co/t/issue-in-elasticsearch-cluster/129308/8 "2018-05-24T13:02:34Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
