# Issue in Fleet managed APM server configuration

**URL:** <https://discuss.elastic.co/t/issue-in-fleet-managed-apm-server-configuration/363282>\
**Category:** APM\
**Tags:** fleet, server\
**Created:** [July 17, 2024, 12:32pm UTC](https://discuss.elastic.co/t/issue-in-fleet-managed-apm-server-configuration/363282 "2024-07-17T12:32:44Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![amolphp](https://avatars.discourse-cdn.com/v4/letter/a/bc79bd/32.png) [@amolphp](https://discuss.elastic.co/u/amolphp)\
**Post date:** [July 17, 2024, 12:32pm UTC](https://discuss.elastic.co/t/issue-in-fleet-managed-apm-server-configuration/363282/1 "2024-07-17T12:32:44Z")

</div>

I am trying to install Fleet managed APM server on 8.14.2, but getting below error

fleet  
│ └─ status: (STOPPED) Not enrolled into Fleet  
└─ elastic-agent  
├─ status: (DEGRADED) 1 or more components/units in a failed state  
└─ fleet-server-default  
├─ status: (HEALTHY) Healthy: communicating with pid '17578'  
├─ fleet-server-default  
│ └─ status: (FAILED) Error - failed version compatibility check with elasticsearch: elastic fail 401: security\_exception: missing authentication credentials for REST request [/]  
└─ fleet-server-default-fleet-server-fleet\_server-ae583-4ee-acd-f46883  
└─ status: (FAILED) Error - failed version compatibility check with elasticsearch: elastic fail 401: security\_exception: missing authentication credentials for REST request [/]

Fleet Server Policy(elastic-agent.yml):  
id: fleet-server-policy  
revision: 23  
outputs:  
default:  
type: elasticsearch  
hosts:  
- '[http://x.x.x.x](http://x.x.x.x).:1111'  
username: xxxx  
password: xxxx  
preset: balanced  
fleet:  
hosts:  
- '[https://x.x.x.x](https://x.x.x.x).:8220'

Please let me know if I am missing anything?

---

<div class="post-metadata">

**Author:** ![TimV](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/timv/32/13162_2.png) [@TimV](https://discuss.elastic.co/u/TimV)\
**Post date:** [July 18, 2024, 1:48am UTC](https://discuss.elastic.co/t/issue-in-fleet-managed-apm-server-configuration/363282/2 "2024-07-18T01:48:10Z")

</div>

From #Elasticsearch to #APM

---

<div class="post-metadata">

**Author:** ![TimV](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/timv/32/13162_2.png) [@TimV](https://discuss.elastic.co/u/TimV)\
**Post date:** [July 18, 2024, 1:48am UTC](https://discuss.elastic.co/t/issue-in-fleet-managed-apm-server-configuration/363282/3 "2024-07-18T01:48:26Z")

</div>

I've moved this to the `APM` topic.

---

<div class="post-metadata">

**Author:** ![simitt](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/simitt/32/106406_2.png) [@simitt](https://discuss.elastic.co/u/simitt)\
**Post date:** [July 18, 2024, 7:09am UTC](https://discuss.elastic.co/t/issue-in-fleet-managed-apm-server-configuration/363282/4 "2024-07-18T07:09:34Z")

</div>

Added #server
