# Issue in metricbeat 7.12

**URL:** https://discuss.elastic.co/t/issue-in-metricbeat-7-12/268474
**Category:** Beats
**Tags:** metricbeat
**Created:** [March 26, 2021, 11:16am UTC](https://discuss.elastic.co/t/issue-in-metricbeat-7-12/268474 "2021-03-26T11:16:28Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![Aymeric\_Caroff](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/aymeric_caroff/32/86152_2.png) [@Aymeric\_Caroff](https://discuss.elastic.co/u/Aymeric_Caroff)
#### Post date: [March 26, 2021, 11:16am UTC](https://discuss.elastic.co/t/issue-in-metricbeat-7-12/268474/1 "2021-03-26T11:16:28Z")

</div>

Hi,

I've debugging an issue for some time now where metricbeat-7.12 doesn't seem to be able to create a new alias for an index template.

About the set up:

- Elasticsearch 7.12
- Kibana 7.12
- Metricbeat 7.12
- Security enabled (SSL + authentication)

ES and Kibana are behind a reverse proxy.

This is what I see in the logs (apologies if the following doesn't show as code, something in the content seems to make the rendering fail to convert that to code):

```auto
    2021-03-26T11:56:24.155+0100 ERROR [publisher_pipeline_output] pipeline/output.go:154  
    Failed to connect to backoff(elasticsearch(https://<host>/elasticsearch)): Connection marked as failed because the onConnect callback failed: failed to create alias: <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>404 Not Found</title>
</head><body>
404
</body></html>
    2021-03-26T11:56:24.156+0100 INFO [publisher_pipeline_output] pipeline/output.go:145  
    Attempting to reconnect to backoff(elasticsearch(https://<host>/elasticsearch)) with 1 reconnect attempt(s)

```

I initially thought that this issue was due to the proxy (since I had some 405 before) but this doesn't seem to be the case. I went to kibana and run the same request and got the following response:

```auto
    PUT <metricbeat-7.12.0-{now/d}-000001>
    {"aliases":{"metricbeat-7.12.0":{"is_write_index":true}}}

    {
      "error" : "Incorrect HTTP method for uri [/%3Cmetricbeat-7.12.0-%7Bnow/d%7D-000001%3E?pretty=true] and method [PUT], allowed: [POST]",
      "status" : 405
    }

```

Is metricbeat using a endpoint from Elasticsearch that has been removed (or modified)?

Any guidance on how to that issue further would be very appreciated.  
Thanks

---

<div class="post-metadata">

### Author: ![ChrsMark](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/chrsmark/32/55858_2.png) [@ChrsMark](https://discuss.elastic.co/u/ChrsMark)
#### Post date: [March 26, 2021, 2:52pm UTC](https://discuss.elastic.co/t/issue-in-metricbeat-7-12/268474/2 "2021-03-26T14:52:44Z")

</div>

Hi!

Can you share your configuration and I can give it a try to see if this is a regression. Also what version of ES you are running?

C.

---

<div class="post-metadata">

### Author: ![Aymeric\_Caroff](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/aymeric_caroff/32/86152_2.png) [@Aymeric\_Caroff](https://discuss.elastic.co/u/Aymeric_Caroff)
#### Post date: [March 28, 2021, 8:19pm UTC](https://discuss.elastic.co/t/issue-in-metricbeat-7-12/268474/3 "2021-03-28T20:19:46Z")

</div>

Hi!  
Thanks for the offer. Here is the metricbeat config:

```auto
metricbeat.config.modules:
  path: ${path.config}/modules.d/*.yml
  reload.enabled: true

setup.template.settings:
  index.number_of_shards: 1
  index.codec: best_compression
fields:
  env: dev
output.elasticsearch:
  hosts: ["https://<es-host>:443/elasticsearch"]
  protocol: "https"
  username: "<metricbeat_user>"
  password: "${output.elasticsearch.password}"
  
  ssl.enabled: true
  ssl.verification_mode: full
  
  proxy_url: http://<proxy-host>:80

processors:
  - add_host_metadata: ~
  - add_cloud_metadata: ~
  - add_docker_metadata: ~
  - add_kubernetes_metadata: ~

```

And here is my ES config:

```auto
cluster.name: monitoring-cluster
node.name: node-1
path.data: /data/elasticsearch
path.logs: /var/log/elasticsearch
bootstrap.memory_lock: true
cluster.initial_master_nodes: ["node-1"]

xpack.security.enabled: true
xpack.security.http.ssl.enabled: true
xpack.security.http.ssl.key: <path_to_ssl_key>
xpack.security.http.ssl.certificate: <path_to_ssl_crt>
xpack.security.http.ssl.certificate_authorities: <path_to_ssl_crt>

```

Let me know if any more information is required.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [April 25, 2021, 10:20pm UTC](https://discuss.elastic.co/t/issue-in-metricbeat-7-12/268474/4 "2021-04-25T22:20:39Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
