# Issue setting up basic security on Elasticsearch 7.12

**URL:** <https://discuss.elastic.co/t/issue-setting-up-basic-security-on-elasticsearch-7-12/270284>\
**Category:** Elasticsearch\
**Tags:** elastic-stack-security\
**Created:** [April 15, 2021, 4:54pm UTC](https://discuss.elastic.co/t/issue-setting-up-basic-security-on-elasticsearch-7-12/270284 "2021-04-15T16:54:30Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![byoungman](https://avatars.discourse-cdn.com/v4/letter/b/838e76/32.png) [@byoungman](https://discuss.elastic.co/u/byoungman)\
**Post date:** [April 15, 2021, 4:54pm UTC](https://discuss.elastic.co/t/issue-setting-up-basic-security-on-elasticsearch-7-12/270284/1 "2021-04-15T16:54:30Z")

</div>

I just downloaded Elasticsearch 7.12 and have it configured for basic operation with no security enabled.

When I go to enable minimum security as per the documentation - [Set up minimal security for Elasticsearch](https://www.elastic.co/guide/en/elasticsearch/reference/master/security-minimal-setup.html) and enable security by setting the xpack.security.enabled flag to true in the elasticsearch.yml file (Step 2) . My problems start when I start the Elasticsearch service so that I can setup the passwords via the elasticsearch-setup-passwords utility.

I get the following bootstrap check failure and the service stops--

`Transport SSL must be enabled if security is enabled on a [basic] license. Please set [xpack.security.transport.ssl.enabled] to [true]`

Enabling xpack.security.transport.ssl.enabled results in the following error--

`Authentication of [elastic] was terminated by realm [reserved] - failed to authenticate user [elastic]`

So I have officially gone down the rabbit hole in that in order to set up my passwords I have to enable xpack security but in order to have xpack security enabled I have to have transport ssl enabled but if I do that then the elastic user can't be authenticated because it's password hasn't been set. Also if I try to run the elasticsearch-setup-passwords utility I get a bootstrap password error because the system is using ssl now and looking for the elastic user.

What am I doing wrong here?

The only modifications I've made to the elasticsearch.yml file is --

```
xpack.security.enabled: true
xpack.security.transport.ssl.enabled: true

```

Thanks,  
Bill

---

<div class="post-metadata">

**Author:** ![ikakavas](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ikakavas/32/34430_2.png) [@ikakavas](https://discuss.elastic.co/u/ikakavas)\
**Post date:** [April 15, 2021, 8:39pm UTC](https://discuss.elastic.co/t/issue-setting-up-basic-security-on-elasticsearch-7-12/270284/2 "2021-04-15T20:39:23Z")

</div>

Hi there,

> The only modifications I've made to the elasticsearch.yml file is

The bootstrap checks are triggered because you are [in production mode](https://www.elastic.co/guide/en/elasticsearch/reference/current/bootstrap-checks.html#dev-vs-prod-mode). So that means that you have made other changes also, most probably that you've set `transport.host` to a non local IP address.  
The minimal security instructions do not apply to production mode because, as you've seen, transport TLS needs to be configured ( it's not enough to "enable" it ). You can use the [relevant instructions](https://www.elastic.co/guide/en/elasticsearch/reference/master/security-basic-setup.html) for that.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 13, 2021, 8:39pm UTC](https://discuss.elastic.co/t/issue-setting-up-basic-security-on-elasticsearch-7-12/270284/3 "2021-05-13T20:39:28Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
