# Issue starting Kibana 7.3

**URL:** https://discuss.elastic.co/t/issue-starting-kibana-7-3/195365
**Category:** Kibana
**Created:** [August 15, 2019, 3:08pm UTC](https://discuss.elastic.co/t/issue-starting-kibana-7-3/195365 "2019-08-15T15:08:05Z")
**Posts on this page:** 8
**Page:** 1

<div class="post-metadata">

### Author: ![adithyamk](https://avatars.discourse-cdn.com/v4/letter/a/919ad9/32.png) [@adithyamk](https://discuss.elastic.co/u/adithyamk)
#### Post date: [August 15, 2019, 3:08pm UTC](https://discuss.elastic.co/t/issue-starting-kibana-7-3/195365/1 "2019-08-15T15:08:05Z")

</div>

Hi,

I have an issue bringing up Kibana 7.3  
It's similar to the issues others have faced but those comments were not able to resolve the issue and I am not able to comment on that issue as it is closed due to inactivity. Hence a new post.

The issue I am seeing is pretty much the same as

> [@Kibana server is not ready yet - throw er; // Unhandled 'error' event](https://discuss.elastic.co/t/kibana-server-is-not-ready-yet-throw-er-unhandled-error-event/175879/5):
>
> sudo systemctl start kibana; tail -f /var/log/syslog Hope this is the right way see_no_evil

But I do not know if it has been resolved.

Kibana is not able to start and crashes repeatedly.  
This is a fresh install of Kibana 7.3 (one of the comments also mentions the same on a fresh install).

```
-- Logs begin at Fri 2019-08-09 02:00:50 CDT. --
Aug 14 17:43:28 sana-small-1.novalocal systemd[1]: Failed to start Kibana.
Aug 14 17:43:28 sana-small-1.novalocal systemd[1]: Unit kibana.service entered failed state.
Aug 14 17:43:28 sana-small-1.novalocal systemd[1]: kibana.service failed.
Aug 15 09:53:05 sana-small-1.novalocal systemd[1]: Started Kibana.
Aug 15 09:53:06 sana-small-1.novalocal systemd[1]: kibana.service: main process exited, code=exited, status=1/FAILURE
Aug 15 09:53:06 sana-small-1.novalocal systemd[1]: Unit kibana.service entered failed state.
Aug 15 09:53:06 sana-small-1.novalocal systemd[1]: kibana.service failed.
Aug 15 09:53:06 sana-small-1.novalocal systemd[1]: kibana.service holdoff time over, scheduling restart.
Aug 15 09:53:06 sana-small-1.novalocal systemd[1]: Stopped Kibana.
Aug 15 09:53:06 sana-small-1.novalocal systemd[1]: Started Kibana.
Aug 15 09:53:07 sana-small-1.novalocal kibana[8303]: events.js:174
Aug 15 09:53:07 sana-small-1.novalocal kibana[8303]: throw er; // Unhandled 'error' event
Aug 15 09:53:07 sana-small-1.novalocal kibana[8303]: ^
Aug 15 09:53:07 sana-small-1.novalocal kibana[8303]: Error: EACCES: permission denied, open '/var/log/kibana'
Aug 15 09:53:07 sana-small-1.novalocal systemd[1]: kibana.service: main process exited, code=exited, status=1/FAILURE
Aug 15 09:53:07 sana-small-1.novalocal systemd[1]: Unit kibana.service entered failed state.
Aug 15 09:53:07 sana-small-1.novalocal systemd[1]: kibana.service failed.
Aug 15 09:53:07 sana-small-1.novalocal systemd[1]: kibana.service holdoff time over, scheduling restart.
Aug 15 09:53:07 sana-small-1.novalocal systemd[1]: Stopped Kibana.
Aug 15 09:53:07 sana-small-1.novalocal systemd[1]: Started Kibana.
Aug 15 09:53:08 sana-small-1.novalocal kibana[8317]: events.js:174
Aug 15 09:53:08 sana-small-1.novalocal systemd[1]: kibana.service: main process exited, code=exited, status=1/FAILURE
Aug 15 09:53:08 sana-small-1.novalocal systemd[1]: Unit kibana.service entered failed state.
Aug 15 09:53:08 sana-small-1.novalocal systemd[1]: kibana.service failed.
Aug 15 09:53:08 sana-small-1.novalocal systemd[1]: kibana.service holdoff time over, scheduling restart.
Aug 15 09:53:08 sana-small-1.novalocal systemd[1]: Stopped Kibana.
Aug 15 09:53:08 sana-small-1.novalocal systemd[1]: Started Kibana.
Aug 15 09:53:09 sana-small-1.novalocal kibana[8329]: events.js:174
Aug 15 09:53:09 sana-small-1.novalocal systemd[1]: kibana.service: main process exited, code=exited, status=1/FAILURE
Aug 15 09:53:09 sana-small-1.novalocal systemd[1]: Unit kibana.service entered failed state.
Aug 15 09:53:09 sana-small-1.novalocal systemd[1]: kibana.service failed.
Aug 15 09:53:09 sana-small-1.novalocal systemd[1]: kibana.service holdoff time over, scheduling restart.
Aug 15 09:53:09 sana-small-1.novalocal systemd[1]: Stopped Kibana.
Aug 15 09:53:09 sana-small-1.novalocal systemd[1]: Started Kibana.
Aug 15 09:53:10 sana-small-1.novalocal kibana[8342]: events.js:174
Aug 15 09:53:10 sana-small-1.novalocal kibana[8342]: throw er; // Unhandled 'error' event
Aug 15 09:53:10 sana-small-1.novalocal kibana[8342]: ^
Aug 15 09:53:10 sana-small-1.novalocal kibana[8342]: Error: EACCES: permission denied, open '/var/log/kibana'
Aug 15 09:53:10 sana-small-1.novalocal kibana[8342]: Emitted 'error' event at:
Aug 15 09:53:10 sana-small-1.novalocal kibana[8342]: at WriteStream.onerror (_stream_readable.js:691:12)
Aug 15 09:53:10 sana-small-1.novalocal kibana[8342]: at WriteStream.emit (events.js:189:13)
Aug 15 09:53:10 sana-small-1.novalocal kibana[8342]: at lazyFs.open (internal/fs/streams.js:272:12)
Aug 15 09:53:10 sana-small-1.novalocal kibana[8342]: at FSReqWrap.oncomplete (fs.js:141:20)
Aug 15 09:53:10 sana-small-1.novalocal systemd[1]: kibana.service: main process exited, code=exited, status=1/FAILURE
Aug 15 09:53:10 sana-small-1.novalocal systemd[1]: Unit kibana.service entered failed state.
Aug 15 09:53:10 sana-small-1.novalocal systemd[1]: kibana.service failed.
Aug 15 09:53:10 sana-small-1.novalocal systemd[1]: kibana.service holdoff time over, scheduling restart.
Aug 15 09:53:10 sana-small-1.novalocal systemd[1]: Stopped Kibana.
Aug 15 09:53:10 sana-small-1.novalocal systemd[1]: start request repeated too quickly for kibana.service
Aug 15 09:53:10 sana-small-1.novalocal systemd[1]: Failed to start Kibana.
Aug 15 09:53:10 sana-small-1.novalocal systemd[1]: Unit kibana.service entered failed state.
Aug 15 09:53:10 sana-small-1.novalocal systemd[1]: kibana.service failed.

```

[root@sana-small-1 ~]# ls -l /var/lib/kibana/headless\_shell-linux/headless\_shell  
-rwxr-xr-x. 1 kibana kibana 127410016 Aug 12 16:49 /var/lib/kibana/headless\_shell-linux/headless\_shell

So the permissions are set correctly. I wonder if this issue is due to the fact that I am running Kibana as root?

Any help to resolve this issue would be appreciated.

Thank you

---

<div class="post-metadata">

### Author: ![rugenl](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rugenl/32/12887_2.png) [@rugenl](https://discuss.elastic.co/u/rugenl)
#### Post date: [August 15, 2019, 4:26pm UTC](https://discuss.elastic.co/t/issue-starting-kibana-7-3/195365/2 "2019-08-15T16:26:06Z")

</div>

DId you change the user and group in the kibana.service file used by systemd?

---

<div class="post-metadata">

### Author: ![adithyamk](https://avatars.discourse-cdn.com/v4/letter/a/919ad9/32.png) [@adithyamk](https://discuss.elastic.co/u/adithyamk)
#### Post date: [August 15, 2019, 4:51pm UTC](https://discuss.elastic.co/t/issue-starting-kibana-7-3/195365/3 "2019-08-15T16:51:22Z")

</div>

I did. Still the same issue.

[root@sana-small-1 ~]# ls -l /etc/systemd/system/kibana.service  
-rw-r--r--. 1 kibana kibana 508 Jul 24 14:07 /etc/systemd/system/kibana.service

---

<div class="post-metadata">

### Author: ![rugenl](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rugenl/32/12887_2.png) [@rugenl](https://discuss.elastic.co/u/rugenl)
#### Post date: [August 15, 2019, 7:21pm UTC](https://discuss.elastic.co/t/issue-starting-kibana-7-3/195365/4 "2019-08-15T19:21:17Z")

</div>

Share the contents of that file

---

<div class="post-metadata">

### Author: ![adithyamk](https://avatars.discourse-cdn.com/v4/letter/a/919ad9/32.png) [@adithyamk](https://discuss.elastic.co/u/adithyamk)
#### Post date: [August 15, 2019, 8:06pm UTC](https://discuss.elastic.co/t/issue-starting-kibana-7-3/195365/5 "2019-08-15T20:06:07Z")

</div>

```
[root@sana-small-1 system]# cat kibana.service
[Unit]
Description=Kibana
StartLimitIntervalSec=30
StartLimitBurst=3

[Service]
Type=simple
User=kibana
Group=kibana
# Load env vars from /etc/default/ and /etc/sysconfig/ if they exist.
# Prefixing the path with '-' makes it try to load, but if the file doesn't
# exist, it continues onward.
EnvironmentFile=-/etc/default/kibana
EnvironmentFile=-/etc/sysconfig/kibana
ExecStart=/usr/share/kibana/bin/kibana "-c /etc/kibana/kibana.yml"
Restart=always
WorkingDirectory=/

[Install]
WantedBy=multi-user.target
[root@sana-small-1 system]#
```

---

<div class="post-metadata">

### Author: ![rugenl](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rugenl/32/12887_2.png) [@rugenl](https://discuss.elastic.co/u/rugenl)
#### Post date: [August 15, 2019, 10:15pm UTC](https://discuss.elastic.co/t/issue-starting-kibana-7-3/195365/6 "2019-08-15T22:15:20Z")

</div>

The user and group here tell systemd to run kibana as kibana, not as root. Since you started kibana from the command line as root, the ownership of /var/log/kibana is probably set to root, hence running as kibana it doesn't have access.

Change these 2 values to root and you will have to add an option to the ExecStart to allow Kibana to run as root, but I don't remember the exact systax.

---

<div class="post-metadata">

### Author: ![adithyamk](https://avatars.discourse-cdn.com/v4/letter/a/919ad9/32.png) [@adithyamk](https://discuss.elastic.co/u/adithyamk)
#### Post date: [August 19, 2019, 4:25pm UTC](https://discuss.elastic.co/t/issue-starting-kibana-7-3/195365/7 "2019-08-19T16:25:42Z")

</div>

Hi,

Thank you for spotting this. I missed it.  
Yes I added --allow-root to the ExecStart command. Kibana is up and running. This solves the issue.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [September 16, 2019, 4:40pm UTC](https://discuss.elastic.co/t/issue-starting-kibana-7-3/195365/8 "2019-09-16T16:40:11Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
