# Issue to setup Fleet Server

**URL:** https://discuss.elastic.co/t/issue-to-setup-fleet-server/333209
**Category:** Elastic Agent
**Tags:** fleet
**Created:** [May 11, 2023, 12:42pm UTC](https://discuss.elastic.co/t/issue-to-setup-fleet-server/333209 "2023-05-11T12:42:15Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![Shoeb\_Masum](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shoeb_masum/32/118691_2.png) [@Shoeb\_Masum](https://discuss.elastic.co/u/Shoeb_Masum)
#### Post date: [May 11, 2023, 12:42pm UTC](https://discuss.elastic.co/t/issue-to-setup-fleet-server/333209/1 "2023-05-11T12:42:15Z")

</div>

Continuing the discussion from [How to get started with Elastic APM?](https://discuss.elastic.co/t/how-to-get-started-with-elastic-apm/328124):

@Wave

I've taken two VM as suggested -  
VM1 (elasticsearch, kibana): 192.168.1.41  
VM2 (Fleet Elastic Agent): 192.168.1.42

I've install Elasticsearch and kibana in one VM (VM1). Kibana GUI is working fine.  
Change made in elasticsearch configuration file -

> network.host: localhost  
> http.port: 9201

As both are in the same server, in kibana configuration is made the change as below -

> elasticsearch.hosts: ["[http://localhost:9201](http://localhost:9201)"]

The problem is - when I tried to set up the fleet server in VM2 from Kiabana GUI, installation is getting failed as VM2 cannot communicate to elasticsearch with URL [http://192.168.1.41:9201](http://192.168.1.41:9201). This elasticsearch URL is required in Fleet setup. I did curl from VM1 but it failed too. When I do curl from VM1 using this [http://localhost:9201](http://localhost:9201) it is getting successful.

When I made change in elasticsearch configuration file like below, and give elasticsearch service restart it failed.

> network.host: 0.0.0.0

Any suggestion how I can have my single server (VM1) ealsticsearch available from different server (VM2) to complete Fleet server setup?

---

<div class="post-metadata">

### Author: ![eMitch](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/emitch/32/93607_2.png) [@eMitch](https://discuss.elastic.co/u/eMitch)
#### Post date: [May 11, 2023, 7:46pm UTC](https://discuss.elastic.co/t/issue-to-setup-fleet-server/333209/2 "2023-05-11T19:46:14Z")

</div>

Changing the network.host to 0.0.0.0 tells Elasticsearch that you want to try and run in a production mode and [starts enforcing bootstrap checks](https://www.elastic.co/guide/en/elasticsearch/reference/current/system-config.html). Do you have the Elasticsearch service logs for why it's failing?

You could also [set the single-node discovery.type](https://www.elastic.co/guide/en/elasticsearch/reference/current/bootstrap-checks.html#single-node-discovery) which will allow you to change the network.host to 0.0.0.0.

---

<div class="post-metadata">

### Author: ![Shoeb\_Masum](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shoeb_masum/32/118691_2.png) [@Shoeb\_Masum](https://discuss.elastic.co/u/Shoeb_Masum)
#### Post date: [May 15, 2023, 12:46pm UTC](https://discuss.elastic.co/t/issue-to-setup-fleet-server/333209/3 "2023-05-15T12:46:16Z")

</div>

> [@eMitch](#):
>
> [set the single-node discovery.type](https://www.elastic.co/guide/en/elasticsearch/reference/current/bootstrap-checks.html#single-node-discovery)

Solved as per your suggestion by adding the following line in elasticsearch.yml file  
discovery.type: single-node

Using kibana GUI, Fleet server made up by installing Elastic Agent with "Fleet up policy". After that I tied to add Elastic Agent with Agent policy; that got failed. Suddenly I saw an error message in kibana "Fleet Server is not Healthy". I removed the Fleet server from kibana GUI and tried to install (VM2 using CLI) again but it is getting failed.

 ![Fleet server](https://us1.discourse-cdn.com/elastic/original/3X/b/f/bfe618240464d16061f47412550a6158213a3bff.jpeg)

---

<div class="post-metadata">

### Author: ![Wave](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/wave/32/117242_2.png) [@Wave](https://discuss.elastic.co/u/Wave)
#### Post date: [May 17, 2023, 1:48pm UTC](https://discuss.elastic.co/t/issue-to-setup-fleet-server/333209/4 "2023-05-17T13:48:49Z")

</div>

Glad you got earlier question solved. Fleet can be tricky to install. Have you tried the steps outlined in the fleet troubleshooting guide from the picture you provided: [Troubleshoot common problems | Fleet and Elastic Agent Guide [8.7] | Elastic](https://www.elastic.co/guide/en/fleet/8.7/fleet-troubleshooting.html)

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [June 7, 2023, 9:49am UTC](https://discuss.elastic.co/t/issue-to-setup-fleet-server/333209/5 "2023-06-07T09:49:32Z")

</div>

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.
