# Issue while starting elastic search service

**URL:** https://discuss.elastic.co/t/issue-while-starting-elastic-search-service/371558
**Category:** Elasticsearch
**Created:** [December 5, 2024, 5:44pm UTC](https://discuss.elastic.co/t/issue-while-starting-elastic-search-service/371558 "2024-12-05T17:44:31Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![Mandara](https://avatars.discourse-cdn.com/v4/letter/m/a87d85/32.png) [@Mandara](https://discuss.elastic.co/u/Mandara)
#### Post date: [December 5, 2024, 5:44pm UTC](https://discuss.elastic.co/t/issue-while-starting-elastic-search-service/371558/1 "2024-12-05T17:44:31Z")

</div>

Hi All ,  
I am getting below error while starting up elastic service . May I know how to fix this issue as I am new to Elasticsearch .

systemd-entrypoint[62417]: CompileCommand: dontinline java/lang/invoke/MethodHandle.setAsTypeCache bool dontin\>  
Dec 05 17:34:51 abc systemd-entrypoint[62417]: CompileCommand: dontinline java/lang/invoke/MethodHandle.asTypeUncached bool dontin\>  
Dec 05 17:34:51 abc systemd-entrypoint[62350]: Failed to load native library:jansi-2.4.0-60af8a6ef4be6b80-libjansi.so. The native \>  
Dec 05 17:34:51 abc systemd-entrypoint[62350]: java.lang.UnsatisfiedLinkError: /tmp/elasticsearch-18024583892260990691/jansi-2.4.0\>  
Dec 05 17:34:52 abc systemd-entrypoint[62350]: ERROR: Elasticsearch did not exit normally - check the logs at /var/log/elasticsear\>  
Dec 05 17:34:53 abc systemd-entrypoint[62350]: ERROR: Elasticsearch died while starting up, with exit code 1  
Dec 05 17:34:53 abc systemd[1]: elasticsearch.service: Main process exited, code=exited, status=1/FAILURE  
Dec 05 17:34:53 abc systemd[1]: elasticsearch.service: Failed with result 'exit-code'.  
Dec 05 17:34:53 abc systemd[1]: Failed to start Elasticsearch.

When i executed journalctl -xe I got below error

sshd[61828]: error: kex\_exchange\_identification: Connection closed by remote host

---

<div class="post-metadata">

### Author: ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)
#### Post date: [December 12, 2024, 9:29am UTC](https://discuss.elastic.co/t/issue-while-starting-elastic-search-service/371558/2 "2024-12-12T09:29:51Z")

</div>

> [@Mandara](#):
>
> Failed to load native library:jansi-2.4.0-60af8a6ef4be6b80-libjansi.so. The native

Which version of Elasticsearch are you using?

What is the operating system and architecture?

Is the `/tmp` directory executable?

---

<div class="post-metadata">

### Author: ![Mandara](https://avatars.discourse-cdn.com/v4/letter/m/a87d85/32.png) [@Mandara](https://discuss.elastic.co/u/Mandara)
#### Post date: [December 12, 2024, 10:05am UTC](https://discuss.elastic.co/t/issue-while-starting-elastic-search-service/371558/3 "2024-12-12T10:05:28Z")

</div>

Which version of Elasticsearch are you using? - elasticsearch-8.16.1-x86\_64.rpm one i dowloaded.  
What is the operating system and architecture? -- OS VERSION : redhat-8.8  
Is the `/tmp` directory executable? -- no it is not executable  
/tmp ext4 rw,nodev,noexec,nosuid 1 2

---

<div class="post-metadata">

### Author: ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)
#### Post date: [December 12, 2024, 10:10am UTC](https://discuss.elastic.co/t/issue-while-starting-elastic-search-service/371558/4 "2024-12-12T10:10:44Z")

</div>

I googled it and although I did not find anything specifically related to Elasticsearch I found [a similar issue](https://issues.apache.org/jira/browse/MNG-7500) that may be related.

---

<div class="post-metadata">

### Author: ![Mandara](https://avatars.discourse-cdn.com/v4/letter/m/a87d85/32.png) [@Mandara](https://discuss.elastic.co/u/Mandara)
#### Post date: [December 12, 2024, 10:25am UTC](https://discuss.elastic.co/t/issue-while-starting-elastic-search-service/371558/5 "2024-12-12T10:25:45Z")

</div>

I checked the link but did not find resolution .Can you please tell me how to I change the path ? from /tmp to other directory ?

I followed the below link for  
downloading Elasticsearch

> **[Install Elasticsearch with RPM | Elasticsearch Guide \[8.16\] | Elastic](https://www.elastic.co/guide/en/elasticsearch/reference/current/rpm.html)**

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [January 9, 2025, 10:26am UTC](https://discuss.elastic.co/t/issue-while-starting-elastic-search-service/371558/6 "2025-01-09T10:26:09Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
