# Issue with Elastic agent installation

**URL:** <https://discuss.elastic.co/t/issue-with-elastic-agent-installation/317830>\
**Category:** Elastic Agent\
**Created:** [October 31, 2022, 3:18pm UTC](https://discuss.elastic.co/t/issue-with-elastic-agent-installation/317830 "2022-10-31T15:18:48Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![subash](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/subash/32/59912_2.png) [@subash](https://discuss.elastic.co/u/subash)\
**Post date:** [October 31, 2022, 3:18pm UTC](https://discuss.elastic.co/t/issue-with-elastic-agent-installation/317830/1 "2022-10-31T15:18:48Z")

</div>

We are using Elastic Cloud Enterprise 2.13.

When installing the Elastic agents in windows PC, getting the below warnings.

```auto
Info: Starting enrollment to URL: https://hostname:9243
Warn: Remote server is not ready to accept connections, will retry in a moment
Info: Retrying enrollment to URL: https://hostname:9243

```

When I check the status of the Elastic agent, it gives the below error.

```auto
PS> ./elastic-agent.exe status
Error: failed to communicate with Elastic Agent daemon: rpc error: code = Unavailable desc = connection error: desc = "transport: Error while dialing open \\\\.\\pipe\\elastic-agent-e841deaceb2a76970405be8d93857858a506994c7e76b3e05c28d5cff44f1050: The system cannot find the file specified."

```

Please help to get this issue resolved

---

<div class="post-metadata">

**Author:** ![MichelLaterman](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/michellaterman/32/110221_2.png) [@MichelLaterman](https://discuss.elastic.co/u/MichelLaterman)\
**Post date:** [November 1, 2022, 8:39pm UTC](https://discuss.elastic.co/t/issue-with-elastic-agent-installation/317830/2 "2022-11-01T20:39:01Z")

</div>

Where is the fleet-server installed? Is it running on port `9243`? the default is `8220`

---

<div class="post-metadata">

**Author:** ![subash](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/subash/32/59912_2.png) [@subash](https://discuss.elastic.co/u/subash)\
**Post date:** [November 2, 2022, 5:21am UTC](https://discuss.elastic.co/t/issue-with-elastic-agent-installation/317830/3 "2022-11-02T05:21:59Z")

</div>

It is running on port 9243.

---

<div class="post-metadata">

**Author:** ![MichelLaterman](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/michellaterman/32/110221_2.png) [@MichelLaterman](https://discuss.elastic.co/u/MichelLaterman)\
**Post date:** [November 2, 2022, 2:03pm UTC](https://discuss.elastic.co/t/issue-with-elastic-agent-installation/317830/4 "2022-11-02T14:03:47Z")

</div>

Where is it running? Is it running on the localhost? Is the host you're running it on called `hostname`?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 30, 2022, 2:03pm UTC](https://discuss.elastic.co/t/issue-with-elastic-agent-installation/317830/5 "2022-11-30T14:03:56Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
