# Issue with elastic search river plugin

**URL:** <https://discuss.elastic.co/t/issue-with-elastic-search-river-plugin/19976>\
**Category:** Elasticsearch\
**Created:** [September 26, 2014, 7:43am UTC](https://discuss.elastic.co/t/issue-with-elastic-search-river-plugin/19976 "2014-09-26T07:43:07Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![kexu\_xu](https://avatars.discourse-cdn.com/v4/letter/k/ac8455/32.png) [@kexu\_xu](https://discuss.elastic.co/u/kexu_xu)\
**Post date:** [September 26, 2014, 7:43am UTC](https://discuss.elastic.co/t/issue-with-elastic-search-river-plugin/19976/1 "2014-09-26T07:43:07Z")

</div>

Hi,all

when load data to elastic search using river, I always get the error:  
ClassNotFoundException.

The fellow is the error description:  
The elastic search has 3 nodes,their ip is 192.168.71.234,192.168.71.235  
and 192.168.71.236  
First, Install the river plugin, the 3 node return right, and the  
${elasticsearch.home}/plugins directory has the plugin.  
Second, execute the curl command:  
curl -XPUT '192.168.71.236:9201/\_river/myhadoop/\_meta' -d '{  
"type":"hadoop",  
"hadoop":{  
"path":"/user/test/appinfo/2014-09-15",  
},  
"index":{  
"index":"dmp2",  
"type":"tag",  
"sha":true  
}  
}'  
Finally, i get the river status,but get error:  
{  
"\_index" : "\_river",  
"\_type" : "myhadoop",  
"\_id" : "\_status",  
"\_version" : 1,  
"found" : true,  
"\_source":{"error":"NoClassSettingsException[Failed to load class with  
value [hadoop]]; nested: ClassNotFoundException[hadoop];  
","node":{"id":"ECzwbXLPTnqP5Ch4IQTAVg","name":"node71-235-open","transport\_address":"inet[localhost/192.168.71.235:9600]"}}  
}

what is the problem here?

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/c471df95-4602-4514-bcd5-97dfbc9cb0ad%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/c471df95-4602-4514-bcd5-97dfbc9cb0ad%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [September 26, 2014, 4:53pm UTC](https://discuss.elastic.co/t/issue-with-elastic-search-river-plugin/19976/2 "2014-09-26T16:53:17Z")

</div>

Did you restart your nodes?

--  
David Pilato | Technical Advocate | [elasticsearch.com](http://elasticsearch.com)  
[david.pilato@elasticsearch.com](mailto:david.pilato@elasticsearch.com)  
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 26 septembre 2014 à 09:43:10, kexu xu ([xukexu9@gmail.com](mailto:xukexu9@gmail.com)) a écrit:

Hi,all

when load data to elastic search using river, I always get the error: ClassNotFoundException.

The fellow is the error description:  
The elastic search has 3 nodes,their ip is 192.168.71.234,192.168.71.235 and 192.168.71.236  
First, Install the river plugin, the 3 node return right, and the ${elasticsearch.home}/plugins directory has the plugin.  
Second, execute the curl command:  
curl -XPUT '192.168.71.236:9201/\_river/myhadoop/\_meta' -d '{  
"type":"hadoop",  
"hadoop":{  
"path":"/user/test/appinfo/2014-09-15",  
},  
"index":{  
"index":"dmp2",  
"type":"tag",  
"sha":true  
}  
}'  
Finally, i get the river status,but get error:  
{  
"\_index" : "\_river",  
"\_type" : "myhadoop",  
"\_id" : "\_status",  
"\_version" : 1,  
"found" : true,  
"\_source":{"error":"NoClassSettingsException[Failed to load class with value [hadoop]]; nested: ClassNotFoundException[hadoop]; ","node":{"id":"ECzwbXLPTnqP5Ch4IQTAVg","name":"node71-235-open","transport\_address":"inet[localhost/192.168.71.235:9600]"}}  
}

what is the problem here?

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/c471df95-4602-4514-bcd5-97dfbc9cb0ad%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/c471df95-4602-4514-bcd5-97dfbc9cb0ad%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/etPan.542599fe.515f007c.5f84%40MacBook-Air-de-David.local](https://groups.google.com/d/msgid/elasticsearch/etPan.542599fe.515f007c.5f84%40MacBook-Air-de-David.local).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![kexu\_xu](https://avatars.discourse-cdn.com/v4/letter/k/ac8455/32.png) [@kexu\_xu](https://discuss.elastic.co/u/kexu_xu)\
**Post date:** [September 28, 2014, 1:21am UTC](https://discuss.elastic.co/t/issue-with-elastic-search-river-plugin/19976/3 "2014-09-28T01:21:15Z")

</div>

No, I don't restart all nodes. But when install river plugin, do i need  
restart nodes? How dose the Elasticsearch server load the river plugin?

在 2014年9月27日星期六UTC+8上午12时53分44秒，David Pilato写道：

> Did you restart your nodes?
> 
> --  
> _David Pilato_ | Technical Advocate | _[elasticsearch.com](http://elasticsearch.com)  
> [http://elasticsearch.com](http://elasticsearch.com)_  
> [david....@elasticsearch.com](mailto:david....@elasticsearch.com) \<javascript:\>  
> @dadoonet [https://twitter.com/dadoonet](https://twitter.com/dadoonet) | @elasticsearchfr  
> [https://twitter.com/elasticsearchfr](https://twitter.com/elasticsearchfr) | @scrutmydocs  
> [http://twitter.com/scrutmydocs](http://twitter.com/scrutmydocs)  
> [https://twitter.com/scrutmydocs](https://twitter.com/scrutmydocs)
> 
> Le 26 septembre 2014 à 09:43:10, kexu xu ([xuk...@gmail.com](mailto:xuk...@gmail.com) \<javascript:\>)  
> a écrit:
> 
> Hi,all
> 
> when load data to Elasticsearch using river, I always get the error:  
> ClassNotFoundException.
> 
> The fellow is the error description:  
> The Elasticsearch has 3 nodes,their ip is 192.168.71.234,192.168.71.235  
> and 192.168.71.236  
> First, Install the river plugin, the 3 node return right, and the  
> ${elasticsearch.home}/plugins directory has the plugin.  
> Second, execute the curl command:  
> curl -XPUT '192.168.71.236:9201/\_river/myhadoop/\_meta' -d '{  
> "type":"hadoop",  
> "hadoop":{  
> "path":"/user/test/appinfo/2014-09-15",  
> },  
> "index":{  
> "index":"dmp2",  
> "type":"tag",  
> "sha":true  
> }  
> }'  
> Finally, i get the river status,but get error:  
> {  
> "\_index" : "\_river",  
> "\_type" : "myhadoop",  
> "\_id" : "\_status",  
> "\_version" : 1,  
> "found" : true,  
> "\_source":{"error":"NoClassSettingsException[Failed to load class with  
> value [hadoop]]; nested: ClassNotFoundException[hadoop];  
> ","node":{"id":"ECzwbXLPTnqP5Ch4IQTAVg","name":"node71-235-open","transport\_address":"inet[localhost/  
> 192.168.71.235:9600]"}}  
> }
> 
> what is the problem here?
> 
> --  
> You received this message because you are subscribed to the Google Groups  
> "elasticsearch" group.  
> To unsubscribe from this group and stop receiving emails from it, send an  
> email to [elasticsearc...@googlegroups.com](mailto:elasticsearc...@googlegroups.com) \<javascript:\>.  
> To view this discussion on the web visit  
> [https://groups.google.com/d/msgid/elasticsearch/c471df95-4602-4514-bcd5-97dfbc9cb0ad%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/c471df95-4602-4514-bcd5-97dfbc9cb0ad%40googlegroups.com)  
> [https://groups.google.com/d/msgid/elasticsearch/c471df95-4602-4514-bcd5-97dfbc9cb0ad%40googlegroups.com?utm\_medium=email&utm\_source=footer](https://groups.google.com/d/msgid/elasticsearch/c471df95-4602-4514-bcd5-97dfbc9cb0ad%40googlegroups.com?utm_medium=email&utm_source=footer)  
> .  
> For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/7d333649-3f84-4559-9571-9a806276400f%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/7d333649-3f84-4559-9571-9a806276400f%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [September 28, 2014, 5:47am UTC](https://discuss.elastic.co/t/issue-with-elastic-search-river-plugin/19976/4 "2014-09-28T05:47:52Z")

</div>

Yes you need to restart nodes when installing a 'Java' plugin.

--  
David 😉  
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

> Le 28 sept. 2014 à 03:21, kexu xu [xukexu9@gmail.com](mailto:xukexu9@gmail.com) a écrit :
> 
> No, I don't restart all nodes. But when install river plugin, do i need restart nodes? How dose the Elasticsearch server load the river plugin?
> 
> 在 2014年9月27日星期六UTC+8上午12时53分44秒，David Pilato写道：
> 
> > Did you restart your nodes?
> > 
> > --  
> > David Pilato | Technical Advocate | [elasticsearch.com](http://elasticsearch.com)  
> > [david....@elasticsearch.com](mailto:david....@elasticsearch.com)  
> > @dadoonet | @elasticsearchfr | @scrutmydocs
> > 
> > > Le 26 septembre 2014 à 09:43:10, kexu xu ([xuk...@gmail.com](mailto:xuk...@gmail.com)) a écrit:
> > > 
> > > Hi,all
> > > 
> > > when load data to Elasticsearch using river, I always get the error: ClassNotFoundException.
> > > 
> > > The fellow is the error description:  
> > > The Elasticsearch has 3 nodes,their ip is 192.168.71.234,192.168.71.235 and 192.168.71.236  
> > > First, Install the river plugin, the 3 node return right, and the ${elasticsearch.home}/plugins directory has the plugin.  
> > > Second, execute the curl command:  
> > > curl -XPUT '192.168.71.236:9201/\_river/myhadoop/\_meta' -d '{  
> > > "type":"hadoop",  
> > > "hadoop":{  
> > > "path":"/user/test/appinfo/2014-09-15",  
> > > },  
> > > "index":{  
> > > "index":"dmp2",  
> > > "type":"tag",  
> > > "sha":true  
> > > }  
> > > }'  
> > > Finally, i get the river status,but get error:  
> > > {  
> > > "\_index" : "\_river",  
> > > "\_type" : "myhadoop",  
> > > "\_id" : "\_status",  
> > > "\_version" : 1,  
> > > "found" : true,  
> > > "\_source":{"error":"NoClassSettingsException[Failed to load class with value [hadoop]]; nested: ClassNotFoundException[hadoop]; ","node":{"id":"ECzwbXLPTnqP5Ch4IQTAVg","name":"node71-235-open","transport\_address":"inet[localhost/192.168.71.235:9600]"}}  
> > > }
> > > 
> > > what is the problem here?
> > > 
> > > --  
> > > You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
> > > To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearc...@googlegroups.com](mailto:elasticsearc...@googlegroups.com).  
> > > To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/c471df95-4602-4514-bcd5-97dfbc9cb0ad%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/c471df95-4602-4514-bcd5-97dfbc9cb0ad%40googlegroups.com).  
> > > For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).
> 
> --  
> You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
> To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
> To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/7d333649-3f84-4559-9571-9a806276400f%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/7d333649-3f84-4559-9571-9a806276400f%40googlegroups.com).  
> For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/CF5E978B-E92F-435C-AB98-92AA9F8D55C3%40pilato.fr](https://groups.google.com/d/msgid/elasticsearch/CF5E978B-E92F-435C-AB98-92AA9F8D55C3%40pilato.fr).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 12:59am UTC](https://discuss.elastic.co/t/issue-with-elastic-search-river-plugin/19976/5 "2017-07-06T00:59:35Z")

</div>


