# Issue with HTTP Poller : ConfigurationError: Invalid URL

**URL:** https://discuss.elastic.co/t/issue-with-http-poller-configurationerror-invalid-url/262328
**Category:** Logstash
**Created:** [January 27, 2021, 7:30am UTC](https://discuss.elastic.co/t/issue-with-http-poller-configurationerror-invalid-url/262328 "2021-01-27T07:30:09Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![AmarKolhapuri](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/amarkolhapuri/32/102372_2.png) [@AmarKolhapuri](https://discuss.elastic.co/u/AmarKolhapuri)
#### Post date: [January 27, 2021, 7:30am UTC](https://discuss.elastic.co/t/issue-with-http-poller-configurationerror-invalid-url/262328/1 "2021-01-27T07:30:09Z")

</div>

I am facing error with invalid URL for below http\_poller code.

input {  
http\_poller{  
urls =\> {  
test2 =\> {  
method =\> get  
user =\> "weblogic"  
password =\> "welcome1"  
urls =\> "[http://weblogic:7001/management/wls/latest/servers](http://weblogic:7001/management/wls/latest/servers)"  
headers =\> { Accept =\> "application/json" }

```
        }
   }
   request_timeout => 420
   schedule => { every => "60s" }
   codec => "json"
   metadata_target => "http_poller_metadata"
}

```

}  
output {  
elasticsearch { hosts =\> ["localhost:9200"] }  
stdout { codec =\> rubydebug }  
}

============Error =======

[2021-01-27T02:20:10,139][ERROR][logstash.javapipeline][main] Pipeline error {:pipeline\_id=\>"main", :exception=\>#\<LogStash::ConfigurationError: Invalid URL \>, :backtrace=\>["/u01/app/oracle/product/elk/logstash-7.9.3/vendor/bundle/jruby/2.5.0/gems/logstash-input-http\_poller-5.0.2/lib/logstash/inputs/http\_poller.rb:103:in `validate_request!'", "/u01/app/oracle/product/elk/logstash-7.9.3/vendor/bundle/jruby/2.5.0/gems/logstash-input-http_poller-5.0.2/lib/logstash/inputs/http_poller.rb:95:in `normalize\_request'", "/u01/app/oracle/product/elk/logstash-7.9.3/vendor/bundle/jruby/2.5.0/gems/logstash-input-http\_poller-5.0.2/lib/logstash/inputs/http\_poller.rb:55:in `block in setup_requests!'", "org/jruby/RubyHash.java:1415:in `each'", "org/jruby/RubyEnumerable.java:886:in `map'", "/u01/app/oracle/product/elk/logstash-7.9.3/vendor/bundle/jruby/2.5.0/gems/logstash-input-http_poller-5.0.2/lib/logstash/inputs/http_poller.rb:55:in `setup\_requests!'", "/u01/app/oracle/product/elk/logstash-7.9.3/vendor/bundle/jruby/2.5.0/gems/logstash-input-http\_poller-5.0.2/lib/logstash/inputs/http\_poller.rb:45:in `register'", "/u01/app/oracle/product/elk/logstash-7.9.3/logstash-core/lib/logstash/java_pipeline.rb:228:in `block in register\_plugins'", "org/jruby/RubyArray.java:1809:in `each'", "/u01/app/oracle/product/elk/logstash-7.9.3/logstash-core/lib/logstash/java_pipeline.rb:227:in `register\_plugins'", "/u01/app/oracle/product/elk/logstash-7.9.3/logstash-core/lib/logstash/java\_pipeline.rb:386:in `start_inputs'", "/u01/app/oracle/product/elk/logstash-7.9.3/logstash-core/lib/logstash/java_pipeline.rb:311:in `start\_workers'", "/u01/app/oracle/product/elk/logstash-7.9.3/logstash-core/lib/logstash/java\_pipeline.rb:185:in `run'", "/u01/app/oracle/product/elk/logstash-7.9.3/logstash-core/lib/logstash/java_pipeline.rb:137:in `block in start'"], "pipeline.sources"=\>["/u01/app/oracle/product/elk/logstash-7.9.3/config/pipelines/osb3pipe.conf"], :thread=\>"#\<Thread:0x15538ad0 run\>"}  
[2021-01-27T02:20:10,142][INFO][logstash.javapipeline][main] Pipeline terminated {"pipeline.id"=\>"main"}  
[2021-01-27T02:20:10,158][ERROR][logstash.agent] Failed to execute action {:id=\>:main, :action\_type=\>LogStash::ConvergeResult::FailedAction, :message=\>"Could not execute action: PipelineAction::Create, action\_result: false", :backtrace=\>nil}  
[2021-01-27T02:20:10,435][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=\>9600}  
[2021-01-27T02:20:15,311][INFO][logstash.runner] Logstash shut down.  
[2021-01-27T02:20:15,328][ERROR][org.logstash.Logstash] java.lang.IllegalStateException: Logstash stopped processing because of an error: (SystemExit) exit

---

<div class="post-metadata">

### Author: ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)
#### Post date: [January 27, 2021, 4:49pm UTC](https://discuss.elastic.co/t/issue-with-http-poller-configurationerror-invalid-url/262328/2 "2021-01-27T16:49:20Z")

</div>

The second "urls" should be "url": `urls => "http://weblogic:7001/management/wls/latest/servers"`

---

<div class="post-metadata">

### Author: ![AmarKolhapuri](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/amarkolhapuri/32/102372_2.png) [@AmarKolhapuri](https://discuss.elastic.co/u/AmarKolhapuri)
#### Post date: [January 27, 2021, 5:51pm UTC](https://discuss.elastic.co/t/issue-with-http-poller-configurationerror-invalid-url/262328/3 "2021-01-27T17:51:52Z")

</div>

Thanks a lot !. I missed this ☹

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [February 24, 2021, 5:52pm UTC](https://discuss.elastic.co/t/issue-with-http-poller-configurationerror-invalid-url/262328/4 "2021-02-24T17:52:02Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
