# Issue with installation of Elastic search

**URL:** <https://discuss.elastic.co/t/issue-with-installation-of-elastic-search/181353>\
**Category:** Elasticsearch\
**Created:** [May 16, 2019, 9:39am UTC](https://discuss.elastic.co/t/issue-with-installation-of-elastic-search/181353 "2019-05-16T09:39:54Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![abhishek\_Shetty](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/abhishek_shetty/32/46284_2.png) [@abhishek\_Shetty](https://discuss.elastic.co/u/abhishek_Shetty)\
**Post date:** [May 16, 2019, 9:39am UTC](https://discuss.elastic.co/t/issue-with-installation-of-elastic-search/181353/1 "2019-05-16T09:39:54Z")

</div>

Hi Team,

We are in the middle of installing Elastic search and kibana for installing RPA Orchestrator but after installing elastic search I am seeing that service is getting stopped.

Please find below details and help me in fixing the issue asap.

[shettya@scdl-sduipa-001 ~] sudo systemctl status elasticsearch.service ● elasticsearch.service - Elasticsearch Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: disabled) Active: failed (Result: exit-code) since Thu 2019-05-16 00:23:24 PDT; 1h 41min ago Docs: http://www.elastic.co Process: 9421 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p {PID\_DIR}/elasticsearch.pid --quiet (code=exited, status=78)  
Main PID: 9421 (code=exited, status=78)

May 16 00:23:15 scdl-sduipa-001 systemd[1]: Started Elasticsearch.  
May 16 00:23:15 scdl-sduipa-001 elasticsearch[9421]: OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.  
May 16 00:23:24 scdl-sduipa-001 systemd[1]: elasticsearch.service: main process exited, code=exited, status=78/n/a  
May 16 00:23:24 scdl-sduipa-001 systemd[1]: Unit elasticsearch.service entered failed state.  
May 16 00:23:24 scdl-sduipa-001 systemd[1]: elasticsearch.service failed.

Error logs:

root@scdl-sduipa-001:/var/log/elasticsearch# tail -f elasticsearch.log  
[2019-05-16T00:23:23,810][INFO][o.e.t.TransportService] [scdl-sduipa-001] pu blish\_address {10.103.118.153:9300}, bound\_addresses {10.103.118.153:9300}  
[2019-05-16T00:23:23,817][INFO][o.e.b.BootstrapChecks] [scdl-sduipa-001] bo und or publishing to a non-loopback address, enforcing bootstrap checks  
[2019-05-16T00:23:23,838][ERROR][o.e.b.Bootstrap] [scdl-sduipa-001] no de validation exception  
[2] bootstrap checks failed  
[1]: system call filters failed to install; check the logs and fix your configur ation or disable system call filters at your own risk  
[2]: the default discovery settings are unsuitable for production use; at least one of [discovery.seed\_hosts, discovery.seed\_providers, cluster.initial\_master\_n odes] must be configured  
[2019-05-16T00:23:23,848][INFO][o.e.n.Node] [scdl-sduipa-001] st opping ...  
[2019-05-16T00:23:23,872][INFO][o.e.n.Node] [scdl-sduipa-001] st opped  
[2019-05-16T00:23:23,873][INFO][o.e.n.Node] [scdl-sduipa-001] cl osing ...  
[2019-05-16T00:23:23,883][INFO][o.e.n.Node] [scdl-sduipa-001] cl

Java version installed is 1.8.0\_212  
We are using red hat 7.6 OS

---

<div class="post-metadata">

**Author:** ![luiz.santos](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/luiz.santos/32/24664_2.png) [@luiz.santos](https://discuss.elastic.co/u/luiz.santos)\
**Post date:** [May 24, 2019, 2:12pm UTC](https://discuss.elastic.co/t/issue-with-installation-of-elastic-search/181353/2 "2019-05-24T14:12:03Z")

</div>

Hi @abhishek_Shetty,

In order to ensure that some important settings receive the attention that they deserve, Elasticsearch has [bootstrap checks](https://www.elastic.co/guide/en/elasticsearch/reference/current/bootstrap-checks.html) upon startup. If Elasticsearch is in production mode, any bootstrap checks that fail will cause Elasticsearch to refuse to start. We consider an Elasticsearch node to be in [production mode](https://www.elastic.co/guide/en/elasticsearch/reference/current/bootstrap-checks.html#dev-vs-prod-mode) if it can join a cluster via non-loopback addresses.

According to your logs there are two bootstrap checks failing and preventing Elasticsearch to start:

```auto
[1]: system call filters failed to install; check the logs and fix your configuration or disable system call filters at your own risk
[2]: the default discovery settings are unsuitable for production use; at least one of [discovery.seed_hosts, discovery.seed_providers, cluster.initial_master_n odes] must be configured

```

For [1], you can read the [System call filter check](https://www.elastic.co/guide/en/elasticsearch/reference/current/_system_call_filter_check.html) docs and for [2], you can check [Discovery configuration check](https://www.elastic.co/guide/en/elasticsearch/reference/current/_discovery_configuration_check.html) docs.

I hope this helps you move forward.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 21, 2019, 2:12pm UTC](https://discuss.elastic.co/t/issue-with-installation-of-elastic-search/181353/3 "2019-06-21T14:12:09Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
