# Issue with JMX Plugin - No such file or directory - No such directory

**URL:** https://discuss.elastic.co/t/issue-with-jmx-plugin-no-such-file-or-directory-no-such-directory/90920
**Category:** Logstash
**Created:** [June 27, 2017, 6:51am UTC](https://discuss.elastic.co/t/issue-with-jmx-plugin-no-such-file-or-directory-no-such-directory/90920 "2017-06-27T06:51:58Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![r4z0rw1r3666](https://avatars.discourse-cdn.com/v4/letter/r/e79b87/32.png) [@r4z0rw1r3666](https://discuss.elastic.co/u/r4z0rw1r3666)
#### Post date: [June 27, 2017, 6:51am UTC](https://discuss.elastic.co/t/issue-with-jmx-plugin-no-such-file-or-directory-no-such-directory/90920/1 "2017-06-27T06:51:58Z")

</div>

Hello.

I'm experiencing issues when attempting to get the JMX plugin to start via Logstash in a v5 ELK farm.

I have previously installed the jmx plugin via bin/logstash-plugin install logstash-input-jmx and received an error for javac.

I resolved this javac error, then reran the install, no errors after that.

Basically when attempting to start logstash with jmx, it throws a no such file or directory error, even though the jmxconfig file is in the same folder as my bin/logstash -f .conf

> [2017-06-27T16:37:32,621][ERROR][logstash.inputs.jmx] No such file or directory - No such directory: /opt/logstash/logstash-5.4.0/bin/jmx-config  
> [2017-06-27T16:37:32,621][ERROR][logstash.inputs.jmx] org/jruby/RubyDir.java:165:in `initialize' org/jruby/RubyDir.java:406:in `foreach'  
> /opt/logstash/logstash-5.4.0/vendor/bundle/jruby/1.9/gems/logstash-input-jmx-3.0.2/lib/logstash/inputs/jmx.rb:326:in `run' /opt/logstash/logstash-5.4.0/logstash-core/lib/logstash/pipeline.rb:443:in `inputworker'  
> /opt/logstash/logstash-5.4.0/logstash-core/lib/logstash/pipeline.rb:436:in `start\_input'

Further through the log it performs the following:

> [2017-06-27T16:37:32,731][FATAL][logstash.runner] An unexpected error occurred! {:error=\>#\<LogStash::ShutdownSignal: LogStash::ShutdownSignal\>, :backtrace=\>["/opt/logstash/logstash-5.4.0/vendor/bundle/jruby/1.9/gems/logstash-input-jmx-3.0.2/lib/logstash/inputs/jmx.rb:321:in `run'"]}  
> [2017-06-27T16:37:32,735][DEBUG][logstash.pipeline] Shutdown waiting for worker thread #Thread:0x68639872

I appreciate any assistance anyone can give resolving this issue.

Thanks again!

---

<div class="post-metadata">

### Author: ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)
#### Post date: [June 27, 2017, 6:51pm UTC](https://discuss.elastic.co/t/issue-with-jmx-plugin-no-such-file-or-directory-no-such-directory/90920/2 "2017-06-27T18:51:47Z")

</div>

The second error message from the log is incomplete. Please post it again but format it as preformatted text using the `</>` toolbar button.

---

<div class="post-metadata">

### Author: ![r4z0rw1r3666](https://avatars.discourse-cdn.com/v4/letter/r/e79b87/32.png) [@r4z0rw1r3666](https://discuss.elastic.co/u/r4z0rw1r3666)
#### Post date: [July 5, 2017, 1:02am UTC](https://discuss.elastic.co/t/issue-with-jmx-plugin-no-such-file-or-directory-no-such-directory/90920/3 "2017-07-05T01:02:42Z")

</div>

Hi Magnus,

See below:

ERROR StatusLogger No log4j2 configuration file found. Using default configuration: logging only errors to the console.  
Sending Logstash's logs to /opt/logstash/logstash-5.4.0/logs which is now configured via log4j2.properties  
[2017-07-05T11:01:29,747][INFO][logstash.pipeline] Starting pipeline {"id"=\>"main", "pipeline.workers"=\>2, "pipeline.batch.size"=\>125, "pipeline.batch.delay"=\>5, "pipeline.max\_inflight"=\>250}  
[2017-07-05T11:01:29,789][INFO][logstash.inputs.jmx] Create queue dispatching JMX requests to threads  
[2017-07-05T11:01:29,790][INFO][logstash.inputs.jmx] Compile regexp for group alias object replacement  
[2017-07-05T11:01:29,795][INFO][logstash.pipeline] Pipeline main started  
[2017-07-05T11:01:29,804][INFO][logstash.inputs.jmx] Initialize 4 threads for JMX metrics collection  
[2017-07-05T11:01:29,832][INFO][logstash.inputs.jmx] Loading configuration files in path {:path=\>"/opt/logstash/logstash-5.4.0/bin/jmx-config"}  
[2017-07-05T11:01:29,833][ERROR][logstash.inputs.jmx] No such file or directory - No such directory: /opt/logstash/logstash-5.4.0/bin/jmx-config  
[2017-07-05T11:01:29,833][ERROR][logstash.inputs.jmx] org/jruby/RubyDir.java:165:in `initialize' org/jruby/RubyDir.java:406:in`foreach'  
/opt/logstash/logstash-5.4.0/vendor/bundle/jruby/1.9/gems/logstash-input-jmx-3.0.2/lib/logstash/inputs/jmx.rb:326:in `run' /opt/logstash/logstash-5.4.0/logstash-core/lib/logstash/pipeline.rb:443:in`inputworker'  
/opt/logstash/logstash-5.4.0/logstash-core/lib/logstash/pipeline.rb:436:in `start\_input'  
[2017-07-05T11:01:29,867][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=\>9600}  
[2017-07-05T11:01:32,812][WARN][logstash.agent] stopping pipeline {:id=\>"main"}

---

<div class="post-metadata">

### Author: ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)
#### Post date: [July 5, 2017, 6:33am UTC](https://discuss.elastic.co/t/issue-with-jmx-plugin-no-such-file-or-directory-no-such-directory/90920/4 "2017-07-05T06:33:50Z")

</div>

It looks like you've configured the input to look for configuration files in /opt/logstash/logstash-5.4.0/bin/jmx-config but that there's no such directory on the machine.

---

<div class="post-metadata">

### Author: ![r4z0rw1r3666](https://avatars.discourse-cdn.com/v4/letter/r/e79b87/32.png) [@r4z0rw1r3666](https://discuss.elastic.co/u/r4z0rw1r3666)
#### Post date: [July 5, 2017, 7:16am UTC](https://discuss.elastic.co/t/issue-with-jmx-plugin-no-such-file-or-directory-no-such-directory/90920/5 "2017-07-05T07:16:03Z")

</div>

Ok, I thought I just had to have the json file there, not an actual directory containing them. Got it making a connection attempt now.

Thanks for your assistance.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [August 2, 2017, 7:16am UTC](https://discuss.elastic.co/t/issue-with-jmx-plugin-no-such-file-or-directory-no-such-directory/90920/6 "2017-08-02T07:16:35Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
