# Issue with JSON bulk insert "The bulk request must be terminated by a newline \[\\n\]"

**URL:** <https://discuss.elastic.co/t/issue-with-json-bulk-insert-the-bulk-request-must-be-terminated-by-a-newline-n/165902>\
**Category:** Elasticsearch\
**Created:** [January 27, 2019, 12:57pm UTC](https://discuss.elastic.co/t/issue-with-json-bulk-insert-the-bulk-request-must-be-terminated-by-a-newline-n/165902 "2019-01-27T12:57:04Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![ballavamsi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ballavamsi/32/40263_2.png) [@ballavamsi](https://discuss.elastic.co/u/ballavamsi)\
**Post date:** [January 27, 2019, 12:57pm UTC](https://discuss.elastic.co/t/issue-with-json-bulk-insert-the-bulk-request-must-be-terminated-by-a-newline-n/165902/1 "2019-01-27T12:57:04Z")

</div>

I'm trying to bulk upload json to elasticsearch with the below data.  
I searched in the forums and found that last line should be newline even if I did that i'm getting the same error.

 ![error](https://us1.discourse-cdn.com/elastic/original/3X/8/a/8ac4a281f3fd600f6ffca29d93402fb117dd7d07.png)

 ![index](https://us1.discourse-cdn.com/elastic/original/3X/4/1/413e840f9b8614aa985461d2b8ad1710266fdacb.png)  
This is the index i'm using  
{"index":{"\_index":"momogmail","\_type":"email","\_id":"1"}}  
{"From":"Somesampletext","To":"abc","CC":"cctext","BCC":"bcctext"}

my mapping

 ![mapping](https://us1.discourse-cdn.com/elastic/original/3X/f/3/f399d60eb09f373e683c9c2b51822044244640a5.png)

---

<div class="post-metadata">

**Author:** ![abdon](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/abdon/32/9195_2.png) [@abdon](https://discuss.elastic.co/u/abdon)\
**Post date:** [January 27, 2019, 2:16pm UTC](https://discuss.elastic.co/t/issue-with-json-bulk-insert-the-bulk-request-must-be-terminated-by-a-newline-n/165902/2 "2019-01-27T14:16:25Z")

</div>

You're using the wrong content type. You should be using `"Content-Type: application/x-ndjson"`. Can you see if that resolves the issue?

(By the way, posting screenshots of requests and error messages is not very useful, please copy and paste the actual messages as code-formatted text)

---

<div class="post-metadata">

**Author:** ![ballavamsi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ballavamsi/32/40263_2.png) [@ballavamsi](https://discuss.elastic.co/u/ballavamsi)\
**Post date:** [January 27, 2019, 2:32pm UTC](https://discuss.elastic.co/t/issue-with-json-bulk-insert-the-bulk-request-must-be-terminated-by-a-newline-n/165902/3 "2019-01-27T14:32:53Z")

</div>

Hi,

I tried with application/x-ndjson still getting the same error.

> C:\Users\vamsi.srinivas.balla\>curl -s -XPOST localhost:9200/momogmail/emails/\_bulk?pretty -H "Content-Type: application/x-ndjson" -d @"C:\Users\vamsi.srinivas.balla\Downloads/learnermomo1.json"  
> {  
> "error" : {  
> "root\_cause" : [  
> {  
> "type" : "illegal\_argument\_exception",  
> "reason" : "The bulk request must be terminated by a newline [\n]"  
> }  
> ],  
> "type" : "illegal\_argument\_exception",  
> "reason" : "The bulk request must be terminated by a newline [\n]"  
> },  
> "status" : 400  
> }

---

<div class="post-metadata">

**Author:** ![forloop](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/forloop/32/9021_2.png) [@forloop](https://discuss.elastic.co/u/forloop)\
**Post date:** [January 27, 2019, 2:37pm UTC](https://discuss.elastic.co/t/issue-with-json-bulk-insert-the-bulk-request-must-be-terminated-by-a-newline-n/165902/4 "2019-01-27T14:37:00Z")

</div>

From the notepad++ screenshot, the final line should have `LF`.

---

<div class="post-metadata">

**Author:** ![ballavamsi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ballavamsi/32/40263_2.png) [@ballavamsi](https://discuss.elastic.co/u/ballavamsi)\
**Post date:** [January 27, 2019, 2:50pm UTC](https://discuss.elastic.co/t/issue-with-json-bulk-insert-the-bulk-request-must-be-terminated-by-a-newline-n/165902/5 "2019-01-27T14:50:52Z")

</div>

Hi,

Thank you all the issue was resolved when I replaced -d with --data-binary along with application/x-ndjson

Regards,  
Vamsi

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 24, 2019, 2:50pm UTC](https://discuss.elastic.co/t/issue-with-json-bulk-insert-the-bulk-request-must-be-terminated-by-a-newline-n/165902/6 "2019-02-24T14:50:53Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
