# Issue with path.repo while starting Elasticsearch as a service

**URL:** <https://discuss.elastic.co/t/issue-with-path-repo-while-starting-elasticsearch-as-a-service/211572>\
**Category:** Elasticsearch\
**Created:** [December 12, 2019, 6:37am UTC](https://discuss.elastic.co/t/issue-with-path-repo-while-starting-elasticsearch-as-a-service/211572 "2019-12-12T06:37:34Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![vishuk619](https://avatars.discourse-cdn.com/v4/letter/v/c2a13f/32.png) [@vishuk619](https://discuss.elastic.co/u/vishuk619)\
**Post date:** [December 12, 2019, 6:37am UTC](https://discuss.elastic.co/t/issue-with-path-repo-while-starting-elasticsearch-as-a-service/211572/1 "2019-12-12T06:37:34Z")

</div>

**Describe the feature** : Elasticsearch service doesn't get started if path.repo contains a repository path that needs credentials.

**Elasticsearch version** ( `bin/elasticsearch --version` ): 6.5.4

**Plugins installed** : [Search guard]

**JVM version** ( `java -version` ): 1.8

**OS version** ( `uname -a` if on a Unix-like system): Windows 10, Windows Server 2012 R2

**Description of the problem including expected versus actual behavior** :

When we give a repository path which needs credentials in **path.repo** & we connect to that repository using [net use](https://docs.microsoft.com/en-us/previous-versions/windows/it-pro/windows-server-2012-r2-and-2012/gg651155(v%3Dws.11)) command, elasticsearch doesn't start as a service. However, elasticsearch.bat works perfectly fine.

Fails with error message like this: "Exception java.lang.IllegalStateException: Unable to access 'path.repo', Caused by: java.nio.file.FileSystemException, **Unable to determine if root directory exists**"

**Steps to reproduce** :

1. Open elasticsearch.yml & add a repository path to path.repo. The repository path should be asking for credentials (may be give cross domain machine's share)
2. Now execute this command to connect to the share: "net use '\machine-name\share1'"
3. Once you are connected, start Elasticsearch as a service. Fails with above mentioned exception. Try starting the same using "elasticsearch.bat", it works perfectly.

**Provide logs (if relevant)** :  
[Elasticsearch Logs.zip](https://github.com/elastic/elasticsearch/files/3954174/Elasticsearch.Logs.zip)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 9, 2020, 6:37am UTC](https://discuss.elastic.co/t/issue-with-path-repo-while-starting-elasticsearch-as-a-service/211572/2 "2020-01-09T06:37:35Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
