# Issues with agent on windows service start loop

**URL:** <https://discuss.elastic.co/t/issues-with-agent-on-windows-service-start-loop/322250>\
**Category:** Elastic Agent\
**Created:** [December 31, 2022, 9:48pm UTC](https://discuss.elastic.co/t/issues-with-agent-on-windows-service-start-loop/322250 "2022-12-31T21:48:21Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![pshilling](https://avatars.discourse-cdn.com/v4/letter/p/8e8cbc/32.png) [@pshilling](https://discuss.elastic.co/u/pshilling)\
**Post date:** [December 31, 2022, 9:48pm UTC](https://discuss.elastic.co/t/issues-with-agent-on-windows-service-start-loop/322250/1 "2022-12-31T21:48:21Z")

</div>

I installed the agent on my windows 10 test machine using the script generated from my fleet server. I used cmd run as administrator to run the installer. I seem to be stuck in a service start loop. The error logs show the following…

```auto
{"log.level":"info","@timestamp":"2022-12-31T18:19:33.896Z","log.origin":{"file.name":"cmd/run.go","file.line":209},"message":"APM instrumentation disabled","ecs.version":"1.6.0"}
{"log.level":"info","@timestamp":"2022-12-31T18:19:33.917Z","log.origin":{"file.name":"application/application.go","file.line":78},"message":"Detecting execution mode","ecs.version":"1.6.0"}
{"log.level":"info","@timestamp":"2022-12-31T18:19:33.925Z","log.origin":{"file.name":"application/application.go","file.line":102},"message":"Agent is managed by Fleet","ecs.version":"1.6.0"}
{"log.level":"info","@timestamp":"2022-12-31T18:19:33.926Z","log.origin":{"file.name":"capabilities/capabilities.go","file.line":59},"message":"capabilities file not found in C:\\Program Files\\Elastic\\Agent\\capabilities.yml","ecs.version":"1.6.0"}
{"log.level":"error","@timestamp":"2022-12-31T18:19:34.578Z","log.logger":"cmd_run","log.origin":{"file.name":"cmd/run.go","file.line":67},"message":"run command finished with error","error":{"message":"starting GRPC listener: listen tcp 127.0.0.1:6789: bind: An attempt was made to access a socket in a way forbidden by its access permissions."},"ecs.version":"1.6.0"}

```

---

<div class="post-metadata">

**Author:** ![MichelLaterman](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/michellaterman/32/110221_2.png) [@MichelLaterman](https://discuss.elastic.co/u/MichelLaterman)\
**Post date:** [January 4, 2023, 7:14pm UTC](https://discuss.elastic.co/t/issues-with-agent-on-windows-service-start-loop/322250/2 "2023-01-04T19:14:46Z")

</div>

It looks like the agent is unable to bind it's metrics endpoints to a socket (`6789`); is the installation running with admin permissions?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 1, 2023, 7:15pm UTC](https://discuss.elastic.co/t/issues-with-agent-on-windows-service-start-loop/322250/3 "2023-02-01T19:15:38Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
