# Issues with Elasticseach 7 on WSL - Windows 11

**URL:** https://discuss.elastic.co/t/issues-with-elasticseach-7-on-wsl-windows-11/302134
**Category:** Elasticsearch
**Created:** [April 11, 2022, 4:16pm UTC](https://discuss.elastic.co/t/issues-with-elasticseach-7-on-wsl-windows-11/302134 "2022-04-11T16:16:14Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![giss](https://avatars.discourse-cdn.com/v4/letter/g/258eb7/32.png) [@giss](https://discuss.elastic.co/u/giss)
#### Post date: [April 11, 2022, 4:16pm UTC](https://discuss.elastic.co/t/issues-with-elasticseach-7-on-wsl-windows-11/302134/1 "2022-04-11T16:16:14Z")

</div>

Hi there. I tried to install Elastichseach 7.17.

When I try to start elastic I have this error:

```auto
 sudo -i service elasticsearch start
 * Starting Elasticsearch Server Exception in thread "main" java.nio.file.NoSuchFileException: /etc/elasticsearch/jvm.options
        at java.base/sun.nio.fs.UnixException.translateToIOException(UnixException.java:92)
        at java.base/sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:106)
        at java.base/sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:111)
        at java.base/sun.nio.fs.UnixFileSystemProvider.newByteChannel(UnixFileSystemProvider.java:218)
        at java.base/java.nio.file.Files.newByteChannel(Files.java:380)
        at java.base/java.nio.file.Files.newByteChannel(Files.java:432)
        at java.base/java.nio.file.spi.FileSystemProvider.newInputStream(FileSystemProvider.java:422)
        at java.base/java.nio.file.Files.newInputStream(Files.java:160)
        at org.elasticsearch.tools.launchers.JvmOptionsParser.readJvmOptionsFiles(JvmOptionsParser.java:168)
        at org.elasticsearch.tools.launchers.JvmOptionsParser.jvmOptions(JvmOptionsParser.java:124)
        at org.elasticsearch.tools.launchers.JvmOptionsParser.main(JvmOptionsParser.java:86)

```

And also with this command:

```auto
 sudo service elasticsearch start
 * Starting Elasticsearch Server Exception in thread "main" java.nio.file.NoSuchFileException: /etc/elasticsearch/jvm.options
        at java.base/sun.nio.fs.UnixException.translateToIOException(UnixException.java:92)
        at java.base/sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:106)
        at java.base/sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:111)
        at java.base/sun.nio.fs.UnixFileSystemProvider.newByteChannel(UnixFileSystemProvider.java:218)
        at java.base/java.nio.file.Files.newByteChannel(Files.java:380)
        at java.base/java.nio.file.Files.newByteChannel(Files.java:432)
        at java.base/java.nio.file.spi.FileSystemProvider.newInputStream(FileSystemProvider.java:422)
        at java.base/java.nio.file.Files.newInputStream(Files.java:160)
        at org.elasticsearch.tools.launchers.JvmOptionsParser.readJvmOptionsFiles(JvmOptionsParser.java:168)
        at org.elasticsearch.tools.launchers.JvmOptionsParser.jvmOptions(JvmOptionsParser.java:124)
        at org.elasticsearch.tools.launchers.JvmOptionsParser.main(JvmOptionsParser.java:86)

```

So, I tried to remove it.. but I have this output

```auto
sudo apt-get --purge autoremove elasticsearch
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
  elasticsearch*
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
After this operation, 517 MB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 44967 files and directories currently installed.)
Removing elasticsearch (7.17.2) ...
Stopping elasticsearch service...System has not been booted with systemd as init system (PID 1). Can't operate.
Failed to connect to bus: Host is down
dpkg: error processing package elasticsearch (--remove):
 installed elasticsearch package pre-removal script subprocess returned error exit status 1
dpkg: too many errors, stopping
System has not been booted with systemd as init system (PID 1). Can't operate.
Failed to connect to bus: Host is down
### NOT starting on installation, please execute the following statements to configure elasticsearch service to start automatically using systemd
 sudo systemctl daemon-reload
 sudo systemctl enable elasticsearch.service
### You can start elasticsearch service by executing
 sudo systemctl start elasticsearch.service
Errors were encountered while processing:
 elasticsearch
Processing was halted because there were too many errors.
E: Sub-process /usr/bin/dpkg returned an error code (1)

```

Please, can anyone help me? Thanks

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [May 9, 2022, 4:16pm UTC](https://discuss.elastic.co/t/issues-with-elasticseach-7-on-wsl-windows-11/302134/2 "2022-05-09T16:16:45Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
