# Issues with indicies after running Curator delete

**URL:** https://discuss.elastic.co/t/issues-with-indicies-after-running-curator-delete/141813
**Category:** Elasticsearch
**Created:** [July 26, 2018, 3:30pm UTC](https://discuss.elastic.co/t/issues-with-indicies-after-running-curator-delete/141813 "2018-07-26T15:30:39Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![rfelske](https://avatars.discourse-cdn.com/v4/letter/r/e9a140/32.png) [@rfelske](https://discuss.elastic.co/u/rfelske)
#### Post date: [July 26, 2018, 3:30pm UTC](https://discuss.elastic.co/t/issues-with-indicies-after-running-curator-delete/141813/1 "2018-07-26T15:30:40Z")

</div>

I have installed Curator and ran a delete command as follows:

curator --config /opt/software/elk/elasticsearch-6.2.4/curator/curator.yml /opt/software/elk/elasticsearch-6.2.4/curator/action\_delete.yml

The delete worked with no issues and cleaned up exactly what was expected. However after the delete I started getting the below error message in elasticsearch log:

[2018-07-25T16:15:42,308][WARN][o.e.x.m.e.l.LocalExporter] unexpected error while indexing monitoring document  
org.elasticsearch.xpack.monitoring.exporter.ExportException: ClusterBlockException[blocked by: [FORBIDDEN/12/index read-only / allow delete (api)];]  
at org.elasticsearch.xpack.monitoring.exporter.local.LocalBulk.lambda$throwExportException$2(LocalBulk.java:140) ~[?:?]

This caused no records to pass elasticsearch and stopped my dashboards. I had to delete all the indicies to stop the error message and get indicies to continue to gather data. Any ideas on why this happened or how to prevent would be greatly appreciated.

The curator.yml is as follows:  
client:  
hosts:  
- aleas031.vwoa.na.vwg  
port: 9200  
url\_prefix:  
use\_ssl: False  
certificate:  
client\_cert:  
client\_key:  
ssl\_no\_validate: False  
http\_auth: elastic:xxxxxxx  
timeout: 30  
master\_only: False

logging:  
loglevel: INFO  
logfile: /data/apps/elk/elasticsearch/logs/curator.log  
logformat: default  
blacklist: []

action\_delete.yml:  
actions:  
1:  
action: delete\_indices  
description: \>-  
Delete indices older than 5 days (based on index name), for logstash-  
prefixed indices. Ignore the error if the filter does not result in an  
actionable list of indices (ignore\_empty\_list) and exit cleanly.  
options:  
ignore\_empty\_list: True  
disable\_action: False  
filters:  
- filtertype: pattern  
kind: prefix  
value: ipstash-  
- filtertype: age  
source: name  
direction: older  
timestring: '%Y.%m.%d'  
unit: days  
unit\_count: 7  
2:  
action: delete\_indices  
description: \>-  
Delete indices older than 5 days (based on index name), for logstash-  
prefixed indices. Ignore the error if the filter does not result in an  
actionable list of indices (ignore\_empty\_list) and exit cleanly.  
options:  
ignore\_empty\_list: True  
disable\_action: False  
filters:  
- filtertype: pattern  
kind: prefix  
value: wasstash-  
- filtertype: age  
source: name  
direction: older  
timestring: '%Y.%m.%d'  
unit: days  
unit\_count: 7  
3:  
action: delete\_indices  
description: \>-  
Delete indices older than 5 days (based on index name), for logstash-  
prefixed indices. Ignore the error if the filter does not result in an  
actionable list of indices (ignore\_empty\_list) and exit cleanly.  
options:  
ignore\_empty\_list: True  
disable\_action: False  
filters:  
- filtertype: pattern  
kind: prefix  
value: metricbeat-  
- filtertype: age  
source: name  
direction: older  
timestring: '%Y.%m.%d'  
unit: days  
unit\_count: 2

---

<div class="post-metadata">

### Author: ![akhileshsingh](https://avatars.discourse-cdn.com/v4/letter/a/ce7236/32.png) [@akhileshsingh](https://discuss.elastic.co/u/akhileshsingh)
#### Post date: [July 26, 2018, 4:00pm UTC](https://discuss.elastic.co/t/issues-with-indicies-after-running-curator-delete/141813/2 "2018-07-26T16:00:11Z")

</div>

@rfelske

Hope i can help but i need some information.

1. Which environment you were using
2. And which version of python you were using.

Thanks

---

<div class="post-metadata">

### Author: ![rfelske](https://avatars.discourse-cdn.com/v4/letter/r/e9a140/32.png) [@rfelske](https://discuss.elastic.co/u/rfelske)
#### Post date: [August 3, 2018, 5:09pm UTC](https://discuss.elastic.co/t/issues-with-indicies-after-running-curator-delete/141813/3 "2018-08-03T17:09:31Z")

</div>

I am using python 2.7.5, I'm not sure what you mean by environment. I am using a basic license.  
FYI

---

<div class="post-metadata">

### Author: ![theuntergeek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/theuntergeek/32/44961_2.png) [@theuntergeek](https://discuss.elastic.co/u/theuntergeek)
#### Post date: [August 3, 2018, 5:29pm UTC](https://discuss.elastic.co/t/issues-with-indicies-after-running-curator-delete/141813/4 "2018-08-03T17:29:37Z")

</div>

Curator did not cause this. It did what you configured it to do. This is something upstream:

> [@rfelske](#):
>
> unexpected error while indexing monitoring document

Your Curator isn’t configured to manage the monitoring indices, _-monitoring-_. You might want to look at those indices, and whether any monitoring changes were made, or added.

---

<div class="post-metadata">

### Author: ![rfelske](https://avatars.discourse-cdn.com/v4/letter/r/e9a140/32.png) [@rfelske](https://discuss.elastic.co/u/rfelske)
#### Post date: [August 7, 2018, 1:18pm UTC](https://discuss.elastic.co/t/issues-with-indicies-after-running-curator-delete/141813/5 "2018-08-07T13:18:53Z")

</div>

Thanks for the info. I am still unsuer why this occurred but as this was a POC I have done a complete re-install for production use and curator is working fine there.  
Thanks,

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [September 4, 2018, 1:19pm UTC](https://discuss.elastic.co/t/issues-with-indicies-after-running-curator-delete/141813/6 "2018-09-04T13:19:00Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
