# Issues with jvm lock

**URL:** <https://discuss.elastic.co/t/issues-with-jvm-lock/291318>\
**Category:** Elasticsearch\
**Tags:** docker\
**Created:** [December 9, 2021, 11:37am UTC](https://discuss.elastic.co/t/issues-with-jvm-lock/291318 "2021-12-09T11:37:25Z")\
**Posts on this page:** 1\
**Showing post:** 2

<div class="post-metadata">

**Author:** ![DineshNaik](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dineshnaik/32/89308_2.png) [@DineshNaik](https://discuss.elastic.co/u/DineshNaik)\
**Post date:** [December 9, 2021, 8:03pm UTC](https://discuss.elastic.co/t/issues-with-jvm-lock/291318/2 "2021-12-09T20:03:55Z")

</div>

Please check this

> [@Elasticserach 7.2 Unable to create cluster with error "Unable to lock JVM Memory: error=12, reason=Cannot allocate memory"](https://discuss.elastic.co/t/elasticserach-7-2-unable-to-create-cluster-with-error-unable-to-lock-jvm-memory-error-12-reason-cannot-allocate-memory/252050/4):
>
> The problem is that you have set bootstrap.memory\_lock: true but your system does not support memory locking. The solution is therefore not to set bootstrap.memory\_lock: true. Instead you should [disable swap](https://www.elastic.co/guide/en/elasticsearch/reference/current/setup-configuration-memory.html).

---

_[View the full topic](https://discuss.elastic.co/t/issues-with-jvm-lock/291318)._
