# Jar Hell - ES1Engineer Training - Lab 2

**URL:** <https://discuss.elastic.co/t/jar-hell-es1engineer-training-lab-2/271028>\
**Category:** Elastic Training\
**Created:** [April 23, 2021, 2:39am UTC](https://discuss.elastic.co/t/jar-hell-es1engineer-training-lab-2/271028 "2021-04-23T02:39:00Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Fjord4](https://avatars.discourse-cdn.com/v4/letter/f/e68b1a/32.png) [@Fjord4](https://discuss.elastic.co/u/Fjord4)\
**Post date:** [April 23, 2021, 2:39am UTC](https://discuss.elastic.co/t/jar-hell-es1engineer-training-lab-2/271028/1 "2021-04-23T02:39:00Z")

</div>

Hello,

Lab 2 - the installation of elasticsearch from ssh1 fails

[2021-04-23T00:09:21,542][ERROR][o.e.b.ElasticsearchUncaughtExceptionHandler] [server1] uncaught exception in thread [main]  
org.elasticsearch.bootstrap.StartupException: java.lang.IllegalStateException: failed to load plugin x-pack-watcher due to jar hell

I am not sure what "jar hell" is though I think it is not good since it does not allow me to install

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [April 23, 2021, 3:01am UTC](https://discuss.elastic.co/t/jar-hell-es1engineer-training-lab-2/271028/2 "2021-04-23T03:01:02Z")

</div>

Welcome!

Could you share the full output?

JarHell indicates that a plugin tries to load a library which is already loaded but with another version or something else which conflicts.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 21, 2021, 3:01am UTC](https://discuss.elastic.co/t/jar-hell-es1engineer-training-lab-2/271028/3 "2021-05-21T03:01:42Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
