# JAVA failed; error='Cannot allocate memory'

**URL:** <https://discuss.elastic.co/t/java-failed-error-cannot-allocate-memory/187340>\
**Category:** Elasticsearch\
**Created:** [June 25, 2019, 1:20pm UTC](https://discuss.elastic.co/t/java-failed-error-cannot-allocate-memory/187340 "2019-06-25T13:20:24Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![Deep\_Manavadaria](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/deep_manavadaria/32/48736_2.png) [@Deep\_Manavadaria](https://discuss.elastic.co/u/Deep_Manavadaria)\
**Post date:** [June 25, 2019, 1:20pm UTC](https://discuss.elastic.co/t/java-failed-error-cannot-allocate-memory/187340/1 "2019-06-25T13:20:24Z")

</div>

I tried to start ES using command **sudo -i service elasticsearch start**

_Got an error_

# sudo -i service elasticsearch start

Starting elasticsearch: warning: Falling back to java on path. This behavior is deprecated. Specify JAVA\_HOME  
OpenJDK 64-Bit Server VM warning: If the number of processors is expected to increase from one, then you should configure the number of parallel GC threads appropriately using -XX:ParallelGCThreads=N  
OpenJDK 64-Bit Server VM warning: INFO: os::commit\_memory(0x00000000c5330000, 986513408, 0) failed; error='Cannot allocate memory' (errno=12)

# 

# There is insufficient memory for the Java Runtime Environment to continue.

# Native memory allocation (mmap) failed to map 986513408 bytes for committing reserved memory.

# An error report file with more information is saved as:

# /var/log/elasticsearch/hs\_err\_pid30097.log

```
                                                       [FAILED]

```

I am using Amazon Linux, Java 1.8, EC 6.x

Anyone can help me?

---

<div class="post-metadata">

**Author:** ![EldrosKandar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/eldroskandar/32/33188_2.png) [@EldrosKandar](https://discuss.elastic.co/u/EldrosKandar)\
**Post date:** [June 26, 2019, 9:20am UTC](https://discuss.elastic.co/t/java-failed-error-cannot-allocate-memory/187340/2 "2019-06-26T09:20:18Z")

</div>

How many RAM does your server have available? How much heap did you allocate for Elasticsearch in jvm.options?

---

<div class="post-metadata">

**Author:** ![Deep\_Manavadaria](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/deep_manavadaria/32/48736_2.png) [@Deep\_Manavadaria](https://discuss.elastic.co/u/Deep_Manavadaria)\
**Post date:** [June 28, 2019, 4:32pm UTC](https://discuss.elastic.co/t/java-failed-error-cannot-allocate-memory/187340/3 "2019-06-28T16:32:01Z")

</div>

![2019-06-28_1229](https://us1.discourse-cdn.com/elastic/original/3X/f/3/f37bd6818e76fd2edc409b811989ce8cceb878cb.png)

---

<div class="post-metadata">

**Author:** ![EldrosKandar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/eldroskandar/32/33188_2.png) [@EldrosKandar](https://discuss.elastic.co/u/EldrosKandar)\
**Post date:** [July 1, 2019, 7:01am UTC](https://discuss.elastic.co/t/java-failed-error-cannot-allocate-memory/187340/4 "2019-07-01T07:01:46Z")

</div>

With which option did you use the `free` command?

Also what about my question on the heap allocated in `/etc/elasticsearch/jvm.options`?

---

<div class="post-metadata">

**Author:** ![Deep\_Manavadaria](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/deep_manavadaria/32/48736_2.png) [@Deep\_Manavadaria](https://discuss.elastic.co/u/Deep_Manavadaria)\
**Post date:** [July 16, 2019, 6:51am UTC](https://discuss.elastic.co/t/java-failed-error-cannot-allocate-memory/187340/5 "2019-07-16T06:51:41Z")

</div>

Hi EldrosKandar

Thanks for your replay, I apologized for the late replay now It's solved, I just upgrade Instance memory and now its work fine.

The latest version of Elastic Search not supported AWS t2.micro.

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [July 16, 2019, 8:14am UTC](https://discuss.elastic.co/t/java-failed-error-cannot-allocate-memory/187340/6 "2019-07-16T08:14:13Z")

</div>

If you want a cheap and quick solution, you can have a look at [cloud.elastic.co](http://cloud.elastic.co). It starts at $17 per month IIRC.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 13, 2019, 8:14am UTC](https://discuss.elastic.co/t/java-failed-error-cannot-allocate-memory/187340/7 "2019-08-13T08:14:20Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
