# Java fatal error with elasticsearch and kibana

**URL:** https://discuss.elastic.co/t/java-fatal-error-with-elasticsearch-and-kibana/48721
**Category:** Elasticsearch
**Created:** [April 28, 2016, 6:01pm UTC](https://discuss.elastic.co/t/java-fatal-error-with-elasticsearch-and-kibana/48721 "2016-04-28T18:01:59Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![Zach\_Lewis](https://avatars.discourse-cdn.com/v4/letter/z/ba8739/32.png) [@Zach\_Lewis](https://discuss.elastic.co/u/Zach_Lewis)
#### Post date: [April 28, 2016, 6:02pm UTC](https://discuss.elastic.co/t/java-fatal-error-with-elasticsearch-and-kibana/48721/1 "2016-04-28T18:02:00Z")

</div>

I'm setting up the elk for the first time so it hasnt worked yet. I start up elasticsearch with no issues but when kibana starts up it crashes java at the same point every time. It looks like it is once the kibana index starts. Any ideas what could cause this?

Current setup on raspberry pi 2:  
arch linux os:  
linux alarmpi 4.1.20-3-ARCH #1 SMP Wed Mar 23 19:01:10 MDT 2016 armv7l GNU/Linux  
Java:  
jdk7-openjdk 7.u99\_2.6.5-1  
jre7-openjdk 7.u99\_2.6.5-1  
jre7-openjdk-headless 7.u99\_2.6.5-1  
elk:  
elasticsearch-2.3.1  
kibana-4.5.0-linux-x86  
logstash-2.3.2

Here's the error I'm getting

> 2016-04-28 17:40:46,582][INFO][node] [Coachwhip] starting ...  
> [2016-04-28 17:40:47,457][INFO][transport] [Coachwhip] publish\_address {127.0.0.1:9300}, bound\_addresses {127.0.0.1:9300}, {[::1]:9300}  
> [2016-04-28 17:40:47,507][INFO][discovery] [Coachwhip] elasticsearch/TWVnZ-xpQNKcAVIQ5tod\_Q  
> (node:31526) fs: re-evaluating native module sources is not supported. If you are using the graceful-fs module, please update it to a more recent version.  
> [2016-04-28 17:40:50,817][INFO][cluster.service] [Coachwhip] new\_master {Coachwhip}{TWVnZ-xpQNKcAVIQ5tod\_Q}{127.0.0.1}{127.0.0.1:9300}, reason: zen-disco-join(elected\_as\_master, [0] joins received)  
> [2016-04-28 17:40:50,931][INFO][http] [Coachwhip] publish\_address {127.0.0.1:9200}, bound\_addresses {127.0.0.1:9200}, {[::1]:9200}  
> [2016-04-28 17:40:50,933][INFO][node] [Coachwhip] started  
> [2016-04-28 17:40:51,288][INFO][gateway] [Coachwhip] recovered [1] indices into cluster\_state  
> [2016-04-28 17:40:54,573][INFO][cluster.routing.allocation] [Coachwhip] Cluster health status changed from [RED] to [YELLOW] (reason: [shards started [[.kibana][0]] ...]).  
> log [17:41:00.448] [info][status][plugin:kibana] Status changed from uninitialized to green - Ready  
> log [17:41:00.674] [info][status][plugin:elasticsearch] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
> log [17:41:00.836] [info][status][plugin:kbn\_vislib\_vis\_types] Status changed from uninitialized to green - Ready  
> log [17:41:00.865] [info][status][plugin:markdown\_vis] Status changed from uninitialized to green - Ready  
> log [17:41:00.891] [info][status][plugin:metric\_vis] Status changed from uninitialized to green - Ready  
> log [17:41:00.914] [info][status][plugin:spyModes] Status changed from uninitialized to green - Ready  
> log [17:41:00.936] [info][status][plugin:statusPage] Status changed from uninitialized to green - Ready  
> log [17:41:00.962] [info][status][plugin:table\_vis] Status changed from uninitialized to green - Ready  
> log [17:41:01.020] [info][listening] Server running at [http://0.0.0.0:5601](http://0.0.0.0:5601)  
> log [17:41:01.435] [info][status][plugin:elasticsearch] Status changed from yellow to green - Kibana index ready
> 
> # 
> 
> # A fatal error has been detected by the Java Runtime Environment:
> 
> # 
> 
> # Internal Error (cppInterpreter\_arm.S:2625), pid=31490, tid=620602480
> 
> # fatal error: \*\*\* Unimplemented opcode: 232 =

> # 
> 
> # JRE version: OpenJDK Runtime Environment (7.0\_99) (build 1.7.0\_99-b00)
> 
> # Java VM: OpenJDK Zero VM (24.95-b01 mixed mode linux-arm )
> 
> # Derivative: IcedTea 2.6.5
> 
> # Distribution: Custom build (Fri Apr 1 06:35:21 MDT 2016)
> 
> # Core dump written. Default location: /usr/share/elasticsearch/logs/core or core.31490
> 
> # 
> 
> # An error report file with more information is saved as:
> 
> # /usr/share/elasticsearch/logs/hs\_err\_pid31490.log
> 
> # 
> 
> # If you would like to submit a bug report, please include
> 
> # instructions on how to reproduce the bug and visit:
> 
> # [http://icedtea.classpath.org/bugzilla](http://icedtea.classpath.org/bugzilla)
> 
> #

---

<div class="post-metadata">

### Author: ![danielmitterdorfer](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/danielmitterdorfer/32/110510_2.png) [@danielmitterdorfer](https://discuss.elastic.co/u/danielmitterdorfer)
#### Post date: [May 2, 2016, 7:07am UTC](https://discuss.elastic.co/t/java-fatal-error-with-elasticsearch-and-kibana/48721/2 "2016-05-02T07:07:20Z")

</div>

Hi,

this already came up earlier: [openJDK on ARM crashes Elastic](https://discuss.elastic.co/t/openjdk-on-arm-crashes-elastic/27283)

The problem is that your JVM implementation does not know what to do with a specific bytecode instruction (opcode 232). The funny thing is that the [JVM specification](http://docs.oracle.com/javase/specs/jvms/se7/html/jvms-6.html#jvms-6.5) does not define such an opcode so I guess bytecode parsing already tripped earlier (although this is really just a wild guess). You should either ask in an Icedtea forum or file a bug at the Icedtea bugzilla.

Daniel

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 5, 2017, 10:54pm UTC](https://discuss.elastic.co/t/java-fatal-error-with-elasticsearch-and-kibana/48721/3 "2017-07-05T22:54:51Z")

</div>


