# Java HotSpot(TM) 64-Bit Server VM warning: Cannot open file logs/gc.log due to No such file or directory

**URL:** <https://discuss.elastic.co/t/java-hotspot-tm-64-bit-server-vm-warning-cannot-open-file-logs-gc-log-due-to-no-such-file-or-directory/136250>\
**Category:** Elasticsearch\
**Created:** [June 18, 2018, 7:22am UTC](https://discuss.elastic.co/t/java-hotspot-tm-64-bit-server-vm-warning-cannot-open-file-logs-gc-log-due-to-no-such-file-or-directory/136250 "2018-06-18T07:22:09Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Yong\_Rhee](https://avatars.discourse-cdn.com/v4/letter/y/aeb1de/32.png) [@Yong\_Rhee](https://discuss.elastic.co/u/Yong_Rhee)\
**Post date:** [June 18, 2018, 7:22am UTC](https://discuss.elastic.co/t/java-hotspot-tm-64-bit-server-vm-warning-cannot-open-file-logs-gc-log-due-to-no-such-file-or-directory/136250/1 "2018-06-18T07:22:09Z")

</div>

I re-installed elasticsearch but still the previous node is running.  
How do I disconnect and delete previous one?  
This is a Window machine

```
PS C:\Program Files\Elastic\Elasticsearch\6.3.0> .\bin\elasticsearch.exe
[2018-06-18T16:06:56,311][INFO][o.e.n.Node] [DESKTOP-C93E9FL] initializing ...
[2018-06-18T16:06:56,334][WARN][o.e.b.ElasticsearchUncaughtExceptionHandler] [DESKTOP-C93E9FL] uncaught exception in thread [main]
org.elasticsearch.bootstrap.StartupException: java.lang.IllegalStateException: failed to obtain node locks, tried [[C:\ProgramData\Elastic\Elasticsearch\da
ta\elasticsearch]] with lock id [0]; maybe these locations are not writable or multiple nodes were started without increasing [node.max_local_storage_nodes
] (was [1])?
	at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:140) ~[elasticsearch-6.3.0.jar:6.3.0]
	at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:127) ~[elasticsearch-6.3.0.jar:6.3.0]
	at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) ~[elasticsearch-6.3.0.jar:6.3.0]
	at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124) ~[elasticsearch-cli-6.3.0.jar:6.3.0]
	at org.elasticsearch.cli.Command.main(Command.java:90) ~[elasticsearch-cli-6.3.0.jar:6.3.0]
	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:93) ~[elasticsearch-6.3.0.jar:6.3.0]
	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:86) ~[elasticsearch-6.3.0.jar:6.3.0]
Caused by: java.lang.IllegalStateException: failed to obtain node locks, tried [[C:\ProgramData\Elastic\Elasticsearch\data\elasticsearch]] with lock id [0]
; maybe these locations are not writable or multiple nodes were started without increasing [node.max_local_storage_nodes] (was [1])?
	at org.elasticsearch.env.NodeEnvironment.<init>(NodeEnvironment.java:243) ~[elasticsearch-6.3.0.jar:6.3.0]
	at org.elasticsearch.node.Node.<init>(Node.java:270) ~[elasticsearch-6.3.0.jar:6.3.0]
	at org.elasticsearch.node.Node.<init>(Node.java:252) ~[elasticsearch-6.3.0.jar:6.3.0]
	at org.elasticsearch.bootstrap.Bootstrap$5.<init>(Bootstrap.java:213) ~[elasticsearch-6.3.0.jar:6.3.0]
	at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:213) ~[elasticsearch-6.3.0.jar:6.3.0]
	at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:326) ~[elasticsearch-6.3.0.jar:6.3.0]
	at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:136) ~[elasticsearch-6.3.0.jar:6.3.0]
	... 6 more
.\bin\elasticsearch.exe : Java HotSpot(TM) 64-Bit Server VM warning: Cannot open file logs/gc.log due to No such file or directory
所在位置 行:1 字符: 1
+ .\bin\elasticsearch.exe
+ ~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo : NotSpecified: (Java HotSpot(TM...le or directory:String) [], RemoteException
    + FullyQualifiedErrorId : NativeCommandError
```

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 16, 2018, 7:22am UTC](https://discuss.elastic.co/t/java-hotspot-tm-64-bit-server-vm-warning-cannot-open-file-logs-gc-log-due-to-no-such-file-or-directory/136250/2 "2018-07-16T07:22:09Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
