# java.io.IOException: failed to obtain in-memory shard lock

**URL:** https://discuss.elastic.co/t/java-io-ioexception-failed-to-obtain-in-memory-shard-lock/147375
**Category:** Elasticsearch
**Created:** [September 5, 2018, 10:52am UTC](https://discuss.elastic.co/t/java-io-ioexception-failed-to-obtain-in-memory-shard-lock/147375 "2018-09-05T10:52:40Z")
**Posts on this page:** 16
**Page:** 1

<div class="post-metadata">

### Author: ![Priya\_Prabhakar](https://avatars.discourse-cdn.com/v4/letter/p/e9c0ed/32.png) [@Priya\_Prabhakar](https://discuss.elastic.co/u/Priya_Prabhakar)
#### Post date: [September 5, 2018, 10:52am UTC](https://discuss.elastic.co/t/java-io-ioexception-failed-to-obtain-in-memory-shard-lock/147375/1 "2018-09-05T10:52:40Z")

</div>

We are intermittently getting the below error in elasticsearch logs. It gets this error after some time, it will be back.

elasticsearch version - "6.3.2"

Real concern in the log

- marking and sending shard failed due to [failed to create shard]
- java.io.IOException: failed to obtain in-memory shard lock
- [70]: failed to obtain shard lock

I have gone through the related blogs which is mentioning this.  
so where I need help

1. Why "shard lock" is happening?
2. Is there any data loss when this happens
3. How to track why it is happening. Any command or any suggestion on this so that I get more details on this

---

<div class="post-metadata">

### Author: ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)
#### Post date: [September 5, 2018, 10:55am UTC](https://discuss.elastic.co/t/java-io-ioexception-failed-to-obtain-in-memory-shard-lock/147375/2 "2018-09-05T10:55:43Z")

</div>

What kind of storage/disk are you using for Elasticsearch?

---

<div class="post-metadata">

### Author: ![Priya\_Prabhakar](https://avatars.discourse-cdn.com/v4/letter/p/e9c0ed/32.png) [@Priya\_Prabhakar](https://discuss.elastic.co/u/Priya_Prabhakar)
#### Post date: [September 5, 2018, 10:56am UTC](https://discuss.elastic.co/t/java-io-ioexception-failed-to-obtain-in-memory-shard-lock/147375/3 "2018-09-05T10:56:08Z")

</div>

We are using RAID0

---

<div class="post-metadata">

### Author: ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)
#### Post date: [September 5, 2018, 11:21am UTC](https://discuss.elastic.co/t/java-io-ioexception-failed-to-obtain-in-memory-shard-lock/147375/4 "2018-09-05T11:21:03Z")

</div>

Local SSDs? Spinning disks?

---

<div class="post-metadata">

### Author: ![Priya\_Prabhakar](https://avatars.discourse-cdn.com/v4/letter/p/e9c0ed/32.png) [@Priya\_Prabhakar](https://discuss.elastic.co/u/Priya_Prabhakar)
#### Post date: [September 6, 2018, 3:16am UTC](https://discuss.elastic.co/t/java-io-ioexception-failed-to-obtain-in-memory-shard-lock/147375/5 "2018-09-06T03:16:55Z")

</div>

Thanks Christian. It is SSD

---

<div class="post-metadata">

### Author: ![Priya\_Prabhakar](https://avatars.discourse-cdn.com/v4/letter/p/e9c0ed/32.png) [@Priya\_Prabhakar](https://discuss.elastic.co/u/Priya_Prabhakar)
#### Post date: [September 6, 2018, 6:30am UTC](https://discuss.elastic.co/t/java-io-ioexception-failed-to-obtain-in-memory-shard-lock/147375/6 "2018-09-06T06:30:28Z")

</div>

@Christian_Dahlqvist Let me know if you need any more details

---

<div class="post-metadata">

### Author: ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)
#### Post date: [September 6, 2018, 6:39am UTC](https://discuss.elastic.co/t/java-io-ioexception-failed-to-obtain-in-memory-shard-lock/147375/7 "2018-09-06T06:39:54Z")

</div>

If you have local SSDs I am not sure what could be causing this. What OS and JVM are you using? What does your cluster setup and configuration look like?

---

<div class="post-metadata">

### Author: ![Priya\_Prabhakar](https://avatars.discourse-cdn.com/v4/letter/p/e9c0ed/32.png) [@Priya\_Prabhakar](https://discuss.elastic.co/u/Priya_Prabhakar)
#### Post date: [September 6, 2018, 6:48am UTC](https://discuss.elastic.co/t/java-io-ioexception-failed-to-obtain-in-memory-shard-lock/147375/8 "2018-09-06T06:48:57Z")

</div>

OS:  
DISTRIB\_ID=Ubuntu  
DISTRIB\_RELEASE=14.04  
DISTRIB\_CODENAME=trusty  
DISTRIB\_DESCRIPTION="Ubuntu 14.04.5 LTS"

JVM:  
openjdk version "1.8.0\_171"  
OpenJDK Runtime Environment (build 1.8.0\_171-8u171-b11-2~14.04-b11)  
OpenJDK 64-Bit Server VM (build 25.171-b11, mixed mode)

Cluster setup:  
6 Master-  
189 datanodes  
18 ingest nodes and  
3 co-ordinators

---

<div class="post-metadata">

### Author: ![Priya\_Prabhakar](https://avatars.discourse-cdn.com/v4/letter/p/e9c0ed/32.png) [@Priya\_Prabhakar](https://discuss.elastic.co/u/Priya_Prabhakar)
#### Post date: [September 7, 2018, 2:47am UTC](https://discuss.elastic.co/t/java-io-ioexception-failed-to-obtain-in-memory-shard-lock/147375/9 "2018-09-07T02:47:29Z")

</div>

Hope the above info helps.

Can please share what is the usual scenarios where the chances of "shard lock" are high or can be the root cause. Anything you want to suggest how to analyse or find the root cause or how to tackle "shard lock" situation.

Or any best practice that you want to share to avoid such situation

---

<div class="post-metadata">

### Author: ![Priya\_Prabhakar](https://avatars.discourse-cdn.com/v4/letter/p/e9c0ed/32.png) [@Priya\_Prabhakar](https://discuss.elastic.co/u/Priya_Prabhakar)
#### Post date: [September 10, 2018, 3:26am UTC](https://discuss.elastic.co/t/java-io-ioexception-failed-to-obtain-in-memory-shard-lock/147375/10 "2018-09-10T03:26:12Z")

</div>

@Christian_Dahlqvist any help in this case?

---

<div class="post-metadata">

### Author: ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)
#### Post date: [September 10, 2018, 5:34am UTC](https://discuss.elastic.co/t/java-io-ioexception-failed-to-obtain-in-memory-shard-lock/147375/11 "2018-09-10T05:34:59Z")

</div>

I have not come across this before, but did look through issues on the Elasticsearch GitHub repo and found [this](https://github.com/elastic/elasticsearch/issues/23199). It does however relate to older versions. It may be worthwhile looking through this and see if any of the potential causes apply to your cluster. If not, I would recommend you open a new issue with as much information about your cluster and work load as possible.

---

<div class="post-metadata">

### Author: ![Priya\_Prabhakar](https://avatars.discourse-cdn.com/v4/letter/p/e9c0ed/32.png) [@Priya\_Prabhakar](https://discuss.elastic.co/u/Priya_Prabhakar)
#### Post date: [September 14, 2018, 5:17am UTC](https://discuss.elastic.co/t/java-io-ioexception-failed-to-obtain-in-memory-shard-lock/147375/12 "2018-09-14T05:17:01Z")

</div>

Thanks @Christian_Dahlqvist. The error didn't reoccur. Will raise the ticket if find one

---

<div class="post-metadata">

### Author: ![hzarrabi](https://avatars.discourse-cdn.com/v4/letter/h/f9ae1b/32.png) [@hzarrabi](https://discuss.elastic.co/u/hzarrabi)
#### Post date: [September 22, 2018, 10:19am UTC](https://discuss.elastic.co/t/java-io-ioexception-failed-to-obtain-in-memory-shard-lock/147375/13 "2018-09-22T10:19:32Z")

</div>

Sometimes when your are out of memory elasticsearch is blocked because it can't allocate shards.

---

<div class="post-metadata">

### Author: ![Priya\_Prabhakar](https://avatars.discourse-cdn.com/v4/letter/p/e9c0ed/32.png) [@Priya\_Prabhakar](https://discuss.elastic.co/u/Priya_Prabhakar)
#### Post date: [September 24, 2018, 6:58am UTC](https://discuss.elastic.co/t/java-io-ioexception-failed-to-obtain-in-memory-shard-lock/147375/14 "2018-09-24T06:58:18Z")

</div>

@hzarrabi for answering. Still unable to locate what caused the issue.

---

<div class="post-metadata">

### Author: ![hzarrabi](https://avatars.discourse-cdn.com/v4/letter/h/f9ae1b/32.png) [@hzarrabi](https://discuss.elastic.co/u/hzarrabi)
#### Post date: [September 24, 2018, 2:06pm UTC](https://discuss.elastic.co/t/java-io-ioexception-failed-to-obtain-in-memory-shard-lock/147375/15 "2018-09-24T14:06:44Z")

</div>

is your elasticsearch responding by http:

[http://ipaddress:9200](http://ipaddress:9200)  
if yes, do you have any indexes in red status. you can see by sending from any browser to your elastic server :  
[http://ipaddress:9200/\_cat/indices?v&h=host,creation.date.string,index,health,status&s=creation.date](http://ipaddress:9200/_cat/indices?v&h=host,creation.date.string,index,health,status&s=creation.date)

if you have in red, in my case I became to resove it by deleting some red indexes from linux command line :  
sudo curl XDELETE [http://ipaddress:9200/\_cat/](http://ipaddress:9200/_cat/)\<indexe\_name\>

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [October 22, 2018, 2:06pm UTC](https://discuss.elastic.co/t/java-io-ioexception-failed-to-obtain-in-memory-shard-lock/147375/16 "2018-10-22T14:06:48Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
